Issue 6180 - Formating of Date
Summary: Formating of Date
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: PC Windows XP
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords: oooqa
: 6181 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-06-27 14:34 UTC by Unknown
Modified: 2004-06-15 00:56 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-06-27 14:34:52 UTC
Help file says to format Date one should go to Format - Date.  However this 
entry does not appear under "Format" on the toolbar.  I want to be able to 
change the built in date format from (example) "27/06/02" to "Thursday 26 June 
2002".
Comment 1 aschrage 2002-06-27 14:44:53 UTC
*** Issue 6181 has been marked as a duplicate of this issue. ***
Comment 2 prgmgr 2002-07-14 20:38:29 UTC
Thanks for posting James.

User would like the option to change the default date format used 
when clicking on Insert | Fields | Date.
Comment 3 stefan.baltzer 2002-11-28 13:05:27 UTC
Reassigned to CJ.
Comment 4 christian.jansen 2003-03-24 07:55:32 UTC
Reassiged to Bettina.
Comment 5 stp 2004-01-31 07:49:31 UTC
Please set target milestone.
Comment 6 kelvine 2004-06-14 05:27:07 UTC
Hi,

I've noticed this issue appear quite often in the users mailing list.

Another scenario is where people wish to conform to the YYYY-MM-DD standard 
because this is their organisation's standard whilst the country standard may 
be MM-DD-YYYY.

The default date can be set in Calc (using templates), but there does not 
appear to be such a feature with Writer.

The ability to set the default date in Writer IMHO is a basic requirement. It 
is not a major issue, just an inconvenience. 

In MS Word this is very easy to do.

Just thought I would provide some feedback.
Comment 7 lohmaier 2004-06-14 18:56:02 UTC
Use a date format of "DDDD DD MMMM YYYY"
Either choose Insert|Fields -> other, select "Date" from the "Type"-Section on
the "Document"-Tab and in the "Format" section choose "additional formats.." in
the following dialog you can enter the custom format. Once you have added it
using the green "hook", it can be reused from the default list of formats for
the chosen language.

Other possibility is to insert the date field first and then select the field
and choose Edit|Field from the menubar (You can as well double-click the field).

If you really see the need for having an option to set the default format
(instead of using a document template) then please file a seperate issue.

User defined format-codes work, so I close this worksforme.
If you think the help needs improvement, then please file an issue agains
component "documentation", subcomponent "Online Help". Thank you.
Comment 8 lohmaier 2004-06-14 18:57:55 UTC
closing issue. Feel free to reopen if previous comment doesn't solve your problem.
Comment 9 kelvine 2004-06-15 00:56:07 UTC
Hi,

Raised the following issue as suggested.

http://www.openoffice.org/issues/show_bug.cgi?id=30216

Thanks

Kelvin