Issue 61949 - Date values shifted by 2 days on table import via copy & paste
Summary: Date values shifted by 2 days on table import via copy & paste
Status: CLOSED DUPLICATE of issue 62797
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.0.1
Hardware: All Windows, all
: P3 Trivial with 3 votes (vote)
Target Milestone: OOo 2.x
Assignee: ocke.janssen
QA Contact: issues@dba
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-02-12 16:34 UTC by andreschnabel
Modified: 2006-08-01 12:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
sample mdb file (164.00 KB, application/vnd.ms-access)
2006-02-12 16:37 UTC, andreschnabel
no flags Details
resulting .odb file (16.84 KB, application/vnd.sun.xml.base)
2006-02-12 16:39 UTC, andreschnabel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description andreschnabel 2006-02-12 16:34:28 UTC
When a table is mported via drag and drop, date values are shifted by 2 days in OOo.

To reproduce:
- open attached .mdb file with Access
- create a new OOo database (or use the attached example)
- drag table "Test_Date" from Access to OOo's tables area
- check create primary key in the copy table wizard
- import all colums
- set field type for column Datum to Date
- open the imported table and set display format for column Datum do date

-> Colums Datum and Text show different values but should sho the same.

Bug found in 2.0.1 and verified in m156
Comment 1 andreschnabel 2006-02-12 16:37:09 UTC
Created attachment 34088 [details]
sample mdb file
Comment 2 andreschnabel 2006-02-12 16:39:53 UTC
Created attachment 34089 [details]
resulting .odb file
Comment 3 Regina Henschel 2006-03-01 18:39:52 UTC
Also the Import from Calc is broken. It's a severe defect.
Comment 4 Frank Schönheit 2006-03-06 08:29:49 UTC
> Also ...
http://qa.openoffice.org/issue_handling/basic_rules.html#one_per_issue
Comment 5 Regina Henschel 2006-03-06 10:32:51 UTC
I have made 62797 for copy&paste from Calc. But I still think, that the comment
here is right. When I copy from Access97 the clipboard format is RTF. I
therefore tried other sources of rtf. So I found the rtf-clipboard form of Calc
leads to +2 days but also the rtf-clipboard format from WordPad leads to +2 days
and copy&paste from WordViewer too. So my comment is, that it is not a problem
of Access but of pasting from clipboard in rtf-format.
Comment 6 alex.thurgood 2006-05-29 07:59:59 UTC
This problem has also been reported by a French user on the n-l dev list. It 
sounds like the eternal "wrong reference date implementation" issue used by Calc 
and Writer which is not the accepted "database reference date".

Can this not be fixed once and for all, this problem has been plaquing OOo for 
as long as I can remember (i.e. since the code was first released) ? I seem to 
recall that the problem had also occurred in StarOffice 5.2 at one stage, so it 
really isn't new.

See also issues 8801, 22687, 22688, 34666, 24313, and 23878 as examples of the 
continuing recurrence of the problem, which at the time was allegedly fixed. 
Like a bad dream, it keeps coming back to haunt us, and in terms of product 
quality, is very detrimental to all who rely on reliable date calculation.

Alex
Comment 7 christoph.lukasiak 2006-07-04 16:13:49 UTC
clu->oj: your turn
Comment 8 christoph.lukasiak 2006-07-04 16:14:57 UTC
set target
Comment 9 ocke.janssen 2006-07-06 14:33:30 UTC
oj->clu: Could you please test this one in a current release m174 e.g. I
couldn't reproduce it there.
Comment 10 aklaver 2006-07-16 21:05:51 UTC
I see the same issue using OO 2.0.2 with either HSQLDB or Postgres 8.1.4 when
copying from Calc.
Comment 11 christoph.lukasiak 2006-07-19 15:31:24 UTC
clu->oj: still repro in a 680m176
Comment 12 ocke.janssen 2006-08-01 12:57:08 UTC
Isn't repro in a m179 and even msc couldn't repro it in a m176. So I set this
one as duplicate to 62797

*** This issue has been marked as a duplicate of 62797 ***
Comment 13 ocke.janssen 2006-08-01 12:59:58 UTC
.