Issue 62097 - The undo of a style change in "Paragraph Style Dialogue" does not reset the “file is changed†flag
Summary: The undo of a style change in "Paragraph Style Dialogue" does not reset the â...
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.1
Hardware: PC Windows XP
: P5 (lowest) Trivial (vote)
Target Milestone: AOO PleaseHelp
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Blocks: 21502
  Show dependency tree
Reported: 2006-02-15 16:00 UTC by burgesspa
Modified: 2013-02-07 21:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

test description of issue and test data (21.09 KB, application/x-compressed)
2006-02-15 16:03 UTC, burgesspa
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description burgesspa 2006-02-15 16:00:26 UTC
The undo of a style change, when no other edits were made to a document, do not
reset the “file is changed†flag and so closing the file causes the “do you want
to save†message to appear.
Comment 1 burgesspa 2006-02-15 16:03:03 UTC
Created attachment 34189 [details]
test description of issue and test data
Comment 2 michael.ruess 2006-02-15 16:15:02 UTC
Reassigned to ES.
Comment 3 Rainer Bielefeld 2006-02-15 16:37:58 UTC
I checked with "2.0.1 RC5 German version WIN XP: [680m1(Build8990)]" and can not
reproduce the problem. My steps to reproduce the problem:

1. Opened OOo
2. Opened 'aemme_undo-styles-and-save-flag-issue-62097.odt' from WIN EXPLORER
   and read instructions
3. Opened 'test data A.odt'
4. Marked (highlighted) Heading 1 using mouse pointer
5. Changed font for Headin from "Arial" to "Verdana" (no "Vera Mono" on my PC)
   using font pulldown menu
   Save-Symbol (Disk) became active (no longer greyed out) as expected
6. Pressed "undo button"
    Save-Symbol (Disk) became inactive (greyed out again) as expected
7. Pressed 'X'-button for "Close Document"
   Document was closed without any "Do you want to save ..." dialogue.

Made several further tests changing proceeding, always same result, I was not
able to reproduce the problem.
Comment 4 burgesspa 2006-02-15 18:02:27 UTC
You have to change the font defintion of e.g. the paragraph style "Heading 1"
used by a paragraph, and do not directly edit the font of a paragraph, perhaps
that is why you cannot repeat the issue. The paragraphs were included so one can
see whether the changes happen or not.

BTW The fonts are actually called "Bitstream Vera ...", I think these are
standard with OOo.

My soffice.exe file has the version 1.9.8985.500 and is dated 2005-12-15.
When I downloaded and installed 2.0.1 over the previous version, from later
evidence it did not seem to have installed ver. 2.0.1. properly, so I
deinstalled everything concerning OOo from my PC before installing again from
scratch. I believe I do now have version "2.0.1" (despite the version on the
soffic.exe file) because other issues said to be solved in 2.0.1 (against 2.0)
are indeed solved with the version I now have installed.

BTW why isn't the full version number displayed in the help > about box? Let me
know if there is another way to determine the version number of an installtion,
in case that is the problem.
Comment 5 Rainer Bielefeld 2006-02-15 18:55:38 UTC
> You have to change the font ...
Where and how?
Comment 6 Rainer Bielefeld 2006-02-15 19:06:18 UTC
Ah, now I see: 

1. place mousepointer somewhere in "Heading 1" of 'test data A.odt'
2. F11 for "Styles and Formatting"
3. Rightclick on "Heading 1"
5. Modify
6. Select other font and confirm with <ok>
   Heading font will be changed, save button becomes active
7. Press undo button
   as expected: Heading font changes back
   unexpected: save button remains active although no more changes are left.
Comment 7 Rainer Bielefeld 2006-02-15 19:07:12 UTC
That's n specia writer problem, I also saw the same effect in CALC
Comment 8 Rainer Bielefeld 2006-02-15 19:13:37 UTC
I believe this one blocks issue 21502
Comment 9 stefan.baltzer 2006-02-16 16:30:39 UTC
SBA->hbrinkm: Please proceed.
Target set to OOo later.
Comment 10 openoffice 2008-11-24 15:06:57 UTC
ama took over undo