Issue 62226 - spellcheck encounters issues with character ' (used for concatenation of words in french for example)
Summary: spellcheck encounters issues with character ' (used for concatenation of wor...
Status: CLOSED DUPLICATE of issue 64400
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P4 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@lingucomponent
URL:
Keywords: oooqa
: 63240 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-02-17 20:56 UTC by nalimilan
Modified: 2013-02-24 20:43 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Wrong Menu Though Error is Marked (10.32 KB, image/png)
2006-12-12 13:01 UTC, pesala
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description nalimilan 2006-02-17 20:56:45 UTC
Using OOo 2.0 under Debian GNU/Linux Etch, french language, but it may occur
with all languages too.

Words are not recognized when they're composed of two parts separated by '
"d'où" for example is a correct expression, composed of "de" and "où" : OOo
doesn't consider this as two words, nor it knows the whole expression.

In French, the word "de" become "d'" before words beginning by vowels, and even
when it is a person name. So "Antigone" will be a word, and "d'Antigone" will be
another, this requiring two entries in the personal dictionary. Many common
words are know, but they aren't when you add "d'" before.

Thus, OOo corrector should consider "d'", "l'" and other things like this as
separate words.
Comment 1 michael.ruess 2006-02-18 06:52:19 UTC
Reassigned to SBA
Comment 2 lohmaier 2006-03-01 00:38:40 UTC
This is one for lingucomponent.

confirming.

Tried to make the summary more understandable.

Although this might require a grammar-checker or at least a decision between two
conflicting opinions.
(your suggestion would mean that "d'Paris" would not be marked as incorrect)

I think the dictionary should be updated to allow concatenation with d' l', etc.
instead. (reflecting this in the user dictionary is a problem though)

Maybe it is possible to define a prefix rule for words beginning with a vowel -
this still would cause some problems when the first letter is a "h" though...
Comment 3 lohmaier 2006-03-25 16:25:28 UTC
*** Issue 63240 has been marked as a duplicate of this issue. ***
Comment 4 rjbutler 2006-03-26 00:05:21 UTC
I had posted 62340 which has been marked as a duplicate.

In English, adding an apostrophe 's to mark the possessive causes partial
failure to recognise by the spellchecker. If this word is added to the user
dictionary, or marked "Ignore all" the word remains underlined, but when you
right-click on it, only the formatting menu is offered, not a list of
alternative words.

This is on Mandriva 2006, OOo 2.0.2.  The same behaviour is not seen in a
Windows installation of the same release.
Comment 5 stefan.baltzer 2006-04-07 19:51:45 UTC
SBA: I tried a 680_m160 developer build on SUSE Linux 9.3.
I see no problem with the English possessive Apostrophe:
Cuff, cuff's and cuffs are all accepted.

Then I installed the French (France) spell check with "DictOOo.sxw".
In that one, the term "d'où" is accepted, as well as variaous other "d'..." terms.
 
Anyway, the problem I can see is that if you have "Hamlet" added to the
dictionary, you will have to add "d'Hamlet" too.  But this works.

Please comment based on Build 680_m160 or younger, Thank you.
Comment 6 dowdenan 2006-04-09 01:07:35 UTC
Same issues in English (I'm using StarOffice 7u5, have loaded OpenOffice 2.0 but
not yet using.)

You need to add both words, for any new hyphenated word.
  ie. They ate Tex-Mex cuisine that night.
  I added all of: 'Tex' 'Mex' and 'Tex-Mex'  to my dictionary.

This area has other problems with word definition logic.  What is a word (or two
words), and what is a variant of a word?

eg. a new name (not in dictionary)
 ie.  Danni (short for Danielle), or Jacqui (short for Jacqueline)
 (This needs to be added as both: Danni  and  Danni's )

eg. a new word will NOT spellcheck, if at the end of sentence
  ie.  The weather in South Yarra.
  (always fails on 'Yarra' with: 'spellcheck is complete')
  Work-around: add space before '.', spellcheck/add, remove space

There many are other similar variations.  What is not clear is what the 'model'
is, and what defined a 'word boundary'.

A possible solution would be to add 'special' class of dictionary labelled as
for: Names, Places, or Brands.  These are all the prime contenders, and the
words contained in them would be handled with this new 'word' definition.

PS. Let me know if I should retest this under latest / best vesino of OOo.


Comment 7 dowdenan 2006-04-09 07:14:45 UTC
Raised issue of single-word spellcheck, followed by period (/full stop) as:
  Issue 64147
Comment 8 dowdenan 2006-04-09 07:23:29 UTC
I have a draft document describing use of specialized dictionaries for:
 - name (first, other)
 - name (last, fmily name)
 - place (proper name)
 - brand (possible in alt. language)

I have been using dditional dictionaries as follows:
 - @names (ALL)
 - @brand (ALL)
 - @places (ALL)
 - @fiction (ALL)  [ for terms you should not normally use; SciFi, fantasy ]
 - @gutteral (ALL)  [ for terms only used in spoken dialogue ]
Comment 9 rjbutler 2006-05-09 06:35:32 UTC
I have just installed 680m165 on my Linux box, and am pleased to say this
problem appears to have gone. Spell checking is also much faster than in 2.0.2.

 I had to jump through a few hoops with hand-editing Dictionary.lst to get the
en_AU dictionary recognised, but  I will be using this regularly until 2.0.3
comes out I think

Thanks all
Comment 10 jack.warchold 2006-05-12 13:52:11 UTC
set to wfm due to the last comment of rjbutler.

please fell free to reopen if this reoccur in the final release of OOo 2.0.3


Comment 11 jack.warchold 2006-05-12 13:52:37 UTC
wfm -> closing
Comment 12 rjbutler 2006-06-27 03:26:17 UTC
May  I please raise this one again

I now have OOC680_m5 Build-3 (Jun 6) running on Mandriva 2006 and it has
regressed to the old behaviour. Language is set to en_AU

Words with apostrophes remain highlighted even after adding to a user dictionary
or Ignore All, and offering alternatives has become extremely slow.

Comment 13 rjbutler 2006-06-28 02:58:15 UTC
Also tested with OOo_OOC680_m6 and the same behaviour persists
Comment 14 rjbutler 2006-07-04 02:28:17 UTC
Also recurs in 2.0.3 final (680m7 build 9044) on Linux
Comment 15 jack.warchold 2006-07-04 09:26:38 UTC
reopend due rjbutlers last comments

will be tested 
Comment 16 pesala 2006-12-12 13:01:08 UTC
Created attachment 41364 [details]
Wrong Menu Though Error is Marked
Comment 17 pesala 2006-12-12 13:03:45 UTC
When words with apostrophe such as "meditator’s" are added to the dictionary they 
are still flagged as an error, and the wrong menu is shown. 
Comment 18 Rainer Bielefeld 2006-12-24 15:38:28 UTC
Related to issue 65119?
Comment 19 nalimilan 2007-05-04 22:00:17 UTC
Yes, it is likely to. But this is a duplicate, the general bug is Issue 64400 (I
added a reference to this bug there): problems managing dashes - with spellchecker.
Comment 20 stefan.baltzer 2007-06-12 15:54:02 UTC
SBA. Set to duplicate.

*** This issue has been marked as a duplicate of 64400 ***
Comment 21 stefan.baltzer 2007-06-12 15:54:33 UTC
SBA. Closed.