Issue 62340 - Make creation of openoffice.org-desktop-integration.tar.gz more robust
Summary: Make creation of openoffice.org-desktop-integration.tar.gz more robust
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: OOo 2.0.2
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: rt
QA Contact: issues@installation
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-20 15:55 UTC by rt
Modified: 2013-08-07 15:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rt 2006-02-20 15:55:44 UTC
This is a follow-up issue to issue 62302.
On OOB680 m1 somehow 'openoffice.org-mandriva-menus-2.0.2-2.noarch.rpm' wasn't
built in sysui/desktop/mandriva. This error slipped through because in
sysui/desktop/util everything underneath
sysui/unxlngi6.pro/bin/desktop-integration gets packed into one tar archive by 
> tar -C [...]/OOB680/sysui/unxlngi6.pro/bin -cf - desktop-integration/ | gzip >
../../unxlngi6.pro/bin/rpm/openoffice.org-desktop-integration.tar.gz
The other desktop integration rpms (freedesktop, redhat, suse) were present, so
we got a valid tar file and no one noticed that there might be a problem.

Please do
- check how it may happen that one of these rpms silently does not get built. It
initially was not built in OOB680 m1 and even a (compatible) rebuild in m2 did
not create it. Unfortunately I cannot reproduce that scenario any more allthough
I saved the original output tree. Everytime I now do a 'build' there the missing
rpm gets created and added to the tar file.
- evaluate possibilities to check for existence of all needed rpm files before
taring them together. Stop with ERROR in case something is missing.
Comment 1 ivo.hinkelmann 2006-03-17 15:31:41 UTC
a file is now touch on successful rpm pack. If that touch file is missing, an
error messeage occur. This should be a indikator of a dmake -i build ran into 
trouble
Comment 2 ivo.hinkelmann 2006-03-17 17:10:57 UTC
please verify

re-open issue and reassign to rt@openoffice.org
Comment 3 ivo.hinkelmann 2006-03-17 17:11:03 UTC
reassign to rt@openoffice.org
Comment 4 ivo.hinkelmann 2006-03-17 17:11:15 UTC
reset resolution to FIXED
Comment 5 rt 2006-03-21 09:22:16 UTC
Verified (with one slight correction: recipe line for flagfile checking has to
start with '@' to prevent echoing of the command line).
Comment 6 rt 2006-04-25 16:37:38 UTC
Seen on master -> closing