Issue 62362 - insert picture function brings up wrong dialog
Summary: insert picture function brings up wrong dialog
Status: CLOSED DUPLICATE of issue 12891
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0.2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: matthias.mueller-prove
QA Contact: issues@sw
Keywords: oooqa
: 62518 (view as issue list)
Depends on:
Reported: 2006-02-21 00:52 UTC by mjneedles
Modified: 2006-02-24 15:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description mjneedles 2006-02-21 00:52:13 UTC
First noticed by working on a brochure with several inserted photos, anchored
"to page".  I deleted one photo so I could insert another in its place, and
clicked the "from File" icon on the Drawing toolbar. This brought up the Picture
dialog. I pressed escape (to dismiss the dialog), then tried again, with the
same result. I tried it with the same icon on the Insert toolbar, with same
results, then from the Insert menu, with the same results.  This was puzzling,
since nothing seemed to be selected.  I clicked the Picture tab on the Picture
dialog, and saw that another photo was supposedly selected, so I dismissed the
dialog and pressed Esc(ape) to deselect everything, then clicked the "from File"
button again, getting the Insert Picture dialog, as expected.

This is, at least for me, not the desired behavior for this button/menu item. It
is supposed to give the Insert Picture dialog, whether any graphic is selected
or not.  I could not see anything in the online Help to support the observed
behavior.  If I wanted the Picture dialog, I'd just double click the photo.  I
really want the Insert Picture from File function to do what its title says it
Comment 1 Joost Andrae 2006-02-21 11:29:34 UTC
JA: can confirm this. If you select the "from file" button from the picture
toolbar if there is a selection of a picture available then the "format picture"
dialog opens. Maybe the string within the picture toolbar is wrong or the
behavior of the button is wrong. As discussed with OS this behavior seems to be
fairly old and opening the "format picture" dialog at this context is correct.
As the application cannot replace help strings if a different context is called
the help tip shows "from file".

JA->MMP: please evaluate what needs to be done to improve the user experience of
Comment 2 michael.ruess 2006-02-24 08:43:12 UTC
*** Issue 62518 has been marked as a duplicate of this issue. ***
Comment 3 lohmaier 2006-02-24 15:41:26 UTC

*** This issue has been marked as a duplicate of 12891 ***
Comment 4 lohmaier 2006-02-24 15:41:55 UTC
closing duplicate.