Issue 62459 - Ugly font in menus
Summary: Ugly font in menus
Alias: None
Product: Internationalization
Classification: Code
Component: ui (show other issues)
Version: current
Hardware: PC Linux, all
: P3 Trivial with 10 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2006-02-23 07:35 UTC by tuharsky
Modified: 2017-05-20 11:31 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Screenshot from 2.0.2 RC1 (63.18 KB, image/png)
2006-02-23 07:37 UTC, tuharsky
no flags Details
Screenshot from 2.0 (61.04 KB, image/png)
2006-02-23 07:38 UTC, tuharsky
no flags Details
diff -u VCL.xcu.20 VCL.xcu.202rc1 (26.03 KB, text/plain)
2006-02-23 07:48 UTC, tuharsky
no flags Details
Screenshot of normal (not bold) fonts in ooo (menu & options view) (164.67 KB, image/png)
2006-03-11 10:48 UTC, jensrutschmann
no flags Details
When replacing Tahoma with Arial fonts look good (16.36 KB, image/png)
2006-03-19 10:59 UTC, jensrutschmann
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tuharsky 2006-02-23 07:35:44 UTC
In OOo 2.0.2 RC1, there is an ugly font in menus. It's bold, badly anti-aliased,
awful. In 2.0 it wasn't there.
Comment 1 tuharsky 2006-02-23 07:37:55 UTC
Created attachment 34388 [details]
Screenshot from 2.0.2 RC1
Comment 2 tuharsky 2006-02-23 07:38:31 UTC
Created attachment 34389 [details]
Screenshot from 2.0
Comment 3 tuharsky 2006-02-23 07:39:22 UTC
Pavel Janik has adviced to compare share/registry/data/org/VCL.xcu
 files from both versions.
Comment 4 tuharsky 2006-02-23 07:48:21 UTC
Created attachment 34390 [details]
diff -u VCL.xcu.20 VCL.xcu.202rc1
Comment 5 tuharsky 2006-02-23 07:48:41 UTC
I'd nearly forgot I'm using slovak (sk) translation.
Comment 6 pavel 2006-03-10 16:50:25 UTC
After private discussion:

This is user settings problem - works in GNOME, doesn't work in ICEWM. We will
debug it here.

I suggested to compare font path in both environments.
Comment 7 jensrutschmann 2006-03-11 01:37:07 UTC
I have the same problem on my gentoo linux system. 

There is also a discussion about this problem going on in the forum. See here

Besides me at least two other users have the same problem with the fonts (none
of them is the reporter of this issue, as I think).

Additionally, in a german SUSE support forum a user has this problem, too.

I think it is not an error it the system configuration regarding the font paths
because version 2.0.1 worked properly. I did not change anything in my system
configuration or in the openoffice config files.

I have KDE 3.4 and the gtk-engines-qt and gtk-engines-qtpixmap packages
installed. Other GTK application do not have this problem.
Comment 8 epyon9283 2006-03-11 05:03:42 UTC
I am experiencing the same issue on Gentoo in KDE 3.5.1.   
Heres what its looks like on my system:  
Comment 9 jensrutschmann 2006-03-11 10:48:25 UTC
Created attachment 34750 [details]
Screenshot of normal (not bold) fonts in ooo (menu & options view)
Comment 10 llopis 2006-03-11 16:24:24 UTC
*** Issue 62459 has been confirmed by votes. ***
Comment 11 tuharsky 2006-03-13 09:56:01 UTC
Here's output of xset q|grep -A1 Font
Working env. (GNOME):

Font Path:
Font cache:
  hi-mark (KB): 5120  low-mark (KB): 3840  balance (%): 70

Ugly env. (IceWM):

Font Path:
Font cache:
  hi-mark (KB): 5120  low-mark (KB): 3840  balance (%): 70

Comment 12 tuharsky 2006-03-13 10:00:15 UTC
I have also tryed setting the working fontpath in ugly env. using
xset fp= blah blah

However it dosen't hlp.
Comment 13 tuharsky 2006-03-13 10:03:01 UTC
The paths are almost identical however. I checked for the two path's that are
visible in working (GNOME's) env fontpath and not visible in ugly (IceWM's), I
mean the


There is nothing there, except of "fontdir" file with "0" inside.

I assume we can say, that fontpath is NOT the case here.
Comment 14 pavel 2006-03-13 10:09:09 UTC
tuharsky: Yes, now it is clear. Looks like it is window manager dependent ?!

Do you have two machines with the same setup? Can you run OOo from one machine
with working environment with exported DISPLAY to the non-working environment?
And vice-versa?

Adding hdu to the CC:.
Comment 15 tuharsky 2006-03-13 10:13:41 UTC
I can also say, that I worked on 4 systems this weekend, all of them are Debian
Sarge, all of them have IceWM installed.

1 and 2, GNOME works flawlessly, whereas IceWM has ugly bold font with OOo202.

3 is strange -the OOo has totally incorrect font (all diacritics gone) under
IceWM. The machine dosen't have GNOME installed and because of little disk
space, no way to try. I can not say this moment, how the older version of OOo20
behaves -I'll try ASAP (might be, until end of week). I can however say, that I
installed probably all available iso8859-2 fonts, so it's not the case that
there werent any to use for OOo..

4 is strange too -OOo under IceWM works well! I'll not be with the machine this
week anymore.

I took just packages snapshots from the machines, if somebody is of interest (I
haven't watch them for now).

The systelm locales settings could be interesting I think now, as much as th
(non)presence of additional TTF fonts. However I can say, that at least one of
the systems (the one that I ran xset commands on) DOES have TTF fonts installed
and registered by fontpath for X (as even is visible from previous posts).
Comment 16 tuharsky 2006-03-13 10:14:45 UTC
pjanik: I can, providing U tell me how :o)
Comment 17 pavel 2006-03-19 09:46:30 UTC
   > Do you have two machines with the same setup? Can you run OOo from one
   > machine with working environment with exported DISPLAY to the non-working
   > environment? And vice-versa?

How to do it?

Lets mark systems as A and B. To display an application running on system A to
the system B's display run this:

1. Run X11 on B

2. ssh -X user@systemB soffice

3. OOo running on system A will be displayed on system B's X server

Please report results for two cases:

case 1: A is working system, B is nonworking system
case 2: A is nonworking system, B is working system

Comment 18 jensrutschmann 2006-03-19 10:59:52 UTC
Created attachment 35020 [details]
When replacing Tahoma with Arial fonts look good
Comment 19 jensrutschmann 2006-03-19 11:06:47 UTC
When I replace Tahoma with Arial the fonts look good again (see attachment). The
problem seems to be related with the Tahoma font, but I had never problems with
this font in another application.

In the forum discussion it seems that most of the users do also use Tahoma. 
So perhaps this helps you a bit. If it does not the you can send me an email if
I can help you in another way. I have only one linux machine though.
Comment 20 aurorix 2006-03-24 09:56:45 UTC
I can also confirm this bug.  It is related specifically to the Tahoma font, 
which is the system font on my machine.


Tools -> Options... -> -> View

   * Disable "Use system font for user interface"

Tools -> Options... -> -> Fonts

    * Enable "Apply replacement table"
    * Replace "Andale Sans UI" with "Arial"

This is a valid workaround, though Tahoma is still rendered incorrectly in 
documents and the font selection combo-box.  Best to steer clear of it ;)
Comment 21 Marcus 2017-05-20 11:31:21 UTC
Reset assigne to the default "".