Issue 62465 - Some chars like äöü or a long "-" are disapearing when exporting to pdf
Summary: Some chars like äöü or a long "-" are disapearing when exporting to pdf
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOO 2.0 Beta2
Hardware: All Linux, all
: P3 Trivial with 6 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo, oooqa
Depends on:
Reported: 2006-02-23 10:29 UTC by christofarn
Modified: 2017-05-20 11:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

document with german chars (5.25 KB, application/vnd.sun.xml.writer)
2006-02-23 10:30 UTC, christofarn
no flags Details
PDF without the german chars (84.29 KB, application/pdf)
2006-02-23 10:31 UTC, christofarn
no flags Details
Postscript file with the german chars (159.10 KB, application/postscript)
2006-02-23 10:32 UTC, christofarn
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description christofarn 2006-02-23 10:29:13 UTC
If I export a text like "Über Änderungen lässt sich schön streiten" into a pdf,
I get something like " ber  nderungen l sst sich sch n streiten".
This happens, when I use the font "Frutiger". I bought this font originaly from
Adobe. (I bought it to times in a different version to be shure, it's not a
problem of the font.)
Remember: If I print the same document to my postscript printer magicolor 3050
from Minolta, all works fine! If I save a print to magicolor 3050 to disk, I get
a perfekt ps-file. I can convert this file to a correct PDF, using kprinter p.e.
So I don't realiy understand, why the pdf-export from writer doesn't work properly.
I'd realy love to use the smart pdf-export, creating links and all the features
you have implemented!
On you find a openoffice document,
the pdf from an export and the ps from am print to minolta magicolor 3050.
The problem exists for openoffice 1 as well as für openoffice 2 beta, I tried on
the actual ubuntu.
For reproducing the problem, you'll need the font "Frutiger" I can send you in
an email.

Thanks for!

PS: Maybe this issue is the same as No. 55058 "Chinese chars not recognizable
upon PDF export"
Comment 1 christofarn 2006-02-23 10:30:43 UTC
Created attachment 34397 [details]
document with german chars
Comment 2 christofarn 2006-02-23 10:31:24 UTC
Created attachment 34398 [details]
PDF without the german chars
Comment 3 christofarn 2006-02-23 10:32:11 UTC
Created attachment 34399 [details]
Postscript file with the german chars
Comment 4 michael.ruess 2006-02-23 11:07:30 UTC
Reassigned to HI.
Comment 5 lohmaier 2006-03-01 00:13:03 UTC
It must be related to the font or a bug that was fixed long time ago.

Type1 or TrueType fonts work in general and are embedded properly with the
umlauts. And even in the attached PDF (that was generated with OOo 1.1.3 btw),
the text is there (just copy the text to an editor - you'll get the umlauts

Both OOo 1.1.3 as well as 2.0beta are outdated.

Please try with a current version (or with OOo 2.0.2rc)
Comment 6 kpalagin 2007-04-12 19:43:55 UTC
No response from author, resolving as WFM.
Comment 7 kpalagin 2007-04-12 19:44:55 UTC
and closing.
Comment 8 hakre 2008-06-11 00:13:29 UTC
I'd like to see this Issue reopened because the last comment is totally untrue. 
Umlauts do not properly work with PostScript Fonts in OOo PDFs because those 
fonts are not properly embedded in OOo pdfs. That easy this is.
Comment 9 hakre 2008-06-11 00:15:49 UTC
Just checked against 2.4.1 and the Bug is still in.
Comment 10 christofarn 2008-06-12 07:30:53 UTC
Please excuse, that my replay is late.

I tested now with openoffice 2.4.0 - same problem:

The umlauts are visible, if I generate the PDF by printing dialogue, but they
disapear, if I generate the PDF by openoffice, using export as pdf.

I cannot see the problem as caused incorrectible by the font, because the
printing routine generates a perfect PDF.

So I think, there is a problem with the font, because other fonts works
properly. But the problem can be solved by optimising the pdf export in
openoffice, as we see, we can gererate a correct PDF by printing dialogue.

Would you like to have my font to make some tests or can I help by further

Comment 11 lohmaier 2008-07-15 20:42:44 UTC
please send the font - I'm not able to reproduce with the Type1 fonts I have here...
Comment 12 christofarn 2008-07-28 08:46:29 UTC
Thanks for your help! I sent the fonts per email to,
because uploading them on this site seems me to be a problem of rights. The Font
is "Frutiger".
Comment 13 hakre 2008-11-18 09:35:01 UTC
With Version 3.0 still the same pitty image. Tested with an OTF Font with 
Postscript Outlines this time:

Made this because I had problems with the PDF Export and the TTF Font Times New 
Roman in the PDF Export on a Win32 System with 2.latest.stable and 
3.latest.stable having the PDF files ugly display on the italic (in German 
"kursiv") font-variant on Apple Systems (Not filed another Issue, just want to 
see all Fonts embedding working instead).
Comment 14 hakre 2008-11-18 09:36:26 UTC
Can someone from the Devs make a statement which Fonts are really supported 
with built in PDF Support?
Comment 15 dukat 2010-01-02 13:43:14 UTC
I have  the same problem with the Calibri font. If I print a document with
umlauts to a printer, there are no "ö"s printed (but "ä" and "ü" are printed
correctly). When I export the same document as PDF, the "ö" is correctly rendered.

I'm using OpenOffice 3.0.1 on Ubuntu 9.04.

Other people seem to have the same problem with the Purisa font, see here (in
German only):
Comment 16 dukat 2010-01-02 13:44:23 UTC
*** Issue 62465 has been confirmed by votes. ***
Comment 17 Marcus 2017-05-20 11:31:37 UTC
Reset assigne to the default "".