Issue 62596 - If you try to find and replace a leading single quote, it will not find it.
Summary: If you try to find and replace a leading single quote, it will not find it.
Status: CLOSED DUPLICATE of issue 29054
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0
Hardware: PC (x86_64) Linux, all
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-02-27 02:49 UTC by daveqb
Modified: 2010-10-23 15:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description daveqb 2006-02-27 02:49:14 UTC
You can read more information on this issue here 
http://www.oooforum.org/forum/viewtopic.phtml?t=30469&start=15&postdays=0&postorder=asc&highlight=&sid=36d432c9df217226f834b056a09de8eb
To sum it up.  If you try to find and replace a leading single quote, it will
not find it in order to replace it.  You can, however, find a single quote on
its own in a cell.  We have tried a few work arounds with some having success
and others (like me) not.  I tried all that was recommended in the above linked
thread.

This functionality is found to work fine in Microsofts Excel program.

I am using Ver 2.0, both one downloaned off the OOo web site and the 2.0
released from SuSe.
Comment 1 kpalagin 2006-03-11 15:36:35 UTC
I am confirming this.
Leading quote can't be found.
OOo 2.0.2.
Comment 2 lars 2006-03-11 17:45:22 UTC
confirmed with 680_m158 on WinXP Pro SP2
Comment 3 frank 2006-03-13 09:46:44 UTC
Hi,

this Issue is a double to some others. I set the double to Issue 29054 .

Find&Replace with regular expressions enabled under more and search for '.*'
(without quotes) and replace with '&' (without quotes) works as expected and
removes the leading apostrophe.

It's searching for dot star and not '^*' as mentioned in the forum.

Frank

*** This issue has been marked as a duplicate of 29054 ***
Comment 4 frank 2006-03-13 09:47:15 UTC
closed double
Comment 5 terrynorth 2006-03-13 10:22:09 UTC
It may be too late to comment.  .* removes leading apostrophes but does not
remove an apostrophe on it's own.  ^. has the same result on my system.  How
anyone can work either method out from the paltry Help documentation, I do not know.
Comment 6 terrynorth 2007-03-29 02:11:35 UTC
This is not a duplicate of 29054.  That issue concerns the importation of data.

This issue concerns finding and removing the leading apostrophe after
importation.  The software should be able to find a leading apostrophe just as
it can find the apostrophe in any other position in the cell.

In Windows, one can evidently find the leading apostrophe with ^' .  Not so in
Linux.  Even the use of the regular expression ^ should be unnecessary since the
character ' is there and can be found anywhere except at the beginning of text
in a cell.
Comment 7 emersonprado 2010-08-20 18:12:35 UTC
I second the comment from contender. This issue is about searching the
apostrophe and perhaps replacing it, while Issue 29054 deals with how the
apostrophe ends up into the cell (another counterproductive issue IMHO).
May I ask developers to reopen this bug? After reading several others, I
understand the apostrophe isn't in the cell, but is just shown to tell (?) the
user it's seeing text. Not being in the cell, it can't be searched. But an
average user can never tell that - we just see the apostrophe, notice it's a
problem and want to get rid of it.
Maybe the issue will be solved not by changing the search engine behaviour, but
changing the awkward apostrophe thing. Anyway, let's get something moving.
Best regards
Comment 8 ubanmidna 2010-10-23 15:30:12 UTC
Created attachment 72503