Issue 62697 - WW8: import hangs/loops on specific large graphic
Summary: WW8: import hangs/loops on specific large graphic
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 1.1.4
Hardware: PC All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-02 02:54 UTC by alanacv
Modified: 2013-08-07 14:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description alanacv 2006-03-02 02:54:25 UTC
We have got a huge Microsoft Word file with 73 pages, about 28Mbytes. The 
contents are Chinese and some pictures.
We cannot use both OOo1.1.4 and OOo2.0 to open it. The program tried to open it 
and after a long long time, it is still stucking.

With Microsoft word, we can open it within seconds.

If we remove all the pictures inside, about 800kbyte now. Then, it can be opened 
successfully with OOo1.1.4 and 2.0. So, the problem is due to the pictures.

Since the content of this file are private. We would like you to establish a 
Private FTP server for us to submit this file to you for trouble shooting.


Regards,

Alan
Comment 1 michael.ruess 2006-03-02 08:22:25 UTC
That sounds quite interesting. Please send the necessary information to get
access to the document directly to "mru@openoffice.org". Maybe the document can
be sent as attachment when zipped.
Thanks a lot!
Comment 2 alanacv 2006-03-07 03:00:10 UTC
Dear MRU,

I have sent the huge file to you.

Thanks 

Alan
Comment 3 michael.ruess 2006-03-09 14:16:15 UTC
MRU->SJ: I have tracked down the problem of the originally 28 MB large word file
to one graphic inside. But it is still 7 MB large...
I will give you the document "by Hand", please delete it after fixing, the
document is confidential.
Comment 4 thb 2006-03-15 16:53:19 UTC
Taking over...
Comment 5 thb 2006-03-15 16:56:57 UTC
@mru: please create an internal bug and attach the file

@alanacv: this is not fixable in the 2.0.3 timeframe - the problems are
architectural, in that we generate an internal representation for the data,
which performs quite badly for the given input (in fact, the import does not
hang, but runs a loooong time).
Comment 6 alanacv 2006-03-16 04:37:12 UTC
thb: Thanks a lot
Comment 7 Mathias_Bauer 2007-03-20 17:46:07 UTC
The target "3.0" is reserved for special features and their sub tasks. "2.x"
seems to be more appropriate.

Thorsten, can you tell more about this issue? What about changing the target to
2.3? 
Comment 8 Mathias_Bauer 2007-03-20 17:46:23 UTC
The target "3.0" is reserved for special features and their sub tasks. "2.x"
seems to be more appropriate.

Thorsten, can you tell more about this issue? What about changing the target to
2.3? 
Comment 9 thb 2007-03-21 23:44:34 UTC
@mba: as pointed out, without reworking large parts of the internal ways we
handle metafiles this is not fixable. 
Comment 10 thb 2008-06-27 23:59:28 UTC
@sj: please take this one back. I no longer have access to the bugdoc.