Issue 62901 - Importing ISO-8859-15 text file results in incorrect encoding
Summary: Importing ISO-8859-15 text file results in incorrect encoding
Status: CLOSED DUPLICATE of issue 54127
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0.2
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-03-07 23:28 UTC by Andrea Pescetti
Modified: 2006-03-09 06:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2006-03-07 23:28:14 UTC
1. Set the locale, as default in many current GNU/Linux distributions, at UTF-8
(in our tests, it_IT.UTF-8).
2. Open gedit, create a text file containing non ASCII characters.
3. Save the file with encoding ISO-8859-15 (i.e., ISO-8859-1 with Euro), name it
"test.txt", close gedit.
4. Run "file test.txt"; you get "ISO-8859 text".
5. Open "test.txt" with Writer.

Expected:
6. OOo can detect the encoding, or asks the user for the encoding.

Actual:
6. OOo cannot detect the encoding, no dialog appears and squares are shown in
place of the non-ASCII characters.

UTF-8 encoded file are correctly imported. Maybe imported text files are treated
as UTF-8 regardless of their actual encoding.

[Reported by Paolo Pedaletti during Italian QA tests]
Comment 1 Andrea Pescetti 2006-03-07 23:42:19 UTC
I must clarify step 5.

Opening the file through File -> Open and setting "Text Encoded" as type works
(user is correctly asked to specify encoding).

Inserting it through Insert -> File and setting "Text Encoded" as type does not
work (user is not prompted for encoding, and apparently the default UTF-8
encoding is used).

This is a regression wrt 1.1.3.
Comment 2 Regina Henschel 2006-03-08 09:37:01 UTC
Yes "Insert - File" with explicit choose of a filter is still broken. I think,
it is duplicate to issue 50705. But you can workaround it: Open the file via
"File - Open" and set the filetype there. Then copy&paste the text to the right
place.

*** This issue has been marked as a duplicate of 50705 ***
Comment 3 michael.ruess 2006-03-08 09:43:10 UTC
Closing duplicate.
Comment 4 Andrea Pescetti 2006-03-08 21:23:47 UTC
I don't believe this qualifies as a duplicate.

Issue 50705 addresses two problems:
1: (Issue summary) When importing an HTML document as "Text", HTML content is
shown instead of HTML source.
2: (in a comment) When inserting a file as "Text encoded", user is not prompted
for the encoding.

This seems to violate the "One problem, one issue" rule.

But, as long as both problems are fixed, I won't reopen this issue (that was
focused on the second problem) nor complain.
Comment 5 Regina Henschel 2006-03-08 21:49:39 UTC
You are right, I took the wrong number. The correct one is issue 54127.
Comment 6 Regina Henschel 2006-03-08 21:50:51 UTC
You should move your votes. This cannot be done automatically.

*** This issue has been marked as a duplicate of 54127 ***
Comment 7 michael.ruess 2006-03-09 06:53:53 UTC
Closing duplicate.