Issue 63030 - Empty directories not packaged
Summary: Empty directories not packaged
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 680m156
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: OOo 2.0.3
Assignee: obrmac
QA Contact: issues@installation
: 57831 63691 (view as issue list)
Depends on:
Blocks: 56189 57252 62765 67331
  Show dependency tree
Reported: 2006-03-10 18:57 UTC by nospam4obr
Modified: 2006-10-28 21:17 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Part1 of the OSX packagng rework (10.80 KB, patch)
2006-03-19 12:10 UTC, nospam4obr
no flags Details | Diff
Made previous patch apply cleanly on rc4 sources (10.69 KB, patch)
2006-03-20 22:17 UTC, nospam4obr
no flags Details | Diff
build log (1.24 MB, application/octet-stream)
2006-03-23 00:57 UTC, maho.nakata
no flags Details
log at instset_oo (61.63 KB, application/octet-stream)
2006-03-23 00:57 UTC, maho.nakata
no flags Details
V2 of proposed patch (against OOB680 m5) (20.03 KB, patch)
2006-03-25 11:48 UTC, nospam4obr
no flags Details | Diff
(Hopefully) final version of this patch for OOB680m5 (83.21 KB, application/x-gzip)
2006-03-31 22:27 UTC, nospam4obr
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description nospam4obr 2006-03-10 18:57:17 UTC
In scp2/source/ooo/directory_ooo.scp there are a number of directories, which
have Styles = (CREATE) proerty set, but use DosName property for their name.

Unfortunatly the code in solenv/bin/modules/installer/ tests for
HostName property only, which causes empty directories to no longer get packaged.
Comment 1 nospam4obr 2006-03-10 19:15:11 UTC
Potentially the problem is even before
collect_directories_with_create_flag_from_directoryarray function.

However, the following snippet works

Directory gid_Dir_User_Fonts
    ParentID = gid_Dir_User;
    DosName = "fonts";
    HostName = "fonts";

while the same snippet without "HostName" does not.
Comment 2 eric.bachard 2006-03-10 20:10:51 UTC

Thank you for the CC :-)


Mac OS X / gcc-4.0 / XCode 2.1/ m158 + macosxfondu cws. I confirm none of the
three following cases works :

1) using 

2) using 
Styles = (CREATE);

using ..nothing ..

Only add a file (making it not empty) in fonts works ...
Comment 3 eric.bachard 2006-03-12 14:34:32 UTC

Please have a look at

Maybe relevant for this issue.
Comment 4 2006-03-13 10:33:30 UTC
"DosName" is converted to "HostName" by the scp linker. I allowed the usage of
"DosName" because of historical reasons, but the correct syntax is "HostName".
But nevertheless both works, because of the linker par2script in cvs module
solenv. Please verify, that in the script created in scp2 only "HostName" can be
found. If you find "DosName" the script is broken and the linker does not work
correct. I just checked this for Solaris, Linux and Windows and everything works
All installations are working without problems. Using in scp2

Directory gid_Dir_User_Fonts
    ParentID = gid_Dir_User;
    DosName = "fonts";
leads to the creation of an empty folder presets/fonts on all three tested
platforms. On Linux and Solaris the folder is part of the core01 package and in
Windows the folder is explicitely included into the table "CreateFolders" which
is required for the creation of empty folders.

For the tested platforms there are no problems. Please give me some more
information about your platforms.  It sounds, as if there is a problem with the
scp linker.
Comment 5 nospam4obr 2006-03-13 13:24:24 UTC
Obviously I was too fast saying that packaging works with HostName: I only
checked setup_osl.ins, but the install set still doesn't have e.g. presets/fonts.

The real problem is that epm creates empty directories in the .install script
for pkgtype portable, which is not run during .dmg generation.
Comment 6 nospam4obr 2006-03-19 12:09:29 UTC
The following patch changes the packaging process for the drag-and-drop
installation to use the -simple option.

NOTE: the patch does not include any changes to configure yet, to test it one
needs to manually unset PKGFORMAT variable.

Open items:

1) Since this patch also changes the installation structure in scp2 from 

install_root/program etc.


install_root/ etc.

we could easily move the readmes and lincenses directories into the
install_root, where they probably make more sense.

2) Currently the changes in instsetoo_native/util/ are only made for
the openoffice target. Do we want openofficemulti and oosdk also ? BTW:
oolanguagepacks do not make much sense now, since there is no way to install
them currently.

Feedback welcome. 
Comment 7 nospam4obr 2006-03-19 12:10:32 UTC
Created attachment 35021 [details]
Part1 of the OSX packagng rework
Comment 8 jjmckenzie 2006-03-20 10:53:20 UTC

It might also make sense to 'borrow', with permission of course, the image that
is used in the Firefox installation to gentlely remind new users to drag the
.app image to the Applications folder, and place it in the install_root.

Comment 9 nospam4obr 2006-03-20 22:17:13 UTC
Created attachment 35077 [details]
Made previous patch apply cleanly on rc4 sources
Comment 10 maho.nakata 2006-03-23 00:56:17 UTC
build was broken with:
MacOSX Tiger+gcc-4.0
MD5 sum of OOo_2.0.2rc4_060227_src.tar.gz
MD5 (/Volumes/ =
Comment 11 maho.nakata 2006-03-23 00:57:11 UTC
Created attachment 35150 [details]
build log
Comment 12 maho.nakata 2006-03-23 00:57:55 UTC
Created attachment 35151 [details]
log at instset_oo
Comment 13 maho.nakata 2006-03-23 01:01:44 UTC
I unsetenv'ed PKGFORMAT after `source'
(something like that) see the build log for details.
Comment 14 eric.bachard 2006-03-23 11:56:49 UTC
*** Issue 57831 has been marked as a duplicate of this issue. ***
Comment 15 nospam4obr 2006-03-25 11:29:18 UTC
Unfortunatly the first version of the patch caused the office to no longer
start, because the soffice.bin no longer got stripped and so there were
duplicate static instances of the ref-counted UNO types.

The second version of the patch patches to strip on OS X as well. The
patch still doesn't have the configure change in it, so PKGFORMAT must be unset

I am also awaiting a background image for the OOo dmg in the next days.

However, SDK and URE come now as .dmg as well, which was the same amount of work
as creating tar.gz. In the long run, we probably should look into how to make
OSX Frameworks out of them.
Comment 16 nospam4obr 2006-03-25 11:48:31 UTC
Created attachment 35241 [details]
V2 of proposed patch (against OOB680 m5)
Comment 17 jjmckenzie 2006-03-26 14:46:12 UTC
Issue 11409 was the original discussion on moving to an installer vice a
packager.  I am certain there are others that have been closed as OpenOffice
1.1.x never got to the installer/packager stage.  IMHO, issue 56189 should be
closed as WONTFIX as work in that issue will be stopped by this issue.

Comment 18 nospam4obr 2006-03-26 15:26:14 UTC
This issue currenlty blocks issue 57252. The proposed fix is a temporary
solution for the X11 port, but might get re-used with the Aqua port. 
Comment 19 nospam4obr 2006-03-26 15:37:45 UTC
Comment 20 yossy_takeuchi 2006-03-28 03:30:41 UTC
Added CC: to yossy_takeuchi
Comment 21 jjmckenzie 2006-03-28 04:51:13 UTC
Ran build of m161 with v2 patch but did not unset the PKGFORMAT.  Build broke,
as expected, in instset_oo.  Will re-run with PKGFORMAT unset.

Comment 22 moxfox 2006-03-28 11:07:49 UTC

As issue 63630 intends to create a .pkg install for Mac X11, what would be the
best way to proceed, for things related to this bug:

1) Just integrate the current patch and fix the .pkg building in another issue?

2) Create a new patch that does .pkg for OS==MACOSX && GUIBASE==unx, and use the
code in the currect patch (drag&drop install) for OS==MACOSX && GUIBASE==aqua ?

What do you think?
Comment 23 nospam4obr 2006-03-28 11:32:24 UTC
Since this issue blocks macosxfondu, I propose to integrate the patch as is
first. Re-enabling osx as default PKGFORMAT for X11 builds can hopefully be done
easily in configure.
Comment 24 jjmckenzie 2006-03-29 01:39:03 UTC
Also look at 62251.  This may be a duplicate of that bug.

I am going to rerun the build with this patch as the build did not create the
appropriate files for a .pkg or .mpkg installer.

Comment 25 jjmckenzie 2006-03-29 15:40:09 UTC
Removed .pkg issues as this issue addresses the missing empty directory problem 
and does not introduce new functionality as far as installer versus drag and 
drop capabilities.

Comment 26 jjmckenzie 2006-03-30 14:11:05 UTC
Added IZ 62765 as this issue breaks 2.0.2 rc 4's ability to work Wizards 
functionality for producing form letters, agendas, Fax Cover sheets and other 
items that depend on the existance of the empty templates folder.

On a good note, I ran a build of 2.0.2 rc 4 with the proposed v2 patch in place 
and after manually updating the file, the build completed and 
Wizards functionality is restored to the template folder.

I send Oliver a message asking how the PKGFORMAT unset feature was going to be 
incorporated in  If we want to permenantly change the MacOSX 
portable builds, this will be unnecessary.

Comment 27 nospam4obr 2006-03-31 22:27:46 UTC
Created attachment 35435 [details]
(Hopefully) final version of this patch for OOB680m5
Comment 28 nospam4obr 2006-03-31 22:31:40 UTC
Updated the patch to include a background image: please put the files into
instsetoo_native/res manually.

This version of the patch does no longer require to unset PKGFORMAT variable,
the new packaging is triggered by OS == MACOSX && PKGFORMAT == portable now.

Going forward, changing configure not to set PKGFORMAT=portable is still desired.
Comment 29 jjmckenzie 2006-04-03 02:10:48 UTC

Do you have a cws to put this in?  I would like to run a verification build
because the empty directory issue blocks release of 2.0.2

Comment 30 jjmckenzie 2006-04-03 02:15:07 UTC
Recommend that this be installed with 2.0.2.rc5.  We will need another build of
2.0.2 rc for OS X.

Comment 31 nospam4obr 2006-04-03 20:56:54 UTC
I have applied V3 of the patch to CWS macosx20xfixes02 (based on m161).
Comment 32 maho.nakata 2006-04-05 21:57:18 UTC
Now I just started to build with your v3 patch.
where should I place osxdndinstall.png ? (you seem to delete this file for cws_src680_macosx20xfixes02)
how about DS_store files? Can I simply ignore this?
Comment 33 nospam4obr 2006-04-06 07:02:48 UTC

please put both files (osxdndinstall.png _and_ DS_Store) into
instsetoo_native/res directory manually. 

BTW: The files are newly integrated in CWS macosx20xfixes02, which makes them
appear as "deleted" on head/master.
Comment 34 maho.nakata 2006-04-06 07:12:06 UTC
thanks. that's why I cannot figure out why we need these
files! from bonsai, these files are in Attic. Now I stated
to rebuild all from scratch.
Comment 35 maho.nakata 2006-04-06 22:09:34 UTC
full build verified on Tiger (Intel Mac)+gcc-4.0
Comment 36 maho.nakata 2006-04-07 01:56:13 UTC
fix verified on intel Mac+gcc-4.0
(wizard problem is disappeared)
now I started to build release packages.
Huge thanks!!!!
Comment 37 jjmckenzie 2006-04-07 04:59:37 UTC
Since this issue is fixed on MacOSX, does this fix also correct the failure to
correct the missing directories in FreeBSD for 2.0.2 rc 4?

Comment 38 jjmckenzie 2006-04-10 00:57:58 UTC
Issue is verified as fixed in 2.0.2 rc 4.  Release is out to QA.
Comment 39 jjmckenzie 2006-06-07 11:51:53 UTC
*** Issue 63691 has been marked as a duplicate of this issue. ***
Comment 40 nospam4obr 2006-10-18 12:37:58 UTC