Issue 63326 - Poor rendering quality / Anti-aliasing?
Summary: Poor rendering quality / Anti-aliasing?
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: AOO Later
Assignee: Armin Le Grand
QA Contact: issues@framework
URL:
Keywords: oooqa
: 69632 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-03-17 22:39 UTC by webmaster
Modified: 2017-05-20 10:35 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A screenshot of the jagged edges around objects, rather than smooth anti-aliased graphics. (78.83 KB, image/png)
2006-04-15 00:48 UTC, webmaster
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description webmaster 2006-03-17 22:39:49 UTC
Dear OOo Developers,

OpenOffice is becoming quite a potent Office Suite, but there is one thing which
holds its productivity back - Rendering Quality. Often lines outline boxes will
disappear until you scroll down and back up, or sometimes only if you change the
zoom, or curved lines with be extremely jagged (in ANY type of document). Is it
possible that the entire display (including images, word-art and custom shapes)
be anti-aliased? Perhaps this would also speed up Presentation animations, and
almost definately would make them more attractive to look at.

Kind Regards,
Matthew

NOTE: I would not be surprised if there is already an issue open for this, but I
could not find one.
Comment 1 Olaf Felka 2006-03-20 09:40:17 UTC
@ sba: Is this something for you? Any knowledge about this?
Comment 2 stefan.baltzer 2006-04-05 10:53:45 UTC
SBA: There may be SEVERAL issues because you describe SEVERAL different problems.
You talk about anti-aliasing as well as repaint errors...

The basic way of issues "Make everything better" is geting closed.

Please focus on ONE problem and give a reproducible description
One Problem != ONE issue. It only wors this way.

A screenshot and a bugdoc EACH look like the right way for your problems.
Set to Worksforme until further details are given.
Please comment.
Comment 3 webmaster 2006-04-15 00:46:01 UTC
Hmmm... I suppose it was a general bug report, and I cannot really think of
making it simpler. I just wanted all of the workspaces to be anti-aliased. Is
this too general for a bug report?

Kind Regards,
Matthew
Comment 4 webmaster 2006-04-15 00:48:55 UTC
Created attachment 35723 [details]
A screenshot of the jagged edges around objects, rather than smooth anti-aliased graphics.
Comment 5 webmaster 2006-04-15 00:50:50 UTC
Sorry, I thought that I had better make it clear too: the glitch at the bottom
right of the screen was due to another aplication, not OpenOffice.


Kind Regards (again),
Matthew
Comment 6 webmaster 2006-04-17 23:24:37 UTC
I hope you don't mind, but since I have restated the issue in terms of a now
simplified issue, I have reopened the issue.

If I have been wrong to do so, please let me know, and close the bug issue.

Kind Regards,
Matthew
Comment 7 hdu@apache.org 2006-04-25 10:20:50 UTC
HDU->AW: as far as I know you are working on AA for OOo-graphics like polygons
etc. I suggest to track the status of this project in this issue if there is no
other issue for this yet...
Comment 8 lohmaier 2006-06-24 22:59:49 UTC
there are other issues... e.g. issue 28526

Note that with cairo support impress has nice antialiasing during slideshow, but
not while editing. Maybe cairo could be used throughout?
Comment 9 Armin Le Grand 2006-07-27 16:08:26 UTC
AW: We are working in that direction, but it will take a while. THB can tell You
more...
Comment 10 thb 2006-07-27 16:28:21 UTC
guys, you're welcome ;-)

Yes, indeed, there's work underway to have at least Draw/Impress render via
canvas also during edit mode. The foundations for that are lain in CWS aw033,
and yours faithfully is currently prototyping a canvas backend for that.
Timeline: no idea, something around OOo3. The remaining apps (calc, writer,
math): after Draw/Impress is done, so, after OOo3.
Comment 11 webmaster 2006-07-28 06:56:18 UTC
Thankyou very much, THB! I have eagerly awaited work on this for a long while,
and am delighted that we will be seeing it before long.

I understand the focus on draw and impress, but would very much like to see it
ASAP in the other modules also.

Yay!

Kind Regards,
Matthew
Comment 12 gleppert 2009-03-13 10:49:27 UTC
Isn't this issue being fixed in OpenOffice 3.1? 
Im mean CWS aw033 and the subsequent CWS that aim to introduce AA in the
OpenOffice Canvas...
Comment 13 Armin Le Grand 2009-03-16 16:09:21 UTC
AW: Not necessarily. Canvas (used in presentation mode) and DrawingLayer (used
in EditMode) are two different things (there are already plans to put those
together, be assured :-)). HTH!
Comment 14 stuttgarter 2010-03-24 13:22:37 UTC
added me to CC
Comment 15 thb 2012-07-13 20:47:21 UTC
Reset to default bug assignee.
Comment 16 Armin Le Grand 2012-07-19 09:57:09 UTC
ALG: Taking ownership
Comment 17 Armin Le Grand 2012-07-25 11:55:15 UTC
ALG: AA is done since a while, closing.
Comment 18 Edwin Sharp 2014-02-27 13:33:48 UTC
*** Issue 69632 has been marked as a duplicate of this issue. ***