Issue 63395 - Change default bullet characters, font and size
Summary: Change default bullet characters, font and size
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 58398 58729 60263 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-03-20 14:22 UTC by frank.loehmann
Modified: 2013-08-07 14:43 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Word default bullets demo doc (19.50 KB, application/msword)
2006-03-22 17:35 UTC, frank.loehmann
no flags Details
Proposal for new default bullets in OOo (12.81 KB, application/vnd.oasis.opendocument.text)
2008-04-08 14:39 UTC, frank.loehmann
no flags Details
pdf document showing former default bullet characters (20.06 KB, application/pdf)
2008-06-30 08:27 UTC, Oliver-Rainer Wittmann
no flags Details
pdf document showing new default bullet characters (24.40 KB, application/pdf)
2008-06-30 08:28 UTC, Oliver-Rainer Wittmann
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description frank.loehmann 2006-03-20 14:22:16 UTC
Change bullets to characters used by competition and change Bullet character
style to not assign any size to bullets.
Comment 1 frank.loehmann 2006-03-20 16:03:41 UTC
Issue #59997# is related to this one, but uses old original bullets introduced
for OOo 2.0.0
Comment 2 frank.loehmann 2006-03-22 17:35:32 UTC
Created attachment 35141 [details]
Word default bullets demo doc
Comment 3 frank.loehmann 2006-04-05 13:30:29 UTC
Change target to PU3. Change not possible for PU3 within timeframe due to lack
of resources.
Comment 4 frank.loehmann 2006-06-12 13:06:58 UTC
No ressources for U4 -> new target 2.x
Comment 5 frank.loehmann 2007-09-06 07:17:28 UTC
Set target.
Comment 6 frank.loehmann 2008-02-07 10:24:44 UTC
*** Issue 58729 has been marked as a duplicate of this issue. ***
Comment 7 frank.loehmann 2008-03-31 11:47:56 UTC
*** Issue 58398 has been marked as a duplicate of this issue. ***
Comment 8 frank.loehmann 2008-04-08 14:39:26 UTC
Created attachment 52656 [details]
Proposal for new default bullets in OOo
Comment 9 frank.loehmann 2008-04-09 11:05:30 UTC
Symbols used from OpenSymbol Font:
Level 1: U+2022
Level 2: U+00B0 (176)
Level 3: U+E579
...
Comment 10 frank.loehmann 2008-04-15 14:20:22 UTC
Please change the bullets for our default bullet list as follows:
Level 1: 2022 (small bullet)
Level 2: 25E6 (small outlined bullet)
Level 3: 25AA (small square)
Level 4 -> Level 1
Level 5 -> Level 2
Level 6 -> Level 3
Level 7 -> Level 1
Level 8 -> Level 2
Level 9 -> Level 3
Level 10 -> Level 1

Numbering/Bullets dialog, 'Bullets' tab (first row, left to right):
1: 2022 (small bullet)
2: 25E6 (small outlined bullet)
3: 25AA (small square)
4: 25AB (small outlined square)

These symbols are used from the font assigned to the paragraph. If this font
does not contain a bullet sign, the font substitution uses OpenSymbol font as
fallback. Therefore these bullets will be added to the OpenSymbol font (see 88261).

The 'Bullets' character style is still assigned to the bullets, but the style is
initally empty. This allows the bullet to grow with the font size of the paragraph.
Comment 11 frank.loehmann 2008-05-09 10:03:53 UTC
The opensymbol font now provides the new bullets. See 88261 for details.
Comment 12 frank.loehmann 2008-05-09 10:08:27 UTC
Dialog changes have been moved to 89225 with new target 3.1.
Comment 13 Oliver-Rainer Wittmann 2008-06-06 09:46:26 UTC
We (FL, IH, MRU and OD) decided the following:
- Instead of using the font of the paragraph for the bullet characters 0x2022,
0x25E6 and 0x25AA font OpenSymbol is used.
- IH will have a second look at the bullet characters in font OpenSymbol and
possibly will apply further improvement.
- FL and MRU will take that changed font OpenSymbol is installed during OOo
installation process.
- Character and Font substitution in WW8 export filter will be revised due to
the new used bullet characters.
Comment 14 Oliver-Rainer Wittmann 2008-06-06 09:55:49 UTC
fixed in cws sw30bf06 - changed files:
/sw/inc/numrule.hxx, 1.36.88.1
/sw/source/core/doc/number.cxx, 1.50.16.1
/sw/source/core/doc/poolfmt.cxx, 1.51.86.1
/sw/source/ui/wrtsh/wrtsh1.cxx, 1.70.88.1
/sw/source/filter/html/htmlnum.cxx, 1.26.88.1
/sw/source/core/text/frmpaint.cxx, 1.56.86.1
/sw/source/core/text/inftxt.cxx, 1.118.60.1
Comment 15 Oliver-Rainer Wittmann 2008-06-06 10:19:02 UTC
forgot to mentioned the following code change:
/sw/source/core/edit/autofmt.cxx, 1.40.88.1
Comment 16 Oliver-Rainer Wittmann 2008-06-19 14:56:21 UTC
OD->MRU: Checked in internal installation set of cws sw30bf06 - please verify.
Comment 17 Oliver-Rainer Wittmann 2008-06-30 08:27:00 UTC
Created attachment 54827 [details]
pdf document showing former default bullet characters
Comment 18 Oliver-Rainer Wittmann 2008-06-30 08:28:06 UTC
Created attachment 54828 [details]
pdf document showing new default bullet characters
Comment 19 michael.ruess 2008-07-01 16:24:54 UTC
Verified in CWS sw30bf06.
Comment 20 michael.ruess 2008-07-15 09:34:58 UTC
Checked in 300m24.
Comment 21 Oliver-Rainer Wittmann 2008-11-28 08:08:25 UTC
*** Issue 60263 has been marked as a duplicate of this issue. ***