Issue 63554 - Calc Autofilter - opening .xls and viewing autofilter criteria results in empty selection
Summary: Calc Autofilter - opening .xls and viewing autofilter criteria results in emp...
Status: CLOSED DUPLICATE of issue 17993
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-03-24 07:08 UTC by kpalagin
Modified: 2010-11-10 15:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
testcase (13.50 KB, application/vnd.ms-excel)
2006-03-24 07:09 UTC, kpalagin
no flags Details
screenshot (42.20 KB, image/gif)
2006-03-24 07:10 UTC, kpalagin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kpalagin 2006-03-24 07:08:23 UTC
Calc - opening attached .xls, viewing autofilter criteria and clicking OK 
results in empty selection.
Repro steps:
1. Open attached .xls and note how 3 lines are displayed by autofilter.
2. Click arrow down next to "Barcode" word and click "-Standart".
3. Observe "Standard filter" dialog (see attached screenshot). 
4. Click OK. Observe how filter selection shrinks to empty.
Calc behaves in described way irrespective of wether "Regular expression" in 
step 3 is selected or not.
Comment 1 kpalagin 2006-03-24 07:09:21 UTC
Created attachment 35194 [details]
testcase
Comment 2 kpalagin 2006-03-24 07:10:37 UTC
Created attachment 35195 [details]
screenshot
Comment 3 Regina Henschel 2006-03-25 23:12:15 UTC
OpenOffice do not use wildcards. To search for 322 inside a text, you can
uncheck 'Search criteria = and <> must apply to whole cells' in
Tools-Options-OOo Calc-Calculate and then simple use 322.
The request for wildcards is in issue 17993.

*** This issue has been marked as a duplicate of 17993 ***
Comment 4 Regina Henschel 2006-03-25 23:12:59 UTC
closing duplicate
Comment 5 biolisypal 2010-11-10 15:43:09 UTC
Created attachment 72982