Issue 63613 - To select multiple objects, we have to click on their borders
Summary: To select multiple objects, we have to click on their borders
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Minor (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-25 13:04 UTC by raindrops
Modified: 2014-05-02 12:47 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: 4.1.0
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description raindrops 2006-03-25 13:04:52 UTC
To select multiple objects (callouts, shapes, etc), we have to click on their
borders; otherwise the last object's text (if any) is selected.

There are two problems with this way of selection:
1. If any object has transparent background, (or a background color that matches
with the surrounding areas of the slide), the use cannot see its edge. It is
impossible to click on the edge.

2. In case the zoom factor is very small (e.g. 50%), the use has to find the
edge veryu carefully; even a small mistake will destroy the earlier selection.
He will have to make the whole selection again.

Suggestions:
1. After selecting one object, if the user presses CTRL or SHFT, OOo should
sense that the intention is to select multiple objects. So even if the user
clicks INSIDE the other objects, OOo should do multi-selection.

>> If the user has clicked inside the first object, OOo would be in text-edit
mode. But a press of CTRL or SHFt should tell OOO that now it should switch over
to object-selection mode.

2. Whenever the mouse moves over the border of an object, it should change
shape, so that user knows when to click. This will be especially useful to
handle objects with transparent/matching color.
Comment 1 Regina Henschel 2006-03-25 16:59:36 UTC
OpenOffice.org works here as designed, so it is not a defect but an enhancement.
You can select multiple objects be dragging a box which contain all this objects.

There is the issue 29804, which covers the difficulty of selecting an invisible
object. Are you sure, we need another issue?
Comment 2 raindrops 2006-03-25 18:44:41 UTC
Yes, that issue covers only one part of it; and that too the developers are not
particularly keen to allow that. (Pity!) 

However, issue 29804 is for Writer, where there are very few objects to begin
with. but this issue is for Impress, where we fiond a lot of objects, and need
to pick several objects from surrounding objects. 

So this issue is NOT a duplicate for issue 29804.

*******
Selection by lasso (drawing a rectangle) is not convenient at all if you have to
pick only certain objects from a lot of surrounding objects.

*********
Time and again I have come across this phrase "works as designed".
Well, I just cannot believe that Impress was specifically designed to behave
this way!

Do this experiment:
1. Create a new file with two blank slides.

2. Create two callouts on page-1. Enter some text in both.

3. Click inside one callout. Press SHFT and click inside the second. 
Notice that a part of string is highlighted in callout-2.
Text in callout-1 is not selected at all.

4. Press CTRL+C 

5. Go to the second (blank) slide. Press CTRL+V

6. Only the partial text of the second callout is copied into slide#2.
>> Both callout SHAPES are not copied (Only some text is copied.)
>> Text from callout#1 is not copied at all!
>> Trailing part of text from callout#2 is also not copied.

Why was Impress designed to behave like this? 
What was the practical application of such a thing?

Clearly this was an undefined area, and during reviews also this seems to be
overlooked.

I think this is a defect alright!
Comment 3 Regina Henschel 2006-03-26 16:18:21 UTC
You can determine which behavior OOo has when clicking. See the settings in
Tools - Options - OOo Impress - General, the area 'Text objects'. Same changes
are available in toolbar 'Options'. If you do not want, that a click leads to
text editing mode you must uncheck 'Allow Quick Editing'.
Comment 4 raindrops 2006-03-27 02:32:40 UTC
Yes, I unchecked the option, and it selected multiple objets as desired.

However, OOOs behavior is not correct when the "Allow Quick editing" option IS
selected.

Let me explain two different cases:

CASE-1: User clicks on the BORDER of object#1 and then clicks INSIDE object#2:

When the border of the first object is clicked, Impress selects the first
object. It may have ACTUALLY switched to the text edit mode, but that is not
evident to the user, because there is no cursor inside the object. This is a
defect: Impress should show the cursor at the very beginning of the text.

Now if the user clicks INSIDE the second object, Impress shows that both objects
are selected. THIS is a second defect, because it leads the user to think that
he can cut/copy both objects (and not the text inside).

But if the user sees carefully, the cursor is there inside the second object;
meaning that Impress is in "Text edit" mode.

Now if Impress IS in text edit mode, then it can edit the text in only one
object at a time. (Not both). Therefore, it must not show selection of both
objects. (So this is defect#3)

Even if Impress is in "Text Edit" mode in the first object, when the user clicks
on the second object, Impress should switch to "object selection" mode
automatically. OR it should release the first object and take the second object,
and show a cursor inside (meaning that Impress is now ready to edit the text in
the second object).

CASE-2: User clicks on border of both objects
When Impress is in "Text edit" mode, a user can click on border of the objects
and select them. This is not consistent with what happens in case-1 above.







Comment 5 wolframgarten 2006-03-27 14:23:54 UTC
For the described behaviour in point 1-6: you cans see easily in which state
(select or editing) your in. The status bar tells you: shape selected or text
edit. If you select text if will be pasted. When you are in text edit mode there
is a clear cursor visible.
Your case-1 seems to describe being in edit mode with no cursor visible: this is
not reproducible.
When you have quick editing selected one click on a textbox or on a text inside
a drawing object is enough to get it into edit mode. Clicks somewhere else into
the object will only select the object.
If you do not want both objects selected in your case why do you use the SHIFT key?
Comment 6 raindrops 2006-03-27 16:48:13 UTC
Yes, you are right: The ststua bar shows the mode (and it is "shape selected").
So let me revise that part of Case-1 and retrace my steps:

I click on border of shape-1. Then I press SHFT and click INSIDE object-2. Since
Impress is NOT in text edit mode, it should add the second object to the
selection, and NOT show the cursor in object-2. This is what I expect (and want).

But this does not happen: Impress switches to text edit mode, and shows the
cursor inside object-2, precisely where you clicked. That would mean that
object-2 is taken up for editing. But it also shows handles around both objects
together (as if they are a group).  That means it has selected both objects, as
if it is in shape select mode. 

In short, at this time Impress shows signs of both modes together. This is
confusing.
Comment 7 wolframgarten 2006-03-28 08:10:48 UTC
Yes, it shows sign of both modes because you switched quick editing on (options
toolbar) and used SHIFT for selecting.
If the first object would be deselected in your action you could say: hey, why
is it deselected? I pressed SHIFT.
If you wouldn't get into text edit mode of the second object you could say: I'm
in quick editing mode, it should switch to it.
This would be really confusing.
Comment 8 wolframgarten 2006-03-28 08:11:43 UTC
Closed.
Comment 9 raindrops 2006-03-28 12:19:58 UTC
Ok now that I have understood the meaning of modes and status bar messages, we
can argue this out. :)

Very simply put, Impress tries to ride two horses: It shows multiple objects
selected, but edits the text in the last selected object.

Why does it then show the multiple object selection? What can I do with it?

Impress can do any one of the following:
1. Selct both objects; and leabve the text edit mode)
2. Drop the first object, select the second object and remain in text edit mode.
3. Produce an error ("Since I am in text edit mode, pressing SHFT+click is not
acceptable") and remain with the text edit mode in object#1. 

But it does not do any of them!
***

That is how PowerPoint behaves; and it is very convenient: The quickedit feature
lets me edit text with a single click, but I can also start selecting multiple
objects without PowerPoint getting in my way. That's a smart way of handling
objects. 
Comment 10 wolframgarten 2006-03-28 12:39:41 UTC
"1. Selct both objects; and leabve the text edit mode"
-> no, because you wanted quick editing. And thats what you get.

"2. Drop the first object, select the second object and remain in text edit mode."
->no, because you used SHIFT to select both. Thats what you get.

"3. Produce an error ("Since I am in text edit mode, pressing SHFT+click is not
acceptable") and remain with the text edit mode in object#1. "
->no, because you clicked on the second object. It must get selected.

Other question: why do you use the SHIFT key when you want to edit text in the
second object? Powerpoint behaves wrong for my taste: when I have selected quick
editing I want it to happen and nothing else.
Comment 11 raindrops 2006-03-28 14:46:10 UTC
Well, you didn't answer my question: 
When Impress shows both objects selected (but is actually editing the last
selected object), what am I supposed to do with the selection?

Even if I am not allowed to press SHFT, why does it respond in thjis strange way?

If a user makes a mistake, the application must help him recover; and not
respond with strange results.

***
To answer your question, I have already said that when I press SHFT and then
click on multiple objects, my only intention is to select them all. I do NOT
want to edit text at the time.

You are suggesting that I should change the mode (through menu). But it would be
too tedious to keep switching modes that way.

It would be far easier to override the mode by pressing SHFT, select the
objects, cut/copy them, and then go back to text-editing. All that, without any
mode-changing!

So I expect SHFT to temporarily override the text-edit mode and switch Impress
to "Object-selection" mode.
 
And that's what PowerPoint does.

Smart, as I said.

It is a very common practice to press a modifier key to change the application's
behavior temporarily. SHFT and CTRL are very commonly used. 

Suppose we want to type "R". Which of the following method is easier?
(a)Press SHFT+r
(b)Press "Caps Lock" key, Press "r" key and then Press "Caps Lock" key again.

If you feel that method (b) is more natural, I won't argue any more.

Thanks..
Comment 12 wolframgarten 2006-03-29 07:37:38 UTC
This is getting us nowhere since we seem to have different opinions of what
should happen and what is happening.
I forward this to requirements but I do not think that this will lead anywhere.
Comment 13 dhollm 2009-05-01 17:44:53 UTC
As a frequent OO user, I agree with the comments made on Tue Mar 28 14:46:10

I use OO all the time and this is a constant problem.  OO makes it hard to
select many objects (hard to click, hard to see them, small handles) which this
issue is a part of.

Also, this is not only an Impress problem but affects at least Draw as well.
Comment 14 Rob Weir 2013-02-02 02:54:59 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 15 Edwin Sharp 2014-05-02 12:47:57 UTC
Maybe new menu entry: View - Object Borders, to be enabled before multiple object selection.
AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 12:11 - Linux x86_64
Debian