Issue 63696 - Scottish names with apostrophe always misspelled
Summary: Scottish names with apostrophe always misspelled
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-28 01:46 UTC by aholiab
Modified: 2018-08-07 21:06 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Cannot spell-correct proper name "O'Hair" (6.98 KB, application/vnd.oasis.opendocument.text)
2006-03-28 19:41 UTC, aholiab
no flags Details
Dictionaries (1.14 KB, application/x-compressed)
2006-03-30 20:54 UTC, aholiab
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description aholiab 2006-03-28 01:46:31 UTC
I am briefly referencing "Madalyn Murray O’Hair," the deceased American atheist.
Her final surname appears to be misspelled in this document, even after I fully
run the spell checker: the apostrophe appears to throw the spell checker off. I
am unaware of an options menu to disable spelling errors of such words.
Comment 1 michael.ruess 2006-03-28 05:44:23 UTC
Reassigned to SBA.
Comment 2 Rainer Bielefeld 2006-03-28 09:58:42 UTC
Copy paste special of the name into a Document with language EN-GB worked fine
with 2.0.2  German version WIN XP: [680m5(Build9011)]": WFM

After I added name "O'Hair" to dict., no further misspelling was detected.

@aholiab,
pls. contribute short sample document and add detailled information how ahd to
what wordbook you tried to add the name.
Comment 3 Rainer Bielefeld 2006-03-28 16:23:09 UTC
I checked with a testfile I received from reporter and  "2.0.2  German version
WIN XP: [680m5(Build9011)]", again WFM.

I deleted "O’Hair" from my SUN-worbook, red waved underline appeared. Made
spellcheck and re-added "O’Hair" to my SUN-worbook, red waved underline
disappeared. No Idea what it is, may be somethin with reporter's settings?

@aholiab
May be you should also contact a User-Mailing-List?
Pls. attach your testfile here using function "Create a new attachment (proposed
patch, testcase, etc.)"!
Comment 4 aholiab 2006-03-28 19:41:43 UTC
Created attachment 35319 [details]
Cannot spell-correct proper name "O'Hair"
Comment 5 aholiab 2006-03-29 02:27:32 UTC
Problem solved, but I had to work around it: during a Spellcheck, I had to open
a dictionary and manually insert "O’Hair". Note the curly left single quote.
This is probably why the AutoSpellcheck thought it was misspelled.

Furthermore, this same dictionary already had the entry, "O'Hair" in it
(straight single quote). This is probably why the Spellcheck
(non-AutoSpellcheck) thought it was spelled correctly.

It looks like a curly quote bug.
Comment 6 Rainer Bielefeld 2006-03-29 06:59:26 UTC
My "apostrophe" in "O’Hair" in the dictionary worked for straight and curly
quote, but I also believe that there might be special coded quotes which cause
problems. 

@aholiab 
How can we prove that? May be you can copy such "non working entry" from you
dict. and attach it here, so that I can insert it here to my wordbook and can
see how it will work?

I belive we need all "Uni-Codes" for the "apostrophes" mentionned here.
Comment 7 aholiab 2006-03-30 01:00:23 UTC
I could send you my user dictionary if that would help. I just re-opened that
dictionary, and both versions of "O'Hair" are visible, with and without the
curly single quote.

I don't know where it is, however--if you could tell me roughly the path, I know
which dictionary it is, but not its location.
Comment 8 Rainer Bielefeld 2006-03-30 05:45:49 UTC
@aholiab:
I have wordbooks in 
C:\Dokumente und Einstellungen\Rainer\Anwendungsdaten\OpenOffice.org2\user\wordbook
and 
C:\Programme\OpenOffice.org 2.0\share\wordbook\de

Please check under Menu "Tools - Options - OOo - Paths" where you find your
dictionaries.

Unfortunately until today I have not understood how OOo uses those different
dictionaries :-(

If there is no confidential content, I believe it would be the best if you
attach all your dicts. (complete folder contents) in one .zip here. 
Comment 9 aholiab 2006-03-30 20:54:11 UTC
Created attachment 35404 [details]
Dictionaries
Comment 10 aholiab 2006-03-30 20:56:27 UTC
I just sent a zipped folder of the only two dictionaries that appear on the path
to dictionaries. Neither appears to be the user dictionary to which I saved
"O'Hair", however. (I searched the hard drive for *.dic.) I don't know what else
to send.
Comment 11 aholiab 2006-04-03 19:06:05 UTC
FWIW, I'm still having this problem, but in a controlled way. I routinely have
curly quotes on, and I am frequently seeing proper names in the possessive form
(curly apostrophe "s"), such as, most recently, "Dooyeweerd’s". Earlier today
"Pearcey’s" was another problem.

But I can immediately fix them if I open a user-defined dictionary and manually
insert the offending entries.

Note that the Spellcheck doesn't see these as misspellings, but Autospellcheck does.

Note also that these problems don't exist if I used the non-curly single quotes.
Comment 12 Raphael Bircher 2011-10-04 22:54:42 UTC
Set back to the default assignee

rbircher > sba feel free to reassigne it to your self

Seems to need aditional QA Work. But it exist same workaround also.
Comment 13 Rob Weir 2013-02-02 02:57:53 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 14 Rob Weir 2013-04-03 21:47:14 UTC
Removing the "needmoreinfo" keyword.  There should be enough information here to test with AOO 3.4.1 to see if the issue still occurs.
Comment 15 Keith N. McKenna 2013-04-03 23:09:02 UTC
I downloaded the test file and opened it in AOO 3.4.1 on my Windows XP-SP3 system. O'Hair is NOT flagged as a misspelling. This using the English dictionary supplied with the installation. Also checked my standard.dic and it does not appear in it. Appears that it is no longer a problem.

Keith
Comment 16 Kay 2013-06-02 22:56:44 UTC
I'm testing with AOO 4.0 using standard US-en dictionary.

My test names of O'Bama, O'Shawnessy, O'Hannigan and O'Hair are all flagged as misspellings. However, a problem with surnames will be an issue with many surnames, not just types with the "O'". I am going to mark this as "Confirmed", though in all honesty, it should probably be changed to Resolved/Not a Bug. There's only so much a particular dictionary for a given language can deal with in my opinion.
Comment 17 Keith N. McKenna 2018-08-07 21:05:46 UTC
I agree with Kay that this is not an AOO bug but a general problem with surnames in general. This is one of the uses for the add to dictionary option in the spellchecker.