Issue 63829 - [Samba] Cant open embedded Base file for editing from mounted disk (nfs or smb)
Summary: [Samba] Cant open embedded Base file for editing from mounted disk (nfs or smb)
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 680m160
Hardware: All All
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2006-03-30 18:51 UTC by valdisvi
Modified: 2013-02-07 21:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description valdisvi 2006-03-30 18:51:42 UTC
There are several problems bugs registered regarding to NFS system, but actually
problem appear on several mounted (any non-local?) filesystems.
It was tested with NFS and SMB shares in Linux and behavior is similar -
database can be opened in main window, but clicking on any other view (table,
form) causes error:
The connection to the data source "DBName" could not be established.

SQL Status: S1000
Error code: -29

File input/output error: /smb/datubazes/Testa/DBname.log

Neither .log nr .lck in filesystem is created, despite user can create and edit
file in filesystem.

In Win desktop the same build, username and smb share works correctly, and .lck
file for database is created.
So, I suppose problem is in OOo Linux build not in misconfigured NFS or SMB shares.
Comment 1 valdisvi 2006-04-25 13:51:58 UTC
As it is real stopper for me and probably many other Linux/unix users, I've
marked this as P2
Comment 2 valdisvi 2006-05-11 12:53:37 UTC
It seems happen also while opening database from other computer using VPN
connection. See:
Comment 3 stephenmurphy 2006-05-15 21:53:06 UTC
I have reproduced this on Windows XP Professional clients with 680m167 when 
the database is held on a Windows 2003 file server.  For two of the clients, 
the problem occurs intermittently, and on a third the problem never occurs at 
all.  I note the same error messages and symptoms as found on the Linux 
systems.  I also note that the .lck file is missing.  Copying the database to 
the local filesystem always works.  I have not yet ascertained why this is 
Comment 4 valdisvi 2006-05-16 09:39:38 UTC
Because it was reproduced on Windows also, I changed platform to All.
I retested it with 680m167 build - from Win2k SP4 workstation database on smb
share (server is Mandriva 2006) was opened succesfully and *.lck file was created.
Comment 5 christoph.lukasiak 2006-06-07 15:58:32 UTC
may anybody write a step by step description for better repro

Comment 6 valdisvi 2006-06-07 21:45:11 UTC
You need two Linux computers. Its mandatory, I've just tested using one host for
simplicity, and it worked. Create NFS share one the first one. See some NSF
howto e.g. Then mount this share on the
other one. And then simply try to edit some Base file in mounted share.
Comment 7 valdisvi 2006-08-09 20:36:50 UTC
I retested it again on SRC680_m180 build. Now *.lck file is created and database
is opened (though extremely slowly), and can even edit records in table, but
when table is closed, error appears:
Due to an unexpected error, crashed. All files ....
Comment 8 cafahl 2007-03-27 20:18:48 UTC
I'm having this problem as well, which is a deal-breaker for my office.  Has
anyone had any luck on it?
Comment 9 christoph.lukasiak 2007-06-18 12:26:30 UTC
clu->msc: may you have a look on this ;)