Issue 63867 - Too many OLE objects open server window
Summary: Too many OLE objects open server window
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m160
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 2.2
Assignee: michael.ruess
QA Contact: issues@framework
URL:
Keywords:
: 62163 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-03-31 14:21 UTC by svante.schubert
Modified: 2007-02-06 13:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
ZIP containing the flat OpenOffice.org/OpenDocument XML filter and document that cause problems with ole objects (and the original sdw doc) (92.04 KB, application/x-compressed)
2006-03-31 14:27 UTC, svante.schubert
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description svante.schubert 2006-03-31 14:21:23 UTC
The attached test document (sdw) was saved as flat XML. Loading the saved flat
XML file (as well attached with suffix 'fodt') with the (attached) XSLT flat
filter error messages pop up after a certain amount of OLE objects have been loaded.
The error message says that there are to many windows open, obviously the hidden
windows of the OLE server, after removing a window, the default replacement
image for OLE objects has been added to the document.

It is most likely that formula documents will be often suffer from this issue,
therefore the target recommendation is OOo 2.0.4, but might be retargeted to OOo
3.0.
Comment 1 svante.schubert 2006-03-31 14:27:23 UTC
Created attachment 35426 [details]
ZIP containing the flat OpenOffice.org/OpenDocument XML filter and document that cause problems with ole objects (and the original sdw doc)
Comment 2 mikhail.voytenko 2006-06-26 15:11:22 UTC
Changing the target.
Comment 3 mikhail.voytenko 2007-01-08 13:24:13 UTC
One of the problems was that the replacement image was not correctly imported
from the flat xml format. It is fixed.
Comment 4 mikhail.voytenko 2007-01-11 15:46:51 UTC
The provided in the attachment ".fodt" document has not the replacement images
for all of the object. So the problem happens on storing to ".fodt" format. 
Comment 5 mikhail.voytenko 2007-01-12 15:48:11 UTC
The only way to avoid the message "Too meny windows open" in this scenario is to
set "Tools/Options/StarOffice/Memory/Number of objects" to small anough value.
This number controls the maximal amount of objects having the server running.
Obviously the number is too high in this scenario.

The message appeares because the attached .fodt document has no replacement
image for some objects. So the replacement images must be generated new, and
because of this the server is started.

But if the .sdw document from the attachemen is exported to .fodt file using
fwk59 cws the result .fodt file will be loaded without the problem.

The message "Too meny windows open" happens also during saving of the .sdw
document to .fodt file. That happens because the .sdw document seems to contain
no information about real object size, although it should. To detect this size
the server must be stated.
Comment 6 mikhail.voytenko 2007-01-17 07:09:33 UTC
MAV->MRU: Please verify the issue.
Comment 7 michael.ruess 2007-01-19 14:28:27 UTC
Verified fix in CWS fwk59.
Comment 8 michael.ruess 2007-02-01 12:06:07 UTC
Checked in 680m201 and OOF680m5.
As MAV pointed out, the error message problem cannot be fixed, because there are
faulty information stored in the sdw.
Comment 9 mikhail.voytenko 2007-02-06 13:26:47 UTC
*** Issue 62163 has been marked as a duplicate of this issue. ***