Issue 63889 - foreground, background and border buttons are not user friendly
Summary: foreground, background and border buttons are not user friendly
Status: CLOSED DUPLICATE of issue 10864
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0.2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-01 17:10 UTC by ilgraspa
Modified: 2006-04-11 13:46 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ilgraspa 2006-04-01 17:10:03 UTC
The toolbar buttons to change foreground color, background color and border
don't work as a user expects.
The user expects that when click on the border button it applies the selected
border to the selected cells; instead it make you have to choose the border you
want every time. The same about background color.
The foreground color changes the selected action when the selected cells change;
this is useless because most times the user wants to apply the same color to
different selection in sequence.
The way these buttons should work is (IMHO):
 - when you click on the button it applies the selected action(border or color)
 - when you click on the arrow next to it make you choose the border(or color)
you want and then applies it.
 - it stores your selection, so when you click on the button next time it
applies the last border (or color) you selected.
 - the selected action should not change when changing the selected cells.
Note that these buttons should be used exactly in the same way (why not using
the same component?)
Comment 1 ilgraspa 2006-04-01 17:15:42 UTC
Note: issue 10864 describe the same problem but only for the border button;
I think this is a problem with all the platforms and all ooo versions, but I
have not tried :(
Comment 2 frank 2006-04-11 13:46:16 UTC
closed double to Issue 10864

*** This issue has been marked as a duplicate of 10864 ***
Comment 3 frank 2006-04-11 13:46:48 UTC
closed double