Issue 64070 - PDF Export of Copyright symbol in certain Type 1 fonts incorrectly handled
Summary: PDF Export of Copyright symbol in certain Type 1 fonts incorrectly handled
Status: CLOSED DUPLICATE of issue 63015
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.0.2
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: hdu@apache.org
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-06 12:13 UTC by valence
Modified: 2013-08-07 14:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Document file illustrating the problem (7.90 KB, application/vnd.sun.xml.writer)
2006-04-06 12:14 UTC, valence
no flags Details
PDF file from the exporter. (138.09 KB, application/pdf)
2006-04-06 12:15 UTC, valence
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description valence 2006-04-06 12:13:59 UTC
For some odd reason, when a document that contains Type 1 fonts (e.g. Palatino
or Avant Garde), the copyright symbol is incorrectly exported into the PDF, and
ends up looking like a single apostrophe.

This seems not to happen with other symbol characters that are nearby in the
font table, and also does not happen with Opentype, Truetype fonts. Even some
Type 1 fonts appear to be OK, such as Helvetica.

I am attaching a source file and the resulting PDF. (The fonts are of course,
not embedded in the odt file.
Comment 1 valence 2006-04-06 12:14:50 UTC
Created attachment 35531 [details]
Document file illustrating the problem
Comment 2 valence 2006-04-06 12:15:51 UTC
Created attachment 35532 [details]
PDF file from the exporter.
Comment 3 michael.ruess 2006-04-06 13:47:23 UTC
Reassigned to HI.
Comment 4 h.ilter 2006-04-10 13:48:55 UTC
HI->HDU: Couldn't reproduce. Please have a look.
Comment 5 valence 2006-04-11 01:20:30 UTC
I should add that I don't see this problem creating a PDF using Adobe Distiller,
and since it doesn't appear to happen in any Type 1 font, you probably need to
use the exact fonts I have (which are part of the original Adobe PS collection).
Let me know if you want me to try anything else.
Comment 6 valence 2006-04-11 01:31:44 UTC
I just searched the issue database agaain, and I think this might be the same as
issue 63015?
Comment 7 hdu@apache.org 2006-05-17 15:03:54 UTC
Yes, I'm now quite confident that the problem has the same root cause.

*** This issue has been marked as a duplicate of 63015 ***
Comment 8 hdu@apache.org 2006-05-18 14:25:12 UTC
Closing duplicate. The case with the copyright symbol should be tested when
issue 63015 is fixed.