Issue 6413 - Selection should follow right click
Summary: Selection should follow right click
Status: CLOSED DUPLICATE of issue 20330
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOo 1.0.0
Hardware: All Linux, all
: P2 Trivial with 4 votes (vote)
Target Milestone: OOo 2.0
Assignee: bettina.haberer
QA Contact: issues@ui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-12 11:39 UTC by jamescrompton
Modified: 2005-03-03 16:54 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jamescrompton 2002-07-12 11:39:05 UTC
When you right click in an OpenOffice.org window, the selection 
doesn't change; the menu that comes up is based on and the action 
you choose applied to the current selection and not what you have 
clicked on. No other application I have used works this way. It 
slows things down (you have to change the selection first, then 
right click) so much that you might as well do without the context 
menu altogether, and inevitably leads to mistakes, since people are 
used to a different behaviour from other applications.
Comment 1 Frank Schönheit 2002-07-12 17:08:57 UTC
confirming issue - this is a valid feature request in the sense that
the current behaviour _could_ be changed. My confirmation does not
mean acceptance in any way.
However, I strongly agree and recommend that we should fix this as
requested. It is something were we already had some discussions about,
but no concrete outcome yet except "we probably should do it". Nobody
could really argue the current behaviour, which indeed is very annoying.

But, we should see this in a more general context: Not only in the
Writer, but everywhere where a context menu is supported, the user
should be able to right click on the item she is interested in, and
the item should be selected, before the context menu is opened.
For instance, some time ago, we changed the behaviour in the Stylist
accordingly (will be in some next OOo snapshot).

An interesting point here, which caused a lot of discussion, is if the
selection should be restored when the context menu is closed. There
are pros and cons for such a behaviour, for instance the expenses for
changing a selection (and everything else which perhaps must be
synchronized with it).

Frank
Comment 2 iavor 2002-09-06 11:37:15 UTC
I join the opinion that selection upon right click is very important.
I waste a lot of time clicking twice.

I do not think the original selection should be restored after the
contex menu has been closed.
Comment 3 stefan.baltzer 2002-10-01 16:36:55 UTC
Reassigned to Christian.
Comment 4 christian.jansen 2003-02-11 16:24:15 UTC
Reassigned to Bettina.
Comment 5 javascriptdude 2004-09-09 01:44:16 UTC
I noticed that this issue is fixed in the latest 2.0 snapshots (1.9.51). :]

Should this issue be targeted in the 2.0 milestone then?
Comment 6 stx123 2004-11-11 10:15:38 UTC
Hi, hasn't this been changed as requested on our way to 2.0?
Thanks, Stefan
Comment 7 matthias.mueller-prove 2004-11-11 13:53:28 UTC
duplicate & fixed for OOo 2

*** This issue has been marked as a duplicate of 20330 ***
Comment 8 bettina.haberer 2005-03-03 16:54:15 UTC
Closed.