Issue 64273 - Titlebar unreadable with certain locale
Summary: Titlebar unreadable with certain locale
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: 680m161
Hardware: All Unix, all
: P3 Trivial (vote)
Target Milestone: OOo 2.0.3
Assignee: Olaf Felka
QA Contact: issues@gsl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-11 11:35 UTC by Olaf Felka
Modified: 2006-05-09 11:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Olaf Felka 2006-04-11 11:35:28 UTC
- seen on the host athene with Solaris 10 s10s_u1wos_19a
- locale set to de_DE.ISO8859-1 or en_US.ISO8859-1 
- starting soffice brings up a title bar that's unreadable
- switching locale to e.g. de_DE.ISO8859-15 solves the problem
Comment 1 philipp.lohmann 2006-04-12 18:06:46 UTC
The reason is that XmbTextListToTextProperty does return garbage in this case.
Exactly why it does that is beyond me; you can change the behaviour by settin or
unsetting environment variables (as long as you use enough of them), or by not
using IIIMP (e.g. by setting USE_XOPENIM=true).

This sounds like memory corruption, but i was not able to find the culprit; also
a test program would not reproduce the problem :-(. So i built in a workaround
for the time being.

fixed in CWS vcl57
Comment 2 philipp.lohmann 2006-04-13 14:30:39 UTC
please verify inCWS vcl57

re-open issue and reassign to of@openoffice.org
Comment 3 philipp.lohmann 2006-04-13 14:30:47 UTC
reassign to of@openoffice.org
Comment 4 philipp.lohmann 2006-04-13 14:30:52 UTC
reset resolution to FIXED
Comment 5 Olaf Felka 2006-04-26 08:45:23 UTC
OF: It's ok with *.ISO8859-1 locales. No regression with other locales.
Comment 6 Olaf Felka 2006-05-09 11:29:07 UTC
Is ok in master m167.