Issue 64450 - Decimal separator
Summary: Decimal separator
Status: CLOSED DUPLICATE of issue 106961
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Trivial with 11 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-18 07:33 UTC by vaclavik
Modified: 2017-05-20 10:01 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description vaclavik 2006-04-18 07:33:55 UTC
Decimal separator can now works in two modes (tools->options->language):  
1) decimal separator defined by system (locales)  
2) decimal separator is set to comma (",") and remapping key in numeric  
keyboard  
  
This is very uncomfortable for manipulating with tables in cvs format and for  
users, that uses different language setting and decimal separator (in cases as  
decimal separator by locale is comma, but data uses period - frequent 
situation). In this cases user musts convert data before computing resp. use 
other key than decimal separator at numeric keyboard.  
  
As decimal separator is (ususally) period (".") or comma (","), it would be  
better change option tools->options->language: decimal separator into popup  
menu with 3 selections:  
1) period - set period as decimal separator, no remapped keyboard  
2) comma - set comma as decimal separator, no remapped keyboard  
3) system - set decimal separator in accordance with system (locales), no  
remapped keyboard  
  
and add new option marked as "remapping numeric keyboard", what changes key in  
numeric keyboard in accordance with above. 
 
See also issues 51662, 63049 etc.
Comment 1 vaclavik 2006-04-19 09:29:21 UTC
Sorry, I wrote about csv format (comma separated value). 
Comment 2 kokito 2006-04-20 10:01:07 UTC
*** Issue 64450 has been confirmed by votes. ***
Comment 3 Mathias_Bauer 2006-04-21 14:26:19 UTC
No patch attached, changing type to "Enhancement"
Comment 4 vaclavik 2006-04-22 19:07:37 UTC
Please change version into 2.0 
Comment 5 pavel 2006-04-23 08:46:21 UTC
.
Comment 6 jbohac 2007-12-11 18:39:39 UTC
I have another idea here. Importing CSV files is really painful if the decimal
separator used in the CSV file is different to your current locale settings
(frequent). 

The CSV import already has a very nice dialog allowing the user to specify what
character should be considered a delimiter. Having an option in this dialog
allowing the user to specify the character used as a decimal separator in the
CSV file would be very helpful.
Comment 7 vaclavik 2007-12-14 20:51:02 UTC
to jbohac:
Yes, but it does not solve my problems (and I think, that not only mine).

My mistake is in it, that I described this issue only as problem of CSV files. 
But for instance, my language uses comma as default decimal separator and I 
use keyboard with period (it is difficulty to use different keyboard 
layouts - [what idiot swap z and y on keyboard?]. 

In this case I can use:
1) my locale with default (comma, but I have not comma in numeric keyboard...)
2) my locale with comma  (grrr...)
3) another locale with period but without native another language setting (the 
only way is set cell language to 'period' locale) - but it works only in 
spredsheet and not in writer table.

I think, that propose solution is better.
Comment 8 Edwin Sharp 2013-11-29 10:58:53 UTC
Duplicate of bug 106961.

*** This issue has been marked as a duplicate of issue 106961 ***