Issue 6448 - how about a viewer app. for all files ?
Summary: how about a viewer app. for all files ?
Status: CLOSED DUPLICATE of issue 9691
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 12 votes (vote)
Target Milestone: ---
Assignee: falko.tesch
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2002-07-15 23:48 UTC by lars
Modified: 2006-03-05 02:07 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lars 2002-07-15 23:48:53 UTC
a viewer program which is simple and compact, it only parses the file and 
displys the content on screen; it allows text to be highlighted, and the window 
content can be scrolled by "drag'ndrop", it has a print icon - and an edit 
icon. this edit icon calls the real app.
This viewer app. would only be abot 500K in size and be nothing more than a 
frame around the content; perhaps similar to Ms Notepad only that instead of 
the white (text) area the file content is displayed (the real file content as 
the OO app. itself displays it).

Now: All OO files get a flag "doc completeted" which can be set by the user 
upon save in the file properties or by an icon in the taskbar of the app. upon 
editing and this flag is used by the viewer app to determine whether itself 
should display the file or the big app. should overtake.

For the api developers: As the viewer app would be loaded first, it is in there 
where the parse and dispay code could be and which could be used by the big 
app.; so no load time is lost there. But a user saves time when only the viewer 
pops up.

Lars
Comment 1 thorsten.martens 2002-07-31 09:50:50 UTC
TM->FT: Another feature-request ! Please have a look, thanks ! 
Comment 2 lars 2002-08-19 22:04:15 UTC
this issue depends on issue 7137 'Seperate content creation and 
content viewing'

that issue is in the ring of issues concerning this matter:
issue 7137 'Seperate content creation and content viewing', issue 
7138 'write-protection on document-level', issue 6889 'pdf creation 
posible with OOo ?'
Comment 3 lars 2002-08-22 04:41:55 UTC
some things to consider:


Calc documents are also created for presenting on screen, so saving 
of screen res. with which that is done (or ask creator which to 
choose) should be implemented.

The viewer could then ask to change the screen res. if necessary.

Offering a Fullscreen-View Mode might be nice.


The viewer should also contain a search icon and offer copy 
functionality if that doesn't cost much.



I think a viewer for each OOo app. is better than one for all (if you 
go the "more demanding" but perhaps "logical" way of making it do 
work for OOo big app. that's what you have to probably do anyway).



Another step is to offer wrapped documents, that are documents with 
the code to display them in an exe file like WinZip Self-Extractor!

This wrapped file really just contains display code and only allows 
to display the document with a 1 pixel black border and scrolling by 
mouse drag&drop (if other things do not cost not much).



And all viewers should be really fast...!
Comment 4 ggabriel 2003-07-07 17:24:36 UTC
I consider a OOo file viewer for those not having OOo installed  
(specially in Windows and Mac platforms, where the majority of Office
users in the world are) a must, that would allow every user to be just
a small file (exe) download away from viewing any OOo generated file.

Please dedicate some resources to this!

thx
Gabriel Gazzán
Comment 5 lars 2003-09-07 02:06:40 UTC
there is another issue with the same request which already has set a 
Target milestone; I'm therefore closing this one;

please: everyone who voted for this one: vote for the other one: it 
has 16 votes already, together, this makes 33 votes

Lars

*** This issue has been marked as a duplicate of 9691 ***
Comment 6 hesse 2003-09-11 10:25:04 UTC
It is not a duplicate because this issues includes not only
presentation but also e.g. writer. Perhaps it should be reopend.
Comment 7 watersrw 2004-09-23 20:42:42 UTC
this is not a duplicate
Comment 8 lohmaier 2006-01-11 18:03:22 UTC
closing duplicate.
Comment 9 paulbe 2006-01-11 23:58:30 UTC
As has been stated (and proven) before this issue is not a duplicate of issue
9691 , because that issue pertains to the presentation component.
So closure because of allegedly being a "duplicate" is not correct.
Comment 10 hesse 2006-03-04 22:32:28 UTC
Hi cloph ,
did you read any of the above statements (mine from the Sep 11,  watersrw Thu
Sep 23)?
Would it not be at least reasonable to answer to these before closing?
I dont know who you are and I know that i am a noboby here, but all these issue
thing is a nonsense if you dont explain in a short sentence why you think we are
all completly wrong.
Thanks
Comment 11 lohmaier 2006-03-05 02:07:39 UTC
all arguments that are inhibitors for the impress viewer apply for the other
viewer apps as well. Since neither of these is sheduled for implementation
anyway, it doesn't make sense to have loads of issues for this.

If you're gonna implement a viewer for the files, then go ahead, nobody will
stop you. But all "regular" OOo-developers have other issues to fix before even
considering to work on a viewer app which is of little use anyway.

Again: If you want a read-only document, you can as well just provide it in pdf
format. There are pdf-viewers for all systems available. Both free (as in free
beer) as free ones (as in "freedom of speech").

You don't snip with your fingers and have a viewer app. (sure, you can just
remove all edit-functins from OOo, but still this would not be a viewer app and
far from being small).

So to summarize: If you want it, do it yourself (or find someone else to do it). 
In the menatime: Just use PDF or another format, export to MS-Office format and
use the MS-Office viewers or install the full OOo.

If you cannot even get an application for one single type of document, then it
is even more unrealistic to request a viewer that deals with all document types.