Issue 64581 - Retain Tools->Options->Paths->Templates in future releases
Summary: Retain Tools->Options->Paths->Templates in future releases
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Trivial with 27 votes (vote)
Target Milestone: OOo 2.0.4
Assignee: matthias.mueller-prove
QA Contact: issues@framework
URL: http://specs.openoffice.org/appwide/o...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-20 20:23 UTC by josephj
Modified: 2007-01-02 11:55 UTC (History)
7 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description josephj 2006-04-20 20:23:08 UTC
Releases 2.0.2 (and prior) work as desired.
The URL above proposes to disable a large number of path settings in the UI in
release 2.0.3.

The template paths setting is something I rely on.  It is especially useful for:

1) To keep all user templates in one constant (easy to remember and find) place
which is OOo release independent (and a much shorter path) e.g. $HOME/OOo-Templates.

2) Since Open using template works with subdirectories (a great feature!),
It is possible to have a subdirectory under the main one for templates for a
prior release e.g. $HOME/OOo-Templates/OOo_1.  This keeps templates organized
and aids greatly in migrating to a new release (e.g. gradually replacing all
stw's with ott's).  The old release template path can be pointed to this
subdirectory.  Then, the new release can see both old and new and the old
release can see only the old.  If the proposed change is implemented, this will
be impossible to do using the UI.

3) There are other instances such as templates stored on a network, etc. where
easy access to this feature would be important.

I am sure there are quite a few "advanced" users who are not programmers or who
do not know java.  It would be far more difficult for them to access this option
if it was only available in a configuration file that most users aren't even
aware of.

If other issues are raised relative to keeping other path settings in the UI,
this issue may be combined with them to maximize votes/priority.
Comment 1 Regina Henschel 2006-04-20 21:59:17 UTC
I agree with you. I use a separate folder for user templates and a separate
folder for user defined dictionaries. It would be very annoying to be forced to
edit configuration files to set the paths. I need separate folders, because they
must be easily accessable from different versions including StarOffice, which
are installed parallel.
Comment 2 thorsten.martens 2006-04-21 09:04:04 UTC
TM->MMP: Please have a look, thanks !
Comment 3 matthias.mueller-prove 2006-04-21 09:40:46 UTC
yes, the idea is to bring pack the necessary paths in a robust way.
Target is OOo 2.4
Comment 4 andypep 2006-04-21 09:54:41 UTC
It is useful to modify these occasionally, but even more important to see 
where the paths are when chasing problems. Please keep them visible in the UI 
in 2.0.3 even if we can't change them. 
 
For multi-user situations, it may be necessary to group templates and 
dictionaries for groups of users, and separate directories for these cases is 
the easy way to do it. 
Comment 5 josephj 2006-04-21 16:33:11 UTC
Wouldn't it just be simpler to leave it alone for a few months until 2.0.4 comes
out and it's done "right"?
Comment 6 grsingleton 2006-04-21 17:01:46 UTC
I think that leaving templates path user configurable is an important feature.
One which I use to share templates to _ALL_ my users. 
Comment 7 claudiadzm 2006-04-27 06:03:45 UTC
My situation now: 
When I save a template, its stored in my user's directory. When I try to open 
it for doing some changes, the writer offers the directory of the 
server-installation. 
That does not make sense for an ordinary user. And I can't explain all our 
user's how to work directly with configuration files. For me that seems a 
regresion to times where computers where only used by computer scientists that 
where used to dipp to the inside of the machines. 
I hope, that will be changed before the final version of 2.0.3. 
cheers, Claudia 
Comment 8 cno 2006-04-29 19:36:31 UTC
I'm in favor of having paths visible, and having the posibility to adapt them
(again ASAP) ....

However, I came along a little problem with importing Basis Libraries. 
After closing and starting OOo again, the library was listed, however Empty,
which results in error message on loading the library's-window. (And of course
trouble to load the lib again.)

It turned out to be caused by my personal settings for Basic-paths: I defined my
own user-location for macro's (Tools|Options|Paths) and removed the pre-defined.
Apparently OOo is not able to handle that.

I wouldn't be surprised if many of the 'Missing script'-errors that pass the
users-lists frequently, have to do with this problem. I've had some myself and
helped others to solve them. And all problems had to do with new installations,
taking over some settings/paths from older installations.

So pls give back the path setting ;-) but pls in robust way :-)
Thanks !
Cor
Comment 10 ms2 2006-05-19 04:45:14 UTC
There should at least be some little configuration tool for adapting the paths
once after istallation or changes.

I agree to some degree with not needing all paths after they are set, but it has
to be done sometimes and there should be a convenient way to do so.

So I propose making a configuration tool or integrating in one of the available.
That way we'd have both: a method of editing paths and no GUI option page.
Comment 11 Mathias_Bauer 2006-05-19 09:28:26 UTC
Just a comment about current ideas how path settings should be. IMHO we should
only allow to add pathes, the default pathes (share/path and user/path) will
neither be shown nor can they be removed. This will make the dialog much more
clear. 
Additionally we are working to make most of the components that currently use
extendable pathes ("multipath") extendable by UNO packages so that e.g.
templates can be added to an installation by just providing a UNO package with
one configuration file (xcu).
Comment 12 jolatt 2006-06-05 15:15:46 UTC
If I go to menu file-template-edit (German: Datei-Dokumentvorlage-Bearbeiten...)
the share-templates are shown. IMO it would be better, that the user-templates
are shown by default.  
Comment 13 Regina Henschel 2006-06-05 15:35:08 UTC
@jolatt: I think that is a different problem, see issue 64328.
Comment 14 emforner 2006-06-27 17:51:18 UTC
I absolutely agree with all the folks who want the template path setting to be
mantained in the UI.
In my case, I need to keep the templates organized by directories and
subdirectories other than the program default ones (also, because I often modify
and update my templates and I need to make them available for the people who
work in my law firm).
So, the best solution would be to keep the UI template path setting as it is in
OOo 2.0.2 and prior, until the bug (which never occurred to me, truly) is fixed
for OOo 2.0.4.
If it's not possibile by now, then bring the UI setting back for OOo 2.0.4 (and
release this last one ASAP).
Comment 15 cianoz 2006-07-01 08:10:38 UTC
Removing the possibility to set the paths for templates in Tools > Options is
one ot the worst change ever done in OOo. 
In a corporate environment this setting is a key feature, moreover choosing
network folders as template source allow OOo to automatically recognize new
templates when someone put them in these directories.

I manage a LAN with over 30 users and network folders used for template are
(were) a core feature. 
Now if i upgrade OOo 2.0.2 to 2.0.3 all my users lose this possibility and all
their currently settings. What shoul i tell to them ? What do i answer to them
when saying that "in Micro$oft Office this doesn't occur" ?
And how should i set now shared templates for every users like i were used to do ?
Comment 16 andreschnabel 2006-07-01 09:03:21 UTC
cianoz:
I absolutely agree, that this was not one of our best decisions. But, there
should be no problem for upgrading, as long as your environment is correctly set
up at the moment.
The option is removed from UI, but the settings in your config files will be
read.  During an upgrade, the user settings will stay in place. Users will loose
no settings at all. 
Comment 17 emforner 2006-07-03 11:38:13 UTC
@ andreschnabel:
It's true that when upgrading from prior OOo 2.0.x to OOo 2.0.3 the template
path settings are not lost; but what if someone had to install Ooo 2.0.3 for the
first time (i.e., without having previously installed OOo 2.0.2 or prior) and,
e.g., have to share common templates with others in the same LAN?
I, for instance, had to uninstall OOo 2.0.3 from a newly bought PC (to add to my
LAN), install OOo 2.0.2, set the proper tempolate path, then uninstall OOo 2.0.2
then install OOo 2.0.3 again to have my templates properly set up.
I hope you'd agree this sounds a bit crazy (I think I heard M$O team laugh from
my remote home in Italy...).
So, the UI Template Path settings tool MUST be back ASAP (OOo 2.0.4?);
otherwise, it has to be made well-known how to manually set the config files to
include new paths or modify the existing ones.
Anyway, I still appreciate your work and continue to use OOo...
Comment 18 Mathias_Bauer 2006-07-03 12:33:06 UTC
As you can see from the target of this issue it is planned to have the dialog
settings back in 2.0.4.
Until then you can patch the settings in the configuration file manually. In
case you have a shared installation you would do it that way anyway.
Comment 19 cianoz 2006-07-03 13:16:51 UTC
I searched a lot over the OOo website, in OOo documentation and with Google, but
i didn't find any clear explanation about which exactly are the config files i
have to modify and what i have to modify inside them.

I suppose the config file is 
C:\Documents and Settings\<user>\Applications
Data\OpenOffice.org2\user\registry\data\org\openoffice\Office\Common.xcu
but why don't you put a *FAQ* to explain it ? I think a lot of people has the
same problem now.

And, please, we want back all other paths entries that OOo 2.0.2 has in the
options window (in the GUI). It was so confortable for the user to able to set
all the paths without getting crazy with config files !
OOo 1.x had too many entries in that windows, but ver 2.0.2 had the right
number, IMHO.
Please.
Comment 20 Mathias_Bauer 2006-07-03 13:43:09 UTC
We will not have all paths back as at least one of them can't be changed by the
user at all (basic) and one of them can make OOo crash if a user does something
stupid (UIConfig).
Some other paths are under investigation. We definitely will have back the
settings for templates, autotexts and autocorrection.
Comment 21 banker 2006-07-03 14:05:48 UTC
@andreschnabel:

Hello,

I'm the responsible person in our company (financial sector, ~1000 employees)
for setting up our standard office product, OpenOffice.org. And I really didn't
want to believe it when I read that most of the customizable path entries would
be removed from 2.03!

But today, after downloading the new german version, I was made a believer: Most
entries are gone! :-(

We have a central template repository, we have a central macro repository and we
have a central directory structure for files.

You can't be serious that all this customization entries shall be hidden in some
undocumented setup files (if ever)? Right now we might have luck because we're
already using OOo 2.02 and according to your statement the upgrade won't touch
the existing path entries. But what shall we do when we have to setup new or
reinstall systems? Install 2.02 first, setup the paths, then upgrade to 2.0x?

IMO: This behaviour MUST be changed asap! And create a well-documented FAQ-entry
until it is fixed!

P.S.: Not that this would belong specifically to this issue but: Setting up a
customized automatic installation of OOo 2.x is a pain in the ... But this is a
different story.

P.P.S.: Beside all the critizsm: I love OpenOffice.org 2! It's truly a great
product (Have been using it since StarWriter 2.0 for OS/2).
Comment 22 andreschnabel 2006-07-03 14:58:58 UTC
hi all, 

you may use http://www.prooo-box.org/%7Eschmidjo/download.php?datei=ooo_pfade.zip
as workaround. This is a package that can be installed by using the OOo package
manager. You will find a new menu item in the Help-Menue. The package is German
but should be easy to handle.

Please be aware that this package is not tested and not at it's final location.
It should be used by admins only. 

Comment 23 emforner 2006-07-03 16:03:13 UTC
Hi andreschnabel,
thanks for the link but... there's just a little problem (I think I share qith
many people): I neither speak nor understand German!
Actually, I'm italian and, even though I speak something more than a bit of
English, I don't even dare to use OOo in English; so, although I believe that
the tool you seggested is very good, I won't even try to unpack the .zip file
(although I have downloaded it).
Maybe, if there was just an english localization of the tool, I could try, but
by now...
I still think the Tools|Options|Paths settings should be restored in full in the
UI (and I'm not the one, I see... also in http://www.oooforum.org/ there's
plenty of people who believe like I do...).
Regards.
Comment 24 marshfeldman 2006-07-03 21:52:04 UTC
If you're going to change the template paths feature, at least update the
documentation to (a) be accurate, (b) explain how templates work now, and (c)
support established users who may need to know what happened to their old
configuration and how to work around things now. To say experienced users can
use the configuration file, without instructions about this file, is terrible.
Even worse, the help file (and countless tutorials, blogs, and how-tos on the
web) still refers to changing template paths! (e.g., from Writer 2.0.3, try Help
-> Find -> Paths). Users need to be alerted to the change, advised what to do
instead, and be told exactly what information they might run into on the web is
no longer valid.

Second, if OOo is going to mess around with templates, why not do it right? As
others have suggested, wait until the remodel in 2.0.4. Even better, distinguish
between a "Template" and a "Style Library." A "template" should be a standard
layout for such things as letters, books, and working papers. For example, a
book template would tell the user what front matter to put where, back matter,
etc. A style library, on the other hand, would change the look and feel of the
book. By changing style libraries (or style sets), the book's look and feel
could change from formal to contemporary, but a common template would still
guide the user through the process of what goes where in a book!

Both template and style libraries should have user-configurable search paths. If
OOo crashes when the user does not do this correctly, how hard is it to test for
a legal path and substitute a default path when the user-configured one is
illegal? Even better, how hard is it to test for a legal path when the user
enters a new path?
Comment 25 bobharvey 2006-07-04 08:18:30 UTC
I have to agree with every word MarshFeldman wrote, I am astonished that the 
project can make such a fundamental mistake when trying to compete with e.g. 
the new Office 12.

In particular:
>Even better, how hard is it to test for a legal path 
>when the user enters a new path?

Well, quite.

Andre Schnabel said:
>I absolutely agree, that this was not one of 
>our best decisions.

No.  And not updating the documentation to match should be /impossible/.

I am surprised that a change as significant as this can be introduced as a dot-
dot point change, without a proper Beta programme.  This is a feature-set 
change, not a bugfix.  

And I am furious that with the Chart module outstanding and some issues as old 
as 5038, 7065, 4579, 1761, 1598, and (god help us) 972 & 366 going unadressed 
that rare programming resource is allocated to this sort of destructive 
tinkering.

If the developers continute to take this high-handed attitude with the users 
and thier views then the bubble of enthusiasm for OOo will burst.  The 
existence of Issuezilla and the ability to communicate so openly with the 
development team is a huge differentiator over the competition, and compensates 
for the lack of user-friendly features or true innovation over the majority 
product.  If the development team continue to concentrate on thier own 
priorities then this advantage will be worthless.

I suggest that someone needs to do a query of the most highly voted-for issues, 
and get them dealt with, making at least a 2.1 and 2.2 revision to include them 
and maintianing 2.0.x until a sensible beta is over for both of them.  There 
are only 165 issues with more than 12 votes.

I use the product intensively, having a political objection to monopolies, and 
try to persuade other people to use it.  But frankly, it isn't as good as it 
thinks it is, and it is nowhere near as good as the opposition.  Microsoft got 
good with usability labs and very large (closed) feedback programmes.   With 
enthusiastic and politically motivated early adopters and an open feedback 
programme, someone should be asking why there are so many "how do I" threads on 
the user forums.
Comment 26 matthias.mueller-prove 2006-07-04 15:40:56 UTC
Template, AutoText, AutoCorrect paths are on their way back into the UI. The
spec documents this change in progress.
Comment 27 emforner 2006-07-04 16:13:03 UTC
At long last!
Welcome back to the UI Path settings tools!
But... can we truly expect this to be for OOo 2.0.4?
I think it'd be better so: maybe bobharvey is a bit too rude, but most of what
he says is true.
I am very happy that OpenOffice.org/StarOffice exists, but it's nonsense if it
has to be that much worst than M$O; maybe home users may find it enough for
their needs, but OOo must target to big users, such as companies, public
administrations etc. if the M$ monopoly has to be broken.
Regards to everybody.
Comment 28 matthias.mueller-prove 2006-07-04 17:09:00 UTC
I suppose so - 2.0.4 is still realistic.
Comment 29 esperantisto 2006-07-24 08:45:31 UTC
I vote for this issue — but with a different (complementary) wish: bring back 
the setting for spellcheck dictionaries! If you concurrently have two (or more) 
versions of OOo, it's not wise to have several copies of your dictionaries.
Comment 30 esperantisto 2006-07-24 08:46:15 UTC
I vote for this issue — but with a different (complementary) wish: bring back 
the setting for spellcheck dictionaries! If you concurrently have two (or more) 
versions of OOo, it's not wise to have several copies of your dictionaries.
Comment 31 untel 2006-07-30 06:11:16 UTC
This behavior must have appeared somewhere in the development betas.
So I guess the lesson is: more of us should try some of these betas sometimes.

For if we let geeks have their way we'd lose much more control.

So I promise myself to try here and there more interim versions before they are
released... but then one has to know where to look. Who knows what surprises
awaits us, what strange decisions will have been made upon the release of a new
version?

Sarcasm aside: we get what we pay for, right?
Comment 32 grsingleton 2006-07-30 13:12:07 UTC
Template path is back in m177. 
Comment 33 matthias.mueller-prove 2006-07-31 15:48:40 UTC
This should be fixed along with i67100
Closing this task.
Comment 34 robertf 2006-10-10 00:01:58 UTC
This issue was closed on July 31, and as of 2.0.4rc3 the templates path has been
restored (thanks!), but the 'User-defined dictionaries' and 'Writing aids' paths
are still missing (and others, but those are the ones I care about right now).
Do we need to open a new issue to get them back, or are they in the works?
Comment 35 jwt 2006-10-11 08:25:02 UTC
Can we have an answer to this, please?  Not only can I not set my 'User-defined
dictionaries' path, but also the settings in Common.xcu seem to be being ignored
by 2.0.4rc3.
Comment 36 pb 2006-10-11 10:15:53 UTC
pb: with 2.0.4 there is a new xcu-file: paths.xcu. Here you can change the paths
which are not shown on the UI. At the moment it is not planned to restore more
paths.
Comment 37 jwt 2006-10-11 12:16:39 UTC
>with 2.0.4 there is a new xcu-file: paths.xcu. Here you can change the paths
which are not shown on the UI.

OK, I have worked out how to do this.  It needs a corresponding entry in Common.xcu

>At the moment it is not planned to restore more paths.

So then a new issue does need raising if we want other paths restoring? 
Comment 38 jwt 2006-10-12 06:32:03 UTC
See issue 70333 for User-defined dictionaries
Comment 39 matthias.mueller-prove 2007-01-02 11:55:17 UTC
closing - template path is back