Issue 6489 - "Reveal Codes" feature
Summary: "Reveal Codes" feature
Status: CLOSED DUPLICATE of issue 3395
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.0.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-20 12:04 UTC by oblomov
Modified: 2003-09-08 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description oblomov 2002-07-20 12:04:49 UTC
Implement a "Reveal Codes" window pane which shows where all the formatting starts and ends. When 
the pane is off, nothing changes in the user interface; when the pane is on, cursor consider 
formatting codes as tokens (and can therefore be "on the left" or "on the right" of these codes (in 
the editing window the cursor doesn't change position), thus allowing the user to:
(1) 
position the entry point precisely wrt to formatting ("in" on "out")
(2) remove formatting 
with a single keypress (delete or backspace, depending on which side of the code it is on)
Also, 
these codes should be active areas: double-clicking on them would trigger the appropriate 
formatting dialog.

I know there are "no codes to reveal" in OOo, yet as it has been longly 
discussed in the discuss mailing list, this feature can be achieved by taking advantage of the 
code used by the .sxw read/save filter, by "XMLizing" (in the sense of what is used to produce 
content.xml) the surroundings of the cursor only.
Comment 1 foskey 2002-07-22 23:52:06 UTC
There is already an issue open on this.

*** This issue has been marked as a duplicate of 3395 ***
Comment 2 michael.bemmer 2003-03-11 17:20:52 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 3 michael.bemmer 2003-03-11 17:24:03 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 4 michael.bemmer 2003-03-11 17:26:06 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 5 michael.bemmer 2003-03-11 17:35:36 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details.