Issue 65043 - Wordart Object doesn't like CTL Characters from imported XLS document.
Summary: Wordart Object doesn't like CTL Characters from imported XLS document.
Status: CLOSED DUPLICATE of issue 35203
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 680m163
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: hdu@apache.org
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-03 14:43 UTC by frank
Modified: 2013-08-07 15:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description frank 2006-05-03 14:43:47 UTC
open the XLS document from Issue 38476 with a Linux patch installation
As you can see, you get only three 'dots' in 3D view. A fully installation of
this cws will show the correct characters.
Comment 1 sven.jacobi 2006-05-03 15:09:22 UTC
sj->hdu: Thanks for taking over this issue.
Comment 2 hdu@apache.org 2006-05-03 15:42:55 UTC
You should both installations on the same machine, there are quite different
fonts installed on them...

The availability and non-availability on fonts may make the difference between
working directly or hitting the problem outlined in issue 35203.
Comment 3 hdu@apache.org 2006-05-04 12:32:43 UTC
I analyzed the difference between the original problem, the situation on an
unpatched SO680m124, the situation of a SO680m124 patched with a SO680m163 patch
from the master and a situation with a SO680m124 patched with a patch from the
CWS  impress92.

Here is the detailed result from the long analysis:
-the situation is the same on m124, m124+pm163 and m124+pcws_impress92 => they
don't see and find the important FZ* fonts
- the situation where an m124+pcws_impress92 was started under different
circumstances, in particular on another computer and with another display is
different => the FZ* fonts are found.

Having or not having the FZ* fonts for your test case makes all the difference
in the world, because they are one of the few fonts that have all the required
glyphs.

Since
- psprint gets its font paths also from the X11 display
- the font paths provided by different X11 displays were different
- the font repoirtoire on different machines was different

this can explain why the FZ* fonts were also found when they were later run on
the same machine on the same display, because psprint was able to remember the
font paths provided by the other display...

Executive summary: Nothing to see here, except for the old issue 35203

*** This issue has been marked as a duplicate of 35203 ***
Comment 4 hdu@apache.org 2006-05-04 12:33:53 UTC
Closing duplicate.
Comment 5 hartsambatchvolv 2010-11-10 16:32:11 UTC
Created attachment 73210
Comment 6 Unknown 2010-11-12 10:30:28 UTC
Created attachment 74703