Issue 65295 - Add Landscape page style to built-in styles for Writer
Summary: Add Landscape page style to built-in styles for Writer
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 680m167
Hardware: All All
: P3 Trivial with 18 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 96864 105702 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-05-11 12:21 UTC by valdisvi
Modified: 2013-08-07 14:43 UTC (History)
8 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
proposed patch (3.64 KB, patch)
2008-09-06 12:41 UTC, rail_ooo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description valdisvi 2006-05-11 12:21:25 UTC
This is cumbersome defect in OO that it has no built-in Landscape page style for
Writer.
Especially it burdens when OO-dev builds are used (which comes quite frequently)
because after each install my own custom Landscape style is lost.
Comment 1 michael.ruess 2006-05-11 12:50:54 UTC
Reassigned to requirements.
Comment 2 pagalmes.lists 2006-08-01 16:25:58 UTC
+1

The landscape page style is one of the most useful for many users, so adding it
as a default style would also make sense to me.
Comment 3 kpalagin 2007-01-27 17:59:51 UTC
Dear developers,
any chance of implementing this enhancement in either 2.2.1 or 2.3?
Comment 4 pagalmes.lists 2007-03-31 13:04:20 UTC
Any news about this ?
Comment 5 kpalagin 2007-08-22 12:01:26 UTC
Dear developers,
please consider this essential enhancement for 2.4.
Thanks a lot.
WBR,
Kirill Palagin.
Comment 6 Mathias_Bauer 2007-08-23 09:28:17 UTC
I wanted to discuss that with fl as soon as he is back from vacation; adding
this style surely isn't a problem. The question is whether adding *one* style is
enough or if we need more of them (we also don't have only one "portrait" like
style).
Comment 7 chkur 2007-09-12 07:57:25 UTC
I partially resolved this problem by writing extension. By pressing button I 
create new style from current style just changing page orientation only.
Comment 8 kpalagin 2007-10-31 21:05:24 UTC
I guess we have missed 2.4 for both this issue and 
http://www.openoffice.org/issues/show_bug.cgi?id=17203.

Not good.
Comment 9 Mathias_Bauer 2008-01-31 16:47:30 UTC
taking over
Comment 10 max.odendahl 2008-02-12 15:47:18 UTC
@mba:

talking about styles here, I think it would also make sense to set the next
style of "Left Page" to "Right Page", and next style of "Right Page" to "Left
Page" accordingly. I guess they are used most of the time (always?) together and
this would save a lot of clicks and modifications.
Comment 11 max.odendahl 2008-05-19 00:00:06 UTC
mod->mba:

just had to do the left - right page style thing again, really annoying. Could
you please set a target for this issue? Still some time left to work on default
page styles for OOo 3.0?

no, this is not the number one reason why I do not switch with my 50000
employees to OOo :-)
Comment 12 rail_ooo 2008-09-06 12:40:30 UTC
Attached is a simple patch which adds "Landscape" page style. Please review.

Set type to PATCH.
Comment 13 rail_ooo 2008-09-06 12:41:08 UTC
Created attachment 56280 [details]
proposed patch
Comment 14 Mathias_Bauer 2008-09-08 10:22:44 UTC
Thanks for the patch. Oliver, please take over. 
Comment 15 Oliver Specht 2008-09-08 10:30:01 UTC
.
Comment 16 Oliver Specht 2008-09-10 13:09:59 UTC
Patch integrated in cws os120 - additional change in 
sw/source/ui/chrdlg/break.cxx
Comment 17 Oliver Specht 2008-10-21 08:52:26 UTC
Reassigned for verification
Comment 18 michael.ruess 2008-10-24 13:18:27 UTC
Verified in CWS os120.
Comment 19 Regina Henschel 2008-12-03 20:14:42 UTC
*** Issue 96864 has been marked as a duplicate of this issue. ***
Comment 20 michael.ruess 2009-01-09 10:30:34 UTC
Checked in DEV300m38 (OOO 3.1 dev build).
Comment 21 michael.ruess 2009-10-08 08:45:28 UTC
*** Issue 105702 has been marked as a duplicate of this issue. ***