Issue 65549 - Plotting of missing values (leave gap,assume zero,continue line)
Summary: Plotting of missing values (leave gap,assume zero,continue line)
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: chart (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: kla
QA Contact: issues@graphics
URL: http://specs.openoffice.org/chart/Mis...
Keywords: ms_interoperability, rfe_eval_ok
: 3411 74204 94365 (view as issue list)
Depends on: 91899
Blocks: 64819 72764 86346
  Show dependency treegraph
 
Reported: 2006-05-18 16:14 UTC by IngridvdM
Modified: 2013-02-24 21:22 UTC (History)
6 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch_080110 (7.54 KB, text/plain)
2008-01-11 01:32 UTC, weiz
no flags Details
patch_080129 (10.46 KB, text/plain)
2008-01-29 05:22 UTC, weiz
no flags Details
TCS_Plotting_of_missing_values (11.16 KB, text/html)
2008-04-15 16:05 UTC, kla
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description IngridvdM 2006-05-18 16:14:18 UTC
If a data range for a series does contain empty cells one can think of different
ways to handle those. For example:
a) don't pain't
b) assume zero
c) interpolate value
It should be possible for the user to choose which handling he would like to use.

Further details have to be specified, e.g.
-what about invalid values
-empty values in x-ranges
-zero option in logarithmic charts
-maybe an automatic flag to handle the different default behaviours of scatter
and line charts (Line Chart->don't paint, Scatter->Interpolate).
Comment 1 IngridvdM 2006-05-18 16:15:06 UTC
accepted
Comment 2 IngridvdM 2007-10-08 10:16:37 UTC
->bm, please take over.
Comment 3 IngridvdM 2007-10-25 07:55:44 UTC
changing target due to limited resources
Comment 4 IngridvdM 2007-11-07 19:36:50 UTC
*** Issue 74204 has been marked as a duplicate of this issue. ***
Comment 5 bjoern.milcke 2007-12-18 08:53:30 UTC
For the file-format specification see
http://lists.oasis-open.org/archives/office/200702/msg00009.html
Comment 6 bjoern.milcke 2007-12-19 12:59:51 UTC
About placing the UI controls for this:

I think there are basically two places where the controls could be placed.

1. In the chart type dialog (and therefore on first page of the wizard). This is
a property at the diagram, and the chart type is the closed choice. It would
have to appear on all chart-type option panels for the following types: line,
scatter (only if points are connected?), area, net, but also bar/line combi chart.

Due to limited space on that pages I would suggest to use a different place:

2. The options tab page of a data series. It is not ideal, but conforming to the
chart-type specific controls like gap-width, overlap and "bars side-by-side" for
bar and column charts. There is enough space to add radio buttons and maybe
additional check boxes.
Comment 7 weiz 2008-01-11 01:31:25 UTC
->bm, iha: The attached is the patch of this issue, I think it's not the final 
patch, I just want to show you what I have done, and to confirm whether it's 
correct or not. I will change or improve it according to your suggestions. :-)
Comment 8 weiz 2008-01-11 01:32:22 UTC
Created attachment 50794 [details]
patch_080110
Comment 9 IngridvdM 2008-01-14 17:34:06 UTC
->weiz: The things written to the files need to be changed. Please look at the
file format definition:
http://lists.oasis-open.org/archives/office/200702/msg00009.html
The attribute is defined to have the name 'treat-empty-cells' not 'nan-data-handle'.
Furthermore the new token is not of type number but instead three different
string should be written to the file, dependent on the choice:
'use-zero' or 'leave-gap' or 'ignore'. As an example look at the token
'label-position'.

Regarding the UI strings I would call the second radio button 'Use zero' or
'Assume zero' or similar. Thus it is more consistent with the other descriptions.

Please try to move the new controls upwards for line charts. It looks very
strange at the moment with that much unused space in between. You can change the
positions of the controls also from c++ code. Please try to move them up
depending on the show/hide behavior of the previous controls in
SchOptionTabPage::Reset.

There needs to be done something around the default values also I think. It is
not so nice to have nothing checked when opening the dialog. Have a look how
this is handled for the new label placements
ChartTypeHelper::getSupportedLabelPlacements as an example.
Comment 10 weiz 2008-01-29 05:20:55 UTC
->iha, bm: The new patch is finished, it's beased on m243. Please let me know 
your suggestions. Thanks a lot!
Comment 11 weiz 2008-01-29 05:22:04 UTC
Created attachment 51217 [details]
patch_080129
Comment 12 IngridvdM 2008-02-20 16:51:06 UTC
->weiz: Thanks for the patch! I've looked at it and did some additional changes
during your vacation as communicated via mail. When the previous chart feature
CWS chart19 is integrated I will create a new CWS chart22 based on that new
master and check in your patch including my additional changes.
Comment 13 IngridvdM 2008-02-22 10:33:57 UTC
Fixed in CWS chart22. For the details have a look at the specification:
http://specs.openoffice.org/chart/MissingValues.odt
The im/export to xcel wil be implemented with issue 86346.
->Thomas, please verify.
Comment 14 kla 2008-04-15 16:05:42 UTC
Created attachment 52828 [details]
TCS_Plotting_of_missing_values
Comment 15 kla 2008-04-16 13:30:38 UTC
Seen ok in CWS chart22 -> verified
Comment 16 IngridvdM 2008-07-11 09:32:43 UTC
The integration of this fix to the OOo 3.0 code line was refused so I change the
target to OOo 3.1.
Comment 17 IngridvdM 2008-09-16 13:45:13 UTC
*** Issue 3411 has been marked as a duplicate of this issue. ***
Comment 18 IngridvdM 2008-09-30 15:01:56 UTC
*** Issue 94365 has been marked as a duplicate of this issue. ***
Comment 19 kla 2008-12-22 09:12:18 UTC
Seen ok in current master(m37) -> closed