Issue 65566 - Right Click/Context menu causes Writer to freeze completely
Summary: Right Click/Context menu causes Writer to freeze completely
Status: CLOSED DUPLICATE of issue 61775
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.2
Hardware: PC Linux, all
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
Keywords: oooqa
Depends on:
Reported: 2006-05-19 05:47 UTC by taladan
Modified: 2006-06-30 22:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description taladan 2006-05-19 05:47:05 UTC
The short:

I first noticed this behaviour when I upgraded to fedora Core 5.  I did a fresh
install and after working with a document (no particular format) I tried to
right click to pull up the context menu.  It caused the doc to freeze.  Now,
every time I work on a document, even if it's opening up a fresh instance of
Writer, and right click, it freezes completely and I end up having to terminate
the process.  I've not tried it on any other OS's as I don't have any installed
to test it on.

I upgraded to OOo 2.0.2 and am still getting this (much) undesired crashing
effect.  I'm a bit unfamiliar with the issue tracking system so I was unable to
locate anything that resembled my problem, so I hope this isn't a replication of
an already reported issue.  I can get around the issue by judicious use of the
menus but it slows the work, and definitely isn't intended behaviour.  For
system information, here's a print out of my uname:

Linux localhost.localdomain 2.6.16-1.2111_FC5 #1 Thu May 4 21:16:58 EDT 2006
i686 athlon i386 GNU/Linux

if you have any questions about this, please feel free to contact me at
Comment 1 michael.ruess 2006-05-19 07:58:29 UTC
Reassigned to ES.
Comment 2 eric.savary 2006-05-19 09:59:18 UTC
1) No freeze or problem in any other application than OOo?
2) which window manager do you use?
3) Does it also freeze when you press Shift+F10 (Context menu shortcut)?
4) Does it also frreze when you start OOo like this:
- in a terminal, set the variable:


or, depending on the shell:


Note: if you use KDE, try vslue "gtk", for Gnome, use "kde".

- start OOo from this terminal.
Comment 3 taladan 2006-05-19 16:09:03 UTC
Answers to questions:

1) No - in fact the only portion that I've noticed freezing on OOo is the
Writer. I've been able to successfully use the spreadsheet with right clicking
and it does fine.

2) KDE

3) Yes.  No matter how I try to open the context menu it causes writer to

4)  Tried running with the environment variable SAL_USE_VCLPLUGIN set to gtk and
run from that terminal.
Comment 4 taladan 2006-05-19 16:10:30 UTC
Gah....clicked submit before I was fully awake - #4 - failed miserably.
Comment 5 eric.savary 2006-05-19 16:30:56 UTC
Good morning, then! ;)

What yo you exactly mean with your last statment?
1) it failed to use "gtk"
2) even with "gtk" set, the context menu freezes OOo?

Plus: you talk about "freeze/crash". It must be one or the other. If you get a
crash, the please send a crash report!.
Comment 6 taladan 2006-05-19 16:43:39 UTC
heh, thanks ;)

Okay:  With the envvariable set the context menu still freezes OOo.  

And sorry for the indistinction. It's a 'Freeze'.  When I right click it stops
completely and just sits there.  if I switch to a different window and switch
back it doesn't even show my doc, just a tan window with the menu list at the
top, completely unclickable.  I let it sit that way one night for about half an
hour.  The only way to get out of it is to (heh) Right click the program tab in
the toolbar and select 'Close'.  It then thinks for about a minute and a half
and says  :

Window with title "Untitled1 - Writer" is not responding. This
window belongs to application 2.0 (PID=32227, hostname=localhost).
Do you wish to terminate this application? (All unsaved data in this application
will be lost.)

then gives me a button titled 'Terminate' and one titled 'Keep Running'.

If I press the one marked 'Keep Running' it continues to remain frozen.  If I
click 'Terminate' it kills that process and exits - never giving me the option
to report a crash.

When I open OOo back up it offers to do document recovery to the last good save
point (I save early and often, specifically for this reason) and I can continue
working with the document....until I forget and Right Click again or try to open
a context menu somehow.

Comment 7 eric.savary 2006-05-19 16:53:40 UTC
mmh... It doesn't look good, sorry! :(
AFAIK: We've never got such a feedback, so I guess there is something wrong
between Fedora Core 5 and OOo... "Last lame tip": does it help if you use
another mouse driver? Please try it if you can.:
Comment 8 taladan 2006-05-19 17:10:59 UTC
Well Dang....that's no good....OOo is my primary office component. 
Unfortunately I don't think it's the mouse driver, as it freezes whenever I do
SHIFT+F10, Right Click the mouse, or hit the 'Context' button on my keyboard
(right hand beside the CTRL key).  since OOo is the only thing that's doing this
I don't think that'd point to a driver issue....but since I'm not a coder, I
can't dig into it and find out for myself.  I guess I'm pretty well stuck with
it until more people report the problem, eh?  Gah.
Comment 9 eric.savary 2006-05-19 18:08:46 UTC
Last thing for today: would it bother you to give me a vnc connection to your
computer (of course, you would give me the data via e-mail, not in this issue!)
so that I can "feel" what happens?
Comment 10 bytesmythe 2006-06-05 11:59:14 UTC
My wife experiences the same behavior on her computer. Here's the info for her

AMD 64 bit CPU
Ubuntu 6.06
Linux hostname 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686 GNU/Linux
OpenOffice 2.0.2

We're running the 32-bit version of Ubuntu so we can use Java/Flash/etc.
Whenever she right-clicks in Writer, it completely freezes. 

We haven't tried setting the aforementioned environment variable. As soon as
she's done printing in a few minutes, we'll try it and post the results.
Comment 11 taladan 2006-06-05 14:53:00 UTC
Alright, an update.  Es, sorry I was unable to get back to you on the VNC thing
- school and work have dragged me down horribly.  

Here's what I've done to try and resolve this issue:

I tried hitting a yum update from the development repo from redhat.  When I did
that OOo wouldn't even start, kept getting errors after the splash screen and an

So I removed OOo entirely from my system and went to the home page and dl'd the
'stable' release from the front page, with JRE support.  Installed JRE on my
system from Java, then installed the rpm of OOo...and I /still/ am getting this
behaviour.  At this point I feel like it may be something in the newer kernel(s)
that's not handling a request from OOo on-right click....but only in the
writer???  That's what blows me away.

I'd gladly let you log in via remote control, but I don't have a VNC server set
up on this machine and I've never done that on linux, so I honestly am at a loss
on how to let you log in to see what it's doing.  

As an aside bytesmyth, sorry to hear that you're getting the same functionality
issue, but glad to see I'm not the only one (means I'm not crazy!).  I have
found that (sometimes) I can leave the app alone and it will eventually unfreeze
after about 20 minutes, or if I do a kill -1 on the process, but still no
context menu and it just freezes right back up when I right click again.

It's crippling to standard usage in writer - specifically when I screw up and
forget that it doesn't work and accidentally right click :|.

Comment 12 taladan 2006-06-05 15:08:11 UTC
Alright, I think I may have another issue that may be causing this.  On a random
whim, I found these two things:

which led me to this issue:

I have somewhere in the neighborhood of ~ 6,000 fonts installed on my system. 
from what these guys are saying, that may well be the issue?

Hope this helps...

Comment 13 taladan 2006-06-05 15:31:59 UTC
Alright...last (hopefully) post for today.  After finding the previous post and
issue, I went in and moved my .fonts (personal fonts folder) to a backup folder
so it would be out of my usual path, and now, OOo writer allows me to right
click with only a 2 second hesitation.  

The fonts option in the context menu is causing it to screw the pooch on
context...I hope there is an easy fix for this or a way to remove the fonts
option from the context menu all together.  I'm looking now, but I don't see a
way (yet).  I'd /really/ like to be able to keep my fonts as they're extremely
useful to me obi wan, you're my only hope!

Comment 14 bytesmythe 2006-06-06 20:38:44 UTC
Ahhh! My wife also has about 7500 fonts installed. I guess we'll have to move
them until this issue is taken care of.

Thanks for the helpful update! :)

Comment 15 hwoarang 2006-06-30 22:56:20 UTC
Same request reported in issue 61775.

Closing as duplicated.

Please, move your votes to issue 61775 and promote it (if you want), trying to
get it for any 2.x release if possible.

Thank you.

*** This issue has been marked as a duplicate of 61775 ***
Comment 16 hwoarang 2006-06-30 22:56:52 UTC
closing as duplicated.