Issue 65726 - Field ignored by auto correct for "Start sentence with capital letter"
Summary: Field ignored by auto correct for "Start sentence with capital letter"
Status: CLOSED DUPLICATE of issue 17449
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0.2
Hardware: All Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-05-23 16:49 UTC by sfriedman
Modified: 2007-08-22 22:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screen capture of type=Table. (67.33 KB, application/msword)
2006-11-28 17:14 UTC, sfriedman
no flags Details
sample document (54.30 KB, application/vnd.oasis.opendocument.text)
2007-01-01 11:01 UTC, Rainer Bielefeld
no flags Details
file showing bug still in OOo2.1 (US english) (7.22 KB, application/vnd.sun.xml.writer)
2007-01-02 21:08 UTC, sfriedman
no flags Details
First letter becames small capital & looses highlighted (68.50 KB, text/plain)
2007-08-22 22:55 UTC, metafora9
no flags Details
First letter becames small capital & looses highlighted (68.50 KB, application/msword)
2007-08-22 22:56 UTC, metafora9
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sfriedman 2006-05-23 16:49:45 UTC
The first 'word' in the sentence was the reference that was displayed as "Table
1".  Ooo was auto-capitalizing the second word in the sentence as it did not
recognize the reference as the start of the sentence.
Comment 1 sfriedman 2006-05-23 18:55:27 UTC
This bug does not occur if the incident-sentence is the first sentence of the
paragraph.
Comment 2 michael.ruess 2006-05-24 06:40:48 UTC
Reassigned to SBA.
Comment 3 parity 2006-05-27 20:28:08 UTC
I can confirm this bug. I inserted a Table in a document. Then I started a
paragraph and wrote:
"Hello. Table 1 Shows ..."

Table 1 was the reference to the table and OpenOffice.org converted the small "s".
Comment 4 kpalagin 2006-11-25 14:27:00 UTC
sfriedman, parity,
please specify how you inserted a reference to the table.
Comment 5 sfriedman 2006-11-27 15:52:22 UTC
Select Insert | Cross Reference.

In the cross-reference dialog box, select type=Table, then Selection="Table 1",
and finally format="Category and Number".  Then hit the insert button.
Comment 6 kpalagin 2006-11-28 16:18:14 UTC
sfriedman, 
I do not see where you can "select type=Table". Any chance of attaching 
screenshot (or two)?

Thanks a lot.
WBR,
K. Palagin.
Comment 7 sfriedman 2006-11-28 17:14:57 UTC
Created attachment 40975 [details]
screen capture of type=Table.
Comment 8 sfriedman 2006-11-28 17:16:23 UTC
Note that the type=Table only shows up if a table has been inserted into the
document already.
Comment 9 Rainer Bielefeld 2007-01-01 11:00:52 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" and was NOT
able to reproduce the problem, pls. see attached sample document.

@sfriedman 
Please specify your Platform and OS (WIN XP?). 
Please attach a sample document.
Comment 10 Rainer Bielefeld 2007-01-01 11:01:38 UTC
Created attachment 41806 [details]
sample document
Comment 11 sfriedman 2007-01-02 21:06:38 UTC
The attached file was created with OOo 2.1 on Windows XP Pro SP2.
Comment 12 sfriedman 2007-01-02 21:08:09 UTC
Created attachment 41840 [details]
file showing bug still in OOo2.1 (US english)
Comment 13 Rainer Bielefeld 2007-01-03 08:35:24 UTC
Yes, now I found what causes the problem. It seems that the autocorrect function
does not recognize any field after the full stop of the sentence before, so that
it recognizes the first "real" word as the absolutely first word of the sentence.

In the example from 'bug-65726.odt' "Table 1" after " ... of the para." is not
recognized as a word, Autocorrect takes "Shows" for the first word and changes
the "s" to a capital letter.

It seems to happen for to all fields (I tested several) and also in DRAW and
IMPRESS text fields.

That's a known problem.

*** This issue has been marked as a duplicate of 17449 ***
Comment 14 Rainer Bielefeld 2007-01-03 12:00:44 UTC
@sfriedman 
Thank you for your contribution!
Comment 15 metafora9 2007-08-22 22:55:22 UTC
Created attachment 47732 [details]
First letter becames small capital & looses highlighted
Comment 16 metafora9 2007-08-22 22:56:46 UTC
Created attachment 47733 [details]
First letter becames small capital & looses highlighted