Issue 65798 - Controls anchored as char initially shown in wrong position; good after re-formatting
Summary: Controls anchored as char initially shown in wrong position; good after re-fo...
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 73845 74240 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-05-26 20:23 UTC by norbert2
Modified: 2013-08-07 14:42 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Zeiterfassung.odt (18.71 KB, application/vnd.oasis.opendocument.text)
2006-05-26 20:25 UTC, norbert2
no flags Details
PDF with destroyed layout (54.95 KB, application/pdf)
2006-05-26 20:26 UTC, norbert2
no flags Details
checkboxes_page_preview.png (80.11 KB, image/png)
2007-11-30 16:24 UTC, norbert2
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description norbert2 2006-05-26 20:23:03 UTC
hi,

- please open the attached document: note the bad positions of the checkboxes,
especially the 3 checkboxes "Vormittag, Nachmittag and 1/1 Tag". the other
checkboxes are displayed to far up.

- open and close the page preview: everything is OK now.

NOTE: if you do a PDF export without a page preview before, the bad layout is
printed into the PDF! I guess that normal printing is also affacted, but I have
not tested it.

This makes this bug a P2 problem in my oppinion. We can't expect that the user
performs a page preview befor each printig/pdf export!

Please also have a look at issue 60143.
Comment 1 norbert2 2006-05-26 20:25:08 UTC
Created attachment 36737 [details]
Zeiterfassung.odt
Comment 2 norbert2 2006-05-26 20:26:45 UTC
Created attachment 36738 [details]
PDF with destroyed layout
Comment 3 norbert2 2006-05-27 14:18:18 UTC
I just have tested printing: The bad layout is also printed to paper!
Comment 4 michael.ruess 2006-05-29 13:14:53 UTC
MRU->OD: the checkboxes in the table(s) are positioned wrongly right after
opening the document. They should be placed on the baseline, but they are
shown/aligned at the top of the line. Whe initiating a re-formatting (e.g.
moving the cell border with mouse) the position will be corrected.
As long as this was ok in OO 1.x we should fix this for one of the next OO 2
updates.
Comment 5 norbert2 2006-06-25 09:50:16 UTC
Why no response anymore?

I tink this bug should be fixed as soon as possible.

Having forms displayed and printed with destroyed layout is a big limitation in
the usability of StarWriter!
Comment 6 Oliver-Rainer Wittmann 2006-06-26 05:59:41 UTC
accept to fix on target OOo 2.x
Comment 7 Oliver-Rainer Wittmann 2007-01-25 10:35:29 UTC
*** Issue 73845 has been marked as a duplicate of this issue. ***
Comment 8 Oliver-Rainer Wittmann 2007-01-25 10:38:21 UTC
Investigation reveals, that the as-character anchored check boxes aren't
positioned correctly, if the content, which contains the as-character anchored
check box, is vertical aligned centered in a table cell.
Comment 9 michael.ruess 2007-02-07 09:17:55 UTC
*** Issue 74240 has been marked as a duplicate of this issue. ***
Comment 10 norbert2 2007-07-20 20:02:26 UTC
I really hate this bug!

Wouldn't it be possible to target it to OOo 2.3?
Comment 11 Oliver-Rainer Wittmann 2007-07-25 07:17:42 UTC
I also hate this defect. But, a fix for OOo 2.3 isn't possible due to lack of
resources and the near deadline of OOo 2.3 code freeze date (2007-08-02).
I will consider this issue for OOo 2.4
Comment 12 Oliver-Rainer Wittmann 2007-11-30 13:53:42 UTC
fixed in cws sw8u10bf02 - changed files:
/sw/source/core/text/porfly.cxx, 1.36.96.1
/sw/source/core/layout/anchoreddrawobject.cxx, 1.23.96.1

defect cause:
<PosAttrSet> attribute at <SwDrawFrmFmt> instance of as-character anchored
drawing objects (shapes and controls) aren't set. Thus, during alignment of
table cells these drawing objects are positioned correct.
Comment 13 norbert2 2007-11-30 16:22:14 UTC
The attached document also shows a problem with the Page Preview.
If you enter the page preview and select "1 x 1 Pages" so that the page is
centered, checkboxes are displayed left in the gray area.

Please clarify, if your fixed code also fixes this bug.

(I will attache a screenshot.)
Comment 14 norbert2 2007-11-30 16:24:14 UTC
Created attachment 50027 [details]
checkboxes_page_preview.png
Comment 15 Oliver-Rainer Wittmann 2007-12-03 07:06:17 UTC
The described problem in the print preview is not fixed by applied fix.
Investigation reveals, that this defect only occurs with controls and it is
independent of the anchor type.

OD->nobert2: Please submit a new issue for this problem in the print preview.You
can assign this issue directly to me. Thx.
Comment 16 norbert2 2007-12-03 20:06:54 UTC
Page preview bug is issue 84210.
Comment 17 Oliver-Rainer Wittmann 2007-12-04 14:51:05 UTC
OD->MRU: Checked in internal installation set of cws sw8u10bf02 - please verify.
Comment 18 Oliver-Rainer Wittmann 2007-12-04 14:55:59 UTC
reassign to MRU for verification
Comment 19 michael.ruess 2007-12-10 15:18:53 UTC
Verified fix in CWS sw8u10bf02.
Comment 20 michael.ruess 2008-07-15 09:27:42 UTC
Checked in OO 2.4.1 and OO3.0 DEV300m24 build.