Issue 66285 - Search & Replace should have an MS compatibility mode
Summary: Search & Replace should have an MS compatibility mode
Status: CLOSED DUPLICATE of issue 28913
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-06-09 16:19 UTC by mguenter99
Modified: 2006-06-09 17:44 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mguenter99 2006-06-09 16:19:41 UTC
The users are used to the special characters ^p etc they found with MS Office.
To make migration easier. There must be a compatibility mode which allows to use
the same search and replace pattern. I suggest also to add a new button in the
search & replace menu with "Special characters" or the like.

By the way: Regular expressions are not understood by many people who are IT
specialist. Therefore for big user communities the term and the complexity of it
should be hidden.

How did I came across this. I like to use word processors for complex search and
replace tasks.

I have a document that I prepare to be exported as CSV. 

The document came as MS Word.

The lines looked a bit like that:
   Stimme, Laut, Wort 6	vá»x, vá»cis  f.
   ()
   feierlich versprechen, geloben 34.	vovẹre
   (voveá», vá»vị, vá»tum)
   Gelübde, Wunsch 38	vá»tum
   ()
   ihr 4; euch 19	vá»s
   ()

What I wanted was to replace  "^p()" with " ()" (in Word talk)

My desired result:
   Stimme, Laut, Wort 6	vá»x, vá»cis  f. ()
   feierlich versprechen, geloben 34.	vovẹre (voveá», vá»vị, vá»tum)
   Gelübde, Wunsch 38	vá»tum ()
   ihr 4; euch 19	vá»s ()

I didn't manage to do the work in OOo neither with regular expressions "$\(\)"
nor otherwise. For my problem I will swap to Word to do it or I will to it in vi.

PS: Perhaps this is a core feature. Sorry, if I didn't place it right.
Comment 1 lohmaier 2006-06-09 17:44:34 UTC
duplicate

*** This issue has been marked as a duplicate of 28913 ***
Comment 2 lohmaier 2006-06-09 17:44:50 UTC
closing duplicate.