Issue 66321 - Take system fontconfig into account
Summary: Take system fontconfig into account
Status: CLOSED DUPLICATE of issue 54603
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.3
Hardware: All Unix, all
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-11 20:59 UTC by calande
Modified: 2008-11-05 20:55 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description calande 2006-06-11 20:59:48 UTC
I have a number of rules in my XML files: /etc/fonts/local.conf (Linux) and
/usr/X11R6/etc/fonts/local.conf (PC-BSD; *BSD) that set/unset antialiasing,
rgba, hinting and autohint for each font (free fonts, Microsoft fonts).

OpenOffice.org doesn't take this file into account and instead offers a very
poor setting that is to turn on/off antialiasing at a certain font size for any
font, regardless of fonts caracteristics. Changing the system's settings won't
change OpenOffice.org's settings either, and it's a pity.

The way OpenOffice.org handles antialiasing and fonts is too simple. It should
take the system's fontconfig settings into account so that the whole system
looks more consistent. If every application acted this way, fonts in every
application would look different!

Once you implement a direct connection between OpenOffice.org and the system
fontconfig, you can remove the following entries in OpenOffice.org settings:
"Tools > Options > OpenOffice.org > View"

 - Use system font for interface (remove)
 - Screen font antialiasing (remove)
 - From n pixels (remove)

Afterwards, OpenOffice.org will look exactly the user wants, like the rest of
his desktop. Thank you.
Comment 1 thorsten.martens 2006-06-14 10:46:36 UTC
TM->requirements: please have a look, thanks !
Comment 2 stefan.baltzer 2008-03-10 16:48:38 UTC
Duplicate. Already implemented in OOo 2.4.

*** This issue has been marked as a duplicate of 54603 ***
Comment 3 Mechtilde 2008-11-05 20:55:56 UTC
close the duplicate