Issue 66332 - spellchecker does not warn if no dictionary exists
Summary: spellchecker does not warn if no dictionary exists
Status: CLOSED DUPLICATE of issue 24439
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: oooqa, regression
Depends on:
Blocks:
 
Reported: 2006-06-12 09:01 UTC by justinschauer
Modified: 2006-06-16 13:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description justinschauer 2006-06-12 09:01:25 UTC
If you have text > character > language formatted to some language other than 
one you have dictionaries for, when you run the spell-checker it will claim 
there are no spelling errors rather than informing you that there is no 
dictionary.

to see this bug:
enter some text.
highlight the text.
right click > Character. Under the Font tab select a language that does NOT have 
a check mark next to it (indicating you do not have the dictionary for that 
language).
hit OK.
run the spellchecker (hit F7).
A dialog box will pop up saying "The spellcheck is complete."

There is no indication that it failed due to lack of a dictionary. in fact, it 
seems to be indicating that everything is spelled correctly!

This bug bit me because somehow my installation of OOo had the default language 
set to English (Canadian), and I could not for the life of me figure out why 
spell check would not find even obvious misspellings. Googling the problem 
eventually led to me realizing the Character Language was set incorrectly, and 
also revealed that others have faced this same problem, so it seems worthwile to 
address.

Thanks.
Comment 1 michael.ruess 2006-06-12 09:09:14 UTC
Reassigned to SBA.
Comment 2 atdsm 2006-06-14 20:42:50 UTC
Confirmed - Windows XP, 2.0.3-RC5.

Agreed, spellcheck should give an error message rather than just assume
everything is spelled correctly. I can see how this would confuse the user!

Steve
Comment 3 atdsm 2006-06-14 21:11:52 UTC
This seems to have been an issue before as well; confer issue 18370. According
to i18370, there should be an error message when an unsupported language is
being spellchecked. (Such an error message aparently used to come up in 1.1rc3.)
However, no such error message appears in 2.0. Confer also issue 16940.

I'm going to leave this issue open, as in my opinion this is a useability defect
and (possibly?) represents a regression from 1.1, when aparently an error
message did exist.

Tentatively setting the regression keyword, although I don't have 1.1.x
installed to verify that the error message used to work properly.
Comment 4 atdsm 2006-06-14 21:22:44 UTC
Please confer also issue 24439, which is a feature request to have the
spellcheck option grayed out when not available (among other things).
Comment 5 lohmaier 2006-06-16 12:30:32 UTC
duplicate.

*** This issue has been marked as a duplicate of 24439 ***
Comment 6 lohmaier 2006-06-16 12:30:51 UTC
closing duplicate.
Comment 7 atdsm 2006-06-16 13:28:08 UTC
Please redirect comments and any votes to issue 24439.