Issue 6634 - Link the "help" menu into a simplified Issuezilla interface
Summary: Link the "help" menu into a simplified Issuezilla interface
Status: CLOSED DUPLICATE of issue 124854
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.0.0
Hardware: Other Other OS
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-29 16:29 UTC by ingenstans
Modified: 2019-10-13 18:32 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ingenstans 2002-07-29 16:29:42 UTC
At present the interface to Issuezilla is extremely compicated and off-putting to new users. The 
web site project is doing much to make it less off-putting, and the QA project is trying to 
something in that direction. But I suggest that a new entry for "OpenOffice.org on the Web" be 
added to the help menu of all the main components. Such an entry would look familiar to people used 
to other apps, and would lead to a three clearly explained choices on a sub-menu:

"Suggest an 
enhancement"
"Look for help from other users"
"Report a possible bug"

"Look for help 
from others" would lead to a simple search interface for the user list -- all the search boxes I 
imagine should have google's simplicity as a model. I know the search is available somewhere on 
the IZ site. But no one will find who is not really dedicated. It should be made easily accessible, 
using an url constructed in OO itself. 

"Report a possible bug" would lead to something like 
the URL attached to this issue, but with the query fields for operating system, OO version, 
component, automatically filled out, since the running instnace of the program must have 
access to that information. If the bug is not found, this info should be used to help construct a 
bug report.

"Suggest an enhancement" should lead to a similar searchbox to the "report 
possible bug" -- in case someone else has requested it -- and then a wizard-like interface which talks 
people through the process of joining a project and  then suggesting an enhancement. 

Both of 
these last ideas are designed to make it easy for people to take their first steps into the 
project, and to increase the accuracy of bug reports.
Comment 1 thorsten.martens 2002-07-31 10:06:50 UTC
TM->FT: Another wish for an enhancement ! Please have a look, thanks !
Comment 2 falko.tesch 2003-09-26 15:02:05 UTC
Good idea (repeated for technical reasons):
At present the interface to Issuezilla is extremely compicated and
off-putting to new users. The web site project is doing much to make
it less off-putting, and the QA project is trying to something in that
direction. But I suggest that a new entry for "OpenOffice.org on the
Web" be added to the help menu of all the main components. Such an
entry would look familiar to people used to other apps, and would lead
to a three clearly explained choices on a sub-menu:
"Suggest an enhancement"
"Look for help from other users"
"Report a possible bug"

"Look for help from others" would lead to a simple search interface
for the user list -- all the search boxes I imagine should have
Google's simplicity as a model. I know the search is available
somewhere on the IZ site. But no one will find who is not really
dedicated. It should be made easily accessible, using an url
constructed in OO itself. 

"Report a possible bug" would lead to something like the URL attached
to this issue, but with the query fields for operating system, OO
version, component, automatically filled out, since the running
instnace of the program must have access to that information. If the
bug is not found, this info should be used to help construct a bug report.

"Suggest an enhancement" should lead to a similar searchbox to the
"report possible bug" -- in case someone else has requested it -- and
then a wizard-like interface which talks people through the process of
joining a project and  then suggesting an enhancement. 
Comment 3 falko.tesch 2003-09-26 15:03:00 UTC
Started
Comment 4 falko.tesch 2003-09-26 15:04:58 UTC
Started
Comment 5 ingenstans 2004-01-22 08:39:44 UTC
There has been a flurry of iscussion on the dev@website list, starting here
http://website.openoffice.org/servlets/ReadMsg?list=dev&msgNo=4541
about making a wizard-based set of pages on the web site for epople who need 
support. I think that ought to be co-ordinated with this issue. In fact I think 
the two of them ought to be folded together, but, since I'm not coding, my 
opinion is not much use :-). 

On the other hand, it is important that the effort is not duplicated, and that 
the interface for the naive user be as clear as possible; which is rather why I 
thought this stuff should be reached from the help menu in the program itself.
Comment 6 bettina.haberer 2010-05-21 14:52:59 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 7 oooforum (fr) 2019-10-13 12:30:50 UTC
Already discussed

*** This issue has been marked as a duplicate of issue 124854 ***