Issue 66359 - Hangs when use shell macro in cygwin
Summary: Hangs when use shell macro in cygwin
Status: CLOSED DUPLICATE of issue 51560
Alias: None
Product: Build Tools
Classification: Code
Component: dmake (show other issues)
Version: OOo 2.0.3
Hardware: PC Windows, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: quetschke
QA Contact: issues@tools
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-12 15:03 UTC by suporte
Modified: 2006-06-12 19:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description suporte 2006-06-12 15:03:59 UTC
In my build env, in a winXP, with .net C++ 2003, and cygwin 1.5.19-4, the build
hangs when find command like 'dmake: Executing shell macro:' in many modules.

=============
Building project sj2
=============
/home/filhocf/ooo_OOC680_m5_src/sj2/stardiv/controller
mkout -- version: 1.6
/home/filhocf/ooo_OOC680_m5_src/sj2/stardiv/controllerdmake: Executing shell
macro: -+ls -1 $(JARDIR) | $(GREP) "^$i"
dmake: Executing shell macro: -+ls -1 $(JARDIR) | $(GREP) "^$i"
Making dpj...
dmake: Executing shell macro: +$(STARDEP) @$(mktmp -o $@ -i $(CLASSDIR) 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

The solution is (only!!) resize the window. I tried in rxvt and bash. Both
cases, is only maximize|restaure the size of window, that the build continue.

Claudio
Comment 1 quetschke 2006-06-12 19:17:22 UTC
Noone was able to create a small testcase for this problem, it looks like
you are hitting:

http://wiki.services.openoffice.org/wiki/Windows#Miscellaneous_info

That makes this a dupplicate of issue 51560.

To repeat it again:
 "I could not reproduce the problem on three different machines."
but I believe you that it exists. Unless someone is able to create a small
testcase that reproducable hangs and doesn't require a full OOo build
environment we can only hope that this bug get's fixed "accidentally" by the
cygwin developpers.

P.S.: Did you try a new snapshot? <http://cygwin.com/snapshots/>

*** This issue has been marked as a duplicate of 51560 ***
Comment 2 quetschke 2006-06-12 19:50:39 UTC
close