Issue 66434 - Incorrect Formatting and Printing of Envelopes
Summary: Incorrect Formatting and Printing of Envelopes
Status: CLOSED DUPLICATE of issue 29924
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0.2
Hardware: PC Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2006-06-14 15:10 UTC by wsherwin
Modified: 2008-04-04 11:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
OOo documents for both Env 6 and 10 and PS files showing the results (65.09 KB, application/x-gzip)
2006-06-14 15:20 UTC, wsherwin
no flags Details
Example of envelope which won't print (8.50 KB, text/plain)
2008-04-01 14:21 UTC, anjalip222
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description wsherwin 2006-06-14 15:10:56 UTC
I am having problems both with U.S. Envelope types 6 and 10.  While the
dimensions appear to be correct in the envelope creation box, the print preview
does not show an envelope that looks like the physical envelope - for No. 6,
print preview displays a square - and the fields to not print where they are
supposed to print:

ENVELOPE 6:
The return address attempts to print far to the left of the page, so while the
vertical dimension is correct, the horizontal dimension does not correspond to
the physical envelope.  Similarly, the Addressee field does not print far enough
to the right - and when it is specified to be far enough to the right, OOo
mistakenly believes that it is running against the right-hand margin of the
envelope and therefore splits lines.  When the text box is elongated on the
left-hand side so that lines are displayed as they should be displayed, the
address prints almost in the center of the envelope, slightly to the left.

ENVELOPE 10:
While I have not done as much testing with number 10 envelopes, both the return
address and addressee fields are shifted down and to the right by about one inch
(2.54 cm) in each dimension - thus creating a lopsided (though fortunately still
useable) envelope.  However, the problem remains that the default placements are
incorrect.

These problems occured on a system running Gentoo Linux (frequently updated),
kernel 2.6.16-r9, CUPS 1.1.23-r7, and using a print driver most similar to
laserjet.ppd (with running diff between that and the file in /etc/cups/ppd
showing a difference in two lines).

Final note: Resolution of this issue would probably be of great boon to OOo as
it would remove what I believe to be one of the final serious advantages of MS
Word over OOo.  Thank you, in advance, for your help in resolving this.
Comment 1 wsherwin 2006-06-14 15:20:33 UTC
Created attachment 37152 [details]
OOo documents for both Env 6 and 10 and PS files showing the results
Comment 2 michael.ruess 2006-06-14 15:24:01 UTC
Reassigned to HI.
Comment 3 h.ilter 2006-06-22 12:49:36 UTC
Interesting, I do not get the same result like you.
Could you please give an step by step description how do you create such
envelope. Just give all settings you made within the envelope dialog. Thanks.
Comment 4 wsherwin 2006-06-23 03:03:02 UTC
Perhaps this isn't a problem in the non-US versions, but here's a description of
what I did:

I first selected the appropriate envelope (6 or 10).  Then, using trial and
error, I moved the top and left boundaries of each field until they were where I
thought they should be - except that I could not place them properly.  I have a
number 6 envelope sitting in front of me on which I specified that the Addressee
field should print starting, I believe, approximately 4.5 inches from the left.
 Instead, it printed only one inch from the left.

I am using an HP LaserJet 1200 to print these envelopes, using CUPS 1.1.23-r7. 
Non-envelope documents print without any problems.  The envelope settings are
the same as those that I had in Microsoft Word XP on my Windows 2000 box when
the printer was connected to that box: in the Printer tab, I have selected the
fifth orientation (vertical, centered), printing from the top, with no offset.

Please tell me if any of this information is useful to you...  Thanks for your help.
Comment 5 hardycc50 2007-03-06 13:57:43 UTC
See following:
http://www.oooforum.org/forum/viewtopic.phtml?t=51226&highlight=insert+envelope
The problem occurs when picking center or left feed of document. This problem
has been present for several releases and the forums until now only showed work
arounds.
Comment 6 hardycc50 2007-03-06 13:59:06 UTC
See following:
http://www.oooforum.org/forum/viewtopic.phtml?t=51226&highlight=insert+envelope
The problem occurs when picking center or left feed of document. This problem
has been present for several releases and the forums until now only showed work
arounds.
Comment 7 kpalagin 2007-04-18 04:03:41 UTC
Seems to be dup of http://qa.openoffice.org/issues/show_bug.cgi?id=29924.
Comment 8 anjalip222 2008-04-01 14:16:04 UTC
Hi, this is Anjali Parmar (from India) and I am facing a similar problem with
envelopes, although in a different environment:

OpenOffice version: 2.4.0
Application: Writer
Platform: PC (Intel P-IV 1.7 GHz)
OS: Windows XP SP2

The primary problem is with printing the envelope with my HP 656c printer.

Before going any further, let me first give a short description of what WORKED
for me:
1.) I have been using MS Word to create a user-defined envelope
2.) The envelope page measured 24cm width x 11cm height in Landscape mode
3.) During printing, I aligned the envelope to the RIGHT face of the printer
tray, as I did with all other documents. The stuff printed accurately.

Now, after I have installed OOo Writer 2.4.0 just two days back, I wanted to do
the same. So...
1.) I created a file, went to page setup, and entered the width as 24.0 cm and
height as 11.0 cm in Landscape mode. Top margin is 2.5 and left margin is 10.0.
2.) Rest everything is set to default.

I open the file (say envelope.odt) entered a text and started printing a page.
Note that I have used the same printer with the system driver that I had earlier
used with MS Word. No printer setting has been modified. Also note that the page
is NOT defined as envelope in OOo Writer, only as a USER page.

The procedure is as follows:
1.) Open the printer tray
2.) Feed an envelope page with its LONGER side aligned to the direction of feed
3.) The longer side of the page is TOUCHING the RIGHT face of the printer tray

When the print command is given, I observe the following:
1.) The paper is drawn in, there is sound of printing
2.) The envelope comes out, but... NOTHING IS PRINTED... THE WHOLE PAGE IS BLANK
3.) I test the same with an A4 paper, and I see that the text IS printed but on
the LEFT side of the printer tray.

This is unusual and buggy because by default, all documents in OOo Writer and MS
Word (at least in my PC) print with reference to the RIGHT hand of the printer.
That is, if I align the page with the RIGHT face of the printer tray, the LEFT
margin of the page will be maintained.

But when the ENVELOPE is inserted, OOo Writer ignores the RIGHT face and starts
printing from the LEFT face, as a result, the ink does not 'fall' on the actual
envelope, and despite the printer ACTUALLY printing, the envelope comes out blank.

Workaround: In Format -> Page settings, I specify an A4 page in Landscape mode.
The margins are set wildly to the LOWER RIGHT of the page where text is to be
entered. This is because Writer behaves 'better' with A4 paper than with the
envelope paper. NOW, if I feed the bare envelope into the printer (not an A4
paper)... voila, the print is immaculate.

Why the problem affects me severely: 01-Apr-2008 is the beginning of a new
financial year, and I had personally planned to dump MS Office and switch
COMPLETELY and FULLY to OpenOffice. So I created new documents and templates to
 transfer all my work into OOo documents. Alas, I bumped into this nasty
envelope problem where the page appears OK in the Print Preview, but when you
actually go ahead to print it, it doesn't.

I agree with the discoverer of this issue: This problem has forced me to rethink
 if really MS Word is dispensible. Maybe it isn't because OOo Writer is still
not doing things as properly and completely as is required in a professional field.
Comment 9 anjalip222 2008-04-01 14:21:27 UTC
Created attachment 52436 [details]
Example of envelope which won't print
Comment 10 kpalagin 2008-04-01 14:28:42 UTC
anjalip222,
please see if http://qa.openoffice.org/issues/show_bug.cgi?id=29924 describes 
your problem.
If yes, please vote for 29924 and post your finding there.
Thanks.
Comment 11 h.ilter 2008-04-04 11:36:02 UTC
Double to 29924

*** This issue has been marked as a duplicate of 29924 ***
Comment 12 h.ilter 2008-04-04 11:36:42 UTC
.