Issue 66520 - Outline destroyed when pasting text from Word as RTF
Summary: Outline destroyed when pasting text from Word as RTF
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.2
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2006-06-16 20:00 UTC by parity
Modified: 2017-05-20 11:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Here you can see the additional wrong heading styles (70.50 KB, image/png)
2006-06-17 10:02 UTC, parity
no flags Details
Here is the damaged document containing only some example text (14.39 KB, application/vnd.oasis.opendocument.text)
2006-06-17 12:01 UTC, parity
no flags Details
Document to show the outline problem when pasting (49.50 KB, application/msword)
2006-06-20 13:03 UTC, michael.ruess
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description parity 2006-06-16 20:00:42 UTC
I just recognized a really serious bug, which is definitely a P1 bug in 2.0.2.

My girlfriend writes a really big document in Writer. It contains a lot of
OLE-objects, pictures (which are linked in most cases) and a lot of styles and
formatting. It just reached a size of 13 MB.

She saved it a few days ago and reopened it today. Alle the headings are not
numbered anymore. They are still declared as "Heading 1", "Heading 2" and
outline numbering is activated, but still the numbers are not displayed. I tried
to click on the headings and activate the numbering. This works for "Heading 1"
but "Heading 2" gets numbered as if it is a "Heading 1". Additionally, the table
of contents gets filled by the first lines of the document and not with the
headings anymore. Last but not least: the document takes about 3 minutes until
it gets openened.

I am now trying to rescue the document by copying it step by step to a new empty

Since the content of the document is confidential I can not append it to this
report. I will try to delete all the important contents and append it in the
next days, but first I have to rescue all the stuff.

I know that this issue report is not very helpful because I cannot identify the
issue directly, but I thought reporting it is really necessary.
Comment 1 parity 2006-06-16 20:41:39 UTC
Ok, it seems as if I managed it to restore everything by copying everything to a
new document (but not the table of contents, this had to be regenerated).

I think the problem was a pasted part from a Word-document, which disturbed the
"style and formatting". The only entry in the table of contents was from that
part of the document.

Since it seems to be a "inserting of formatted text problem", I think that this
issue can be reduced to P2. Can some, who has the privileges, do that?
Comment 2 Rainer Bielefeld 2006-06-17 08:43:54 UTC
That sounds like a serious problem, but unfortunately currently I do not see any
chance to get that reproducible, so that a developer can search for the reasons.
It would be deserving if you could create a short Word document and a short OOo
document and a step by step instruction how to reproduce the problem by pasting
some contents from the WORD document to the OOo document.
Comment 3 parity 2006-06-17 09:41:25 UTC

I just tried to reproduce the problem by starting a small document and pasting
the mentioned part of the word document. I am sorry, I cannot reproduce this bug
anymore. It happened once and was very unpretty but I cannot attach the big
document because it is confidential.

But I now recognized that the pasted Word-Document contains "styles and
formattings" which are interpreted as "Headings". That's why the table of
contents changed. But still it is not clear why all the Heading Enumerations are
missing and why no other heading is inserted in the table of contents.
Comment 4 parity 2006-06-17 09:56:56 UTC

Ok, now I even have some more informations. By the way: I use the german version

I opened the mentioned document today again and I recognized that in the "styles
and formatting" window, there are defined the normal headings (which are called
"Ãœberschrift 1", "Ãœberschrift 2", ... in German). But the pasting of the
Word-Document declared some additional headings, which are top-level in the
hierarchical view. They have the normal English names ("Heading 1", "Heading 2",
...). The Outline numbering option is now only assigned to these (new) headings.
And even the table of contents does only recognize these new headings. The
normal "Ãœberschrift 1" does not get a number anymore and is not in the table of

So I think this issue should be renamed to: "After pasting of a part of a .doc
file, outline numbering of Headings is broken".

P.S.: The Word Document was opened in and pasted from there to
the mentioned document.
Comment 5 parity 2006-06-17 10:02:52 UTC
Created attachment 37209 [details]
Here you can see the additional wrong heading styles
Comment 6 parity 2006-06-17 10:13:21 UTC
As I told before, I cannot attach the whole document. But maybe somebody knows
in which .xml file, the style and formatting is saved. So maybe I can unzip the
file and attach only that .xml file. If that helps.
Comment 7 Rainer Bielefeld 2006-06-17 11:07:34 UTC
I believe a short OOo document containing some original OOo headings, some
pasted WORD headings, a table of contents and also the short WORS source
document containing only few text and the pasted headings might be helpful.

I did a quick test with headings outline numbering for a document with included
paragraphs from WORD and was not able to reproduce your problem. 
Comment 8 parity 2006-06-17 12:01:32 UTC
Created attachment 37212 [details]
Here is the damaged document containing only some example text
Comment 9 parity 2006-06-17 12:03:57 UTC
I just attached an example document containing the formatting issue. The Table
with XX's was a Word-Document opened in Writer 2.0.2 and copyied
to this document.
Comment 10 parity 2006-06-17 12:05:22 UTC
I just attached a document containing this formatting issue.

The table with XX's was in a Word-document which was then opened in Writer 2.0.2 and from there copyied to this document.

It seems to be the source of the issue since it defined some additional headings
which make the "normal" headings useless.
Comment 11 michael.ruess 2006-06-19 08:54:36 UTC
Yeah, I can see the problem in the document there. As it looks, the problems
happens when pasting text from The Word document into the Writer document. Then,
the new styles will be inserted into the Writer document and the settings in
Tools.Outline will be scratched. Please attach the mentioned Word document (or
send to if it's confidential) so that we can reproduce the
issue here.
Comment 12 michael.ruess 2006-06-20 12:58:09 UTC
I have discovered when this happens. I will attach a sample file.
Comment 13 michael.ruess 2006-06-20 13:03:21 UTC
Created attachment 37248 [details]
Document to show the outline problem when pasting
Comment 14 michael.ruess 2006-06-20 13:06:58 UTC
MRU->HBRINKM: open the attached document in MS Word, select all and copy to
clipboard. In Writer document paste the clipboard content as RTF -> the heading
will now have the style "heading x". The are also now present in the outline dialog.
We should really get rid of this nasty bug in the future.
Comment 15 openoffice 2006-07-07 09:47:28 UTC
set target to 2.x
Comment 16 parity 2007-10-06 18:41:11 UTC

will this issue be fixed in the next releases?
Comment 17 Mathias_Bauer 2007-12-03 17:05:45 UTC
according to release status meeting: target 3.x
Comment 18 Mathias_Bauer 2007-12-03 17:09:57 UTC
Comment 19 Marcus 2017-05-20 11:18:12 UTC
Reset assigne to the default "".