Issue 66743 - Undo reverses the word in RTL documents
Summary: Undo reverses the word in RTL documents
Status: CLOSED DUPLICATE of issue 61863
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
Keywords: oooqa
Depends on:
Reported: 2006-06-26 14:23 UTC by farzaneh
Modified: 2007-03-19 00:14 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description farzaneh 2006-06-26 14:23:32 UTC
Steps to reproduce:
1. In writer, write something in a right-to-left script, e.g. Persian.
2. Select part of a word
3. Delete the selected part
4. Click on "Undo" or press Ctl+Z

Expected result:
The deleted part of the word should appeare as it initially was.

Actual result:
The order of the characters are reversed, i.e. در becomes رد after the above steps.
Comment 1 michael.ruess 2006-07-14 11:53:27 UTC
Reassigned to SBA.
Comment 2 farzaneh 2006-11-22 21:28:40 UTC
ping? could anyone reproduce/confirm this?
Comment 3 alan 2006-11-23 06:50:21 UTC
On Windows, I tried on my Hebrew build of 2.0.4, as well as on the English 2.0.4
build I downloaded from this site. I also tried on Hebrew 2.0.4 on Debian Linux.
The behavior was fine in all versions. You report that the bug exists in 2.0.1.
I don't know whether something has been fixed since 2.0.1, or whether there's
something unique about your environment that I haven't reproduced. If you
download the English version of 2.0.4, and see what happens on that version in
your environment, we may have more info to work with.
Comment 4 alan 2006-11-23 07:05:39 UTC
I think I know what the problem is. If "Options/Language Settings/Complex Text
Layout/Use sequence Checking" is set, I can reproduce the problem as well. This
is set by default, so if you clear that setting, the problem may go away. I have
already submitted a request in Issue 61863 that this default be changed, since
AFAIK it's relevant only for Thai, and it causes problems for Hebrew. Now I see
that it causes problems in Persian as well.
Comment 5 farzaneh 2006-11-26 13:05:22 UTC
Thanks ayaniger, that fixes the problem.
so it seems that we could mark this issue as a duplicate of issue #61863 until
the latter is fixed.
Comment 6 cbrunet 2007-03-16 16:14:10 UTC
Marked as duplicate

*** This issue has been marked as a duplicate of 61863 ***
Comment 7 lohmaier 2007-03-19 00:14:55 UTC
closing duplicate