Issue 6690 - Read/Write problems when two users share an Excel file
Summary: Read/Write problems when two users share an Excel file
Status: CLOSED DUPLICATE of issue 4309
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: PC Windows 98
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-08-01 17:29 UTC by Unknown
Modified: 2003-09-08 16:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-08-01 17:29:31 UTC
User A opens an excel spreadsheet in either Excel or OO Calc with "read/write" rights and is
actively using it.  User B opens the same spreadsheet in OO Calc with "read only" rights.
User A cannot save changes to the file anymore. If user B closes OpenOffice, the file 
is not released and user A still cannot write to or save the file.

The only way found to restore the ability to write to the file for
user A is if user B does one of the following:
1. Logs off.
2. Reboots the PC (which essentially logs off).
3. Opens a different spreadsheet.

Another method (if the spreadsheet is on a windows server) is if an
administrator forces the session for user B to close (after User B
closes OpenOffice).

There seems to be two problems here (which may be caused by the same
thing). The first is that user B opening the file with "read only" rights
should not stop user A from writing to it. The second problem is that when user B
closes OpenOffice, all of user B's sessions created from opening that
spreadsheet should be closed.

Note: This problem also exist when the file is used in a peer-to-peer
environment (independent of any server).

Any suggestions?


Regards,
Lynn
Comment 1 oc 2002-11-28 14:50:33 UTC
Sounds like a global (not only spreadsheet) problem.
Comment 2 thorsten.martens 2003-01-14 11:29:04 UTC
This one is some kind of duplicate of #4309 and is caused by a missing
file-locking feature.

*** This issue has been marked as a duplicate of 4309 ***
Comment 3 michael.bemmer 2003-03-11 17:29:06 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 4 michael.bemmer 2003-03-11 17:57:20 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details.