Issue 67003 - Directional info in master slide not saved
Summary: Directional info in master slide not saved
Status: ACCEPTED
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0.3
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-04 13:38 UTC by alan
Modified: 2017-05-20 11:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description alan 2006-07-04 13:38:15 UTC
A user reported the following problem on 2.0.1, and I've found that it exists in
2.0.3 as well:

Setup

OpenOffice 2.0.1 on Debian Etch.

Locale - LANG=en_US, LC_CTYPE=he_IL


Instructions for reproducing the problem:

Open impress

create an empty presentation

Notice how the title and body are with RTL direction

Ask to go into master view (View/Master/Slide Master)

Change the title and bullets to LTR.

Return to regular view

Create a new slide

Type something into the title and body (something with Hebrew in it).

Save the presentation as ODP

Close the presentation

Open the presentation

See how the paragraph changed into a Hebrew paragraph again.


If I do "Format/Page" and set the direction to "Left to right", the
problem is solved. However, this does not survive a save and restore,
for some reason. It seems as if the impress simply does not save the
directionality of the master slide when saving the rest of the document.

The problem also happens if I save the file as sxi (OO 1 format), but if
I save it as ppt, it correctly remembers the right direction.
Comment 1 wolframgarten 2006-07-04 13:43:12 UTC
Reassigned.
Comment 2 christian.guenther 2006-07-26 15:52:00 UTC
I can reproduce the bug.
you don't need to change the locales.
- start an Impress
- switch the CTL options on
- change to the master slide
- click into hte text (editmode) and click on the Right-to-Left button
  -> the bullets are on the right side of the text.
- close the master view
- save the presentation
- make a reload
- the bullets are back on the left side of the text
- click into the text
  -> the Left-to-Right button is selected.
Please have a look.
Comment 3 thomas.lange 2006-08-24 08:49:14 UTC
This problem shows up only for th master slide it does not occur e.g. for a text
box with numbering in Draw. Also MT suspects that this is not a problem of the
EditEngine.
Maybe it is a presentation or xmloff export problem?

TL->CL: Please have a look. Thanks!
Comment 4 Martin Hollmichel 2007-11-09 17:18:35 UTC
set target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 5 clippka 2010-10-11 17:21:31 UTC
bumping target
Comment 6 Marcus 2017-05-20 11:08:35 UTC
Reset assigne to the default "issues@openoffice.apache.org".