Issue 67365 - Calc - page numbering
Summary: Calc - page numbering
Status: CLOSED DUPLICATE of issue 29807
Alias: None
Product: Calc
Classification: Application
Component: printing (show other issues)
Version: OOo 2.0.3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-07-14 11:05 UTC by nbjayme
Modified: 2006-07-28 13:33 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description nbjayme 2006-07-14 11:05:09 UTC
page numbering on calc is confusing.

for example if you choose sheet #3 and do a print preview page number starts
greater than 1.  This is okay and undestandable if the "print only selected
sheet" is not clicked.

But if "print only selected sheet" is enabled then it should not consider the
other sheets when calculating for the page number.
Comment 1 delorea 2006-07-14 20:52:21 UTC
On print preview do you see all pages, or only those selected?
Comment 2 nbjayme 2006-07-14 23:07:58 UTC
The print preview shows all printable ranges of the spreadsheet.  

I have been using OO for a long time.  But I must admit that I get lost with the
page numbering when dealing with more than one sheets and do a print preview.

The workaround would be to manually specify the print range.  But the process is
cumbersome, because if you defined print range from other sheets it will be
included.  You have to manually disable the print range from other sheets.  It
is common for me to encounter users with more than 15 sheets. 

I propose that when "Print Only Selected Sheet" is enabled then:
1) Print preview limits to the currently selected sheet.
2) Ignore defined print range from other sheets.
3) If no print range is defined on the current selected sheet then it defaults
to the entire current selected sheet.
4) Start page numbering from 1.
5) Make the print dialog coincide with the page numbering.

When "Print Only Selected Sheet" is disabled then the current OOCalc behaviour
will be followed.
Comment 3 delorea 2006-07-16 09:04:50 UTC
Well, but in the case you have to propose an enhancement, and not a bug fix.
Comment 4 nbjayme 2006-07-16 19:46:35 UTC
One could treat it as a defect of the "Print Only Selected Sheet" feature.
As it implies that printing is "only" on selected sheet then there should be
no need for pages coming from other sheet to appear when print previewing and
printing.
Comment 5 delorea 2006-07-16 21:13:48 UTC
Actually Print and Print Preview are not related on that.
If you plan to print only selected sheets, pages are ok, starting from 1 on
first printed page.
Think about the fact that you can change a sheet, but you want to print only
changed sheet, with the right page number, and not with page 1.
This is how I expect my spreadsheet works for me.
Comment 6 nbjayme 2006-07-16 22:19:06 UTC
The matter of contention is that the option says "Print Only Selected Sheet". 
Therefore, both print preview and printing must behave according to what the
feature says it should do.  It does not, unfortunately.

If "Print Only Selected Sheet" is unchecked then it behaves the way you mentioned.

Comment 7 nbjayme 2006-07-16 22:25:38 UTC
or shall we say then that an additional option is required to force printable
page to start at 1?  
(that can be anothe solution)... :)
Comment 8 nbjayme 2006-07-16 22:45:16 UTC
The current behaviour of OpenOffice 2  when Print Selected Sheet Only is enabled:

Test Case:
*Operating System: Ubuntu Linux Dapper
*Both Sheet #1 and Sheet #3 have simple contents
  Sheet #1  : "This is sheet 1" value
  Sheet #3  : "This is sheet 3" value
*Turn on footer page numbering using page format or when doing print preview
*User is currently in Sheet #3
*No print range is defined

On print preview it displays all printable pages from Sheet #1 and Sheet #3
Sheet #1 has page number 1
Sheet #3 has page number 2

Do a print to file test... and open the file
It prints Sheet #3 with page number 1


Observations:
   - The Print Preview does not coincide with the printing module.
   - Notice that print dialog allow you to choose to print page from 1-2
      Print page 1 will result to printing Sheet #3
      Print page 2 will result to a blank page
   - The Printing Module behave as expected but the Print Preview is defective.
   
Comment 9 delorea 2006-07-19 09:27:19 UTC
Duplicated

*** This issue has been marked as a duplicate of 29807 ***
Comment 10 frank 2006-07-28 13:33:27 UTC
...and closed