Issue 67371 - WW8: doc files exported from OOo 2.0.3 are now 68k instead of 8k with older builds
Summary: WW8: doc files exported from OOo 2.0.3 are now 68k instead of 8k with older b...
Alias: None
Product: Draw
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.0.3
Hardware: All All
: P3 Trivial with 7 votes (vote)
Target Milestone: OOo 3.0
Assignee: christian.guenther
QA Contact: issues@graphics
Keywords: oooqa, regression
: 65586 67476 67642 69789 71099 71849 81630 83252 88157 (view as issue list)
Depends on:
Reported: 2006-07-14 11:51 UTC by janacek
Modified: 2013-01-07 16:08 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Example of Word and OOo203 output (4.32 KB, application/x-compressed)
2006-09-22 22:34 UTC, ace_dent
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description janacek 2006-07-14 11:51:09 UTC 2.0.3 at least on Linux/PC creates large .doc files (when
compared with OOo 2.0.2 or 1.1.x).
Create a new empty text document and save it as .doc (MS Word 97/2000/XP). It is
96256B large when compared with 8KB from 2.0.2 or 1.1.0.
Comment 1 michael.ruess 2006-07-14 14:44:29 UTC
MRU->MBA: exported doc are now much larger than before. an empty doc is now of
68k size. Maybe another side effect of the "custom-doc-properties"
implementation by DR?
Comment 2 aziem 2006-07-18 07:18:12 UTC
*** Issue 67476 has been marked as a duplicate of this issue. ***
Comment 3 michael.ruess 2006-07-21 10:19:07 UTC
*** Issue 67642 has been marked as a duplicate of this issue. ***
Comment 4 Mathias_Bauer 2006-07-21 16:15:32 UTC
It seems so. The SummaryInformation stream is huge.
Daniel, please have a look
Comment 5 Mathias_Bauer 2006-07-21 16:21:13 UTC
I don't know what exactly goes wrong but possibly the files are broken in some
way. Perhaps we create problems for other applications loading those files? We
should investigate this. So for the moment 2.0.4 target seems appropriate to me.
Comment 6 daniel.rentz 2006-07-26 10:20:26 UTC
The reason is the export of the thumbnail property, this has been added before my 
reimplementation by SJ with issue 63158 (CWS impress89).
Comment 7 daniel.rentz 2006-07-26 10:21:01 UTC
back to QA
Comment 8 michael.ruess 2006-07-26 11:52:24 UTC
OK, it is due to the thumbnail preview which is now also saved in that format.
Comment 9 ace_dent 2006-09-22 22:32:40 UTC
I believe this might still be a bug. (See attached).
* Saved document with single character 'a', with Preview, using Word2003
01.Word2003.doc = 24,064 bytes
* Opened above and resaved (immediately- no changes) using OOo 2.0.3
02.ResavedOOo203.doc = 62,976 bytes

Both .doc files should have preview images saved, although the one produced by
OOo is ~250% larger. The Thumbnail in png format is only 467 bytes!
Furthermore, when browsing files using Explorer on WinXP, only the file created
by Word actually displays a preview thumbnail- the OOo created .doc *doesn't*
display a preview thumbnail...

Comment 10 ace_dent 2006-09-22 22:34:03 UTC
Created attachment 39319 [details]
Example of Word and OOo203 output
Comment 11 ace_dent 2006-09-22 22:36:52 UTC
*** Issue 69789 has been marked as a duplicate of this issue. ***
Comment 12 troodon 2006-09-23 20:27:49 UTC
From Issue 69789 comment 5:

"I have tried this as well.

On FC4 using OOo Milestone 8, the files I created showed the following.

103936 Sep 22 07:14 File_size_test.doc
  6916 Sep 22 07:14 File_size_test.odt

A single capital "A" was saved.

With a 10 page document of 20,071 characters.

No real formatting.
157184 Sep 22 07:23 BadBlockHowTo_test.doc
 16662 Sep 22 07:23 BadBlockHowTo_test.odt

When I looked at the *.doc files using hexedit, there were a large number of
locations just filled with FF's or 00's.  Comparing to an original *.doc file
created on Windows, there were no large FF's or 00's ranges."

I think that's the cause of the problem. Word files saved with OOo have a lot of
locations filled with null values. The same files saved with MS Word haven't all
those nulls.
Comment 13 michael.ruess 2006-09-25 10:41:08 UTC
The users are right; I think there is some space for optimizing the thumbnail
export a little bit.
Comment 14 mestech 2006-09-25 16:25:52 UTC
Adding myself to the CC list.  I see Troodon cp/pasted my comments from 69789. 
Thank you.
Comment 15 billp 2006-10-07 23:10:09 UTC
This problem would cost me several megabytes of wasted disk space every week if
I continued to use OOo 2.0.3. Since the Target Milestone has been set to "OOo
later" it could conceivably be years before being fixed.

In the meantime, is there any way to disable saving with the preview thumbnail
or do I have to go back to OOo 2.0.2? I don't need the preview thumbnail for a
text document but I do need the wasted disk space. The preview thumbnails aren't
displayed anyway in either system that I use (OOo 2.0.3 on Windows XP and
Windows ME).
Comment 16 saxa 2006-10-15 19:51:13 UTC
In ooo 2.0.4 built with ooo-build on linux still persists this problem.
Any way to solve this big file ? An empty file saved in .doc results in about
103kb on my system.

Comment 17 michael.ruess 2006-11-02 08:59:21 UTC
*** Issue 71099 has been marked as a duplicate of this issue. ***
Comment 18 zhongqiyao 2006-11-24 09:58:37 UTC
For 67361 (Word,
clicking into "Target milestone" above does not tell us when is
"OOo Later" and there is a misspelling in the page "isseus".

Since compatibility with Microsoft and its import/export
features are an attraction of OpenOffice, we expect this
problem to be fixed soon.
Similar to the complainer of 67361 (Word), and of 71849 (Excel), and
71915 (PowerPoint), I will be forced to go back to OpenOffice
2.0.1 (the previous official release in Chinese-Traditional-chars)
if it will not be fixed "soon".


Comment 19 daniel.rentz 2006-12-11 10:02:46 UTC
*** Issue 65586 has been marked as a duplicate of this issue. ***
Comment 20 daniel.rentz 2006-12-11 12:23:26 UTC
*** Issue 71849 has been marked as a duplicate of this issue. ***
Comment 21 zhongqiyao 2006-12-14 08:17:24 UTC
Sorry, what I said of 67361 (Word) should be 67371 (Word).
Comment 22 zhongqiyao 2007-01-10 00:29:08 UTC
According to the above conversation, this bug is because of this feature:

OK, it is due to the thumbnail preview which is now also saved in that format.

However, Microsoft Office does not have this problem (super-big file).
And this bug causes memory waste (diskspace) and is still marked as
"OOo later".

This bug already have many duplicates independently found by
many netters.

So could you tell what is the plan for fixing this bug in a "soon"
version of OpenOffice? Thanks.

Comment 23 sven.jacobi 2007-01-10 10:14:55 UTC
I hope I'll have enough time to fix this issue for OOo 2.3. 

Be it as it may if someone can supply a patch this problem it will ensure that
this issue is solved even faster.
Comment 24 daniel.rentz 2007-01-10 14:43:54 UTC
*** Issue 71849 has been marked as a duplicate of this issue. ***
Comment 25 Mathias_Bauer 2007-03-20 18:02:50 UTC
This issue is not restricted to Word files but a general MS Export problem. As
it is due to a problem in image generation I change the component to "drawing".
Comment 26 sacmat2 2007-03-28 05:06:08 UTC
just adding myself as a watcher. I too will be forced back to 2.02 until this is
Comment 27 saxa 2007-03-31 11:28:39 UTC
Can somebody tell where to start look at ?

Comment 28 sven.jacobi 2007-07-25 13:37:14 UTC
I do not have enough time to fix this issue for OOo2.3, so I change the target
to OOo2.4.

@saxa, the code that is creating the preview can be found in
sfx2/source/doc/objcont.cxx GDIMetaFile* SfxObjectShell::GetPreviewMetaFile(
sal_Bool bFullContent ) const

Comment 29 Mathias_Bauer 2007-08-25 21:10:50 UTC
Sven, please make sure that your plans enable us to integrate the fix for 2.4.
Comment 30 michael.ruess 2007-09-17 08:03:36 UTC
*** Issue 81630 has been marked as a duplicate of this issue. ***
Comment 31 foxy123 2007-09-23 17:16:57 UTC
Same here. I am trying to make a file less than 100K and no avail :(
Comment 32 saxa 2007-10-29 07:22:19 UTC
@sj thx for the tip. I will try to look into it.

Comment 33 michael.ruess 2007-11-02 15:57:13 UTC
*** Issue 83252 has been marked as a duplicate of this issue. ***
Comment 34 sven.jacobi 2008-01-21 15:30:53 UTC
I am sorry, I have to retarget this issue to OOo2.4
Comment 35 michael.ruess 2008-04-11 07:56:06 UTC
*** Issue 88157 has been marked as a duplicate of this issue. ***
Comment 36 sven.jacobi 2008-04-15 16:11:22 UTC
This issue has been fixed now in cws[impress141]. Calc & Writer will no longer
create preview bitmaps when saving to ms, when saving impress to ppt everything
stays unchanged. This is the same behavior as it is done in Office 2007.

However, if anybody is unhappy with this change, creating previews can still be
enabled/disabled via configuration. In "Office.Common/Filter/Microsoft/Export"
following three attributes determine if preview creation is enabled:
"EnablePowerPointPreview", "EnableCalcPreview" and "EnableWordPreview".

There is no UI planned to enable/disable these settings.
Comment 37 sven.jacobi 2008-05-13 14:59:49 UTC
sj->wg: This issue is ready to be verified in cws[impress141]
Comment 38 wolframgarten 2008-05-14 09:52:52 UTC
Reassigned. Please verifiy.
Comment 39 christian.guenther 2008-05-15 16:22:17 UTC
CGU: Verified in cws impress141
Comment 40 christian.guenther 2008-07-03 11:21:58 UTC
CGU: Integrated in dev300m22
Comment 41 tobydjones 2013-01-07 16:08:02 UTC
Could you tell me where to find "Office.Common/Filter/Microsoft/Export" please?