Issue 67405 - Changed-Flag will be set by automatically calculated change
Summary: Changed-Flag will be set by automatically calculated change
Status: CONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0.3
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-07-15 17:46 UTC by cphilipp
Modified: 2017-05-20 11:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
example spreadsheet (15.80 KB, application/vnd.sun.xml.calc)
2006-07-15 17:48 UTC, cphilipp
no flags Details
another document showing the same effect (19.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2006-07-16 17:36 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cphilipp 2006-07-15 17:46:33 UTC
I have a spreadsheet containing cells calculated via formulas from other cells
and the result values of calculation are depicted in a chart diagram. When I
open this document, it is set to changed. So when I close it again without any
further changes, I will be asked whether to save my changes or discard them.

This does not happen, if the cells displayed in the chart contain values,
instead of formulas. It also does not happen, when the calculated values are not
put to a chart.

I did not make any experiments, whether the behaviour depends on the formulas
used, the formula is
=ZÄHLENWENN(INDIREKT(bereichRef);F$23)
(should be =COUNTWHEN(INDIRECT(bereichRef);F$23) in English version?),
where bereichRef contains a cell range ($C$10:$C$15).

I would expect a document to be unchanged after opening it. This is the desired
behaviour.

See attachment for example.
Comment 1 cphilipp 2006-07-15 17:48:35 UTC
Created attachment 37786 [details]
example spreadsheet
Comment 2 Rainer Bielefeld 2006-07-16 17:34:04 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" and can
confirm the reported effect. 

All the same with "1.1.4 (German) WIN XP: [645m52 (Build 8824)]".

There isn't any entry in the UNDO-list and also the "Save-Button" is not active,
but when I want to save the document without any change, I will be asked whether
I want to save the document when I want to close it. This will only happen as
long as the formula in 'F24:F26' are active AND the spreadsheet contains a
diagram AND property "calulate cell contents automatically" is set. 

I see the same effect in a self created spreadsheet containing a 'now()' statement.
Comment 3 Rainer Bielefeld 2006-07-16 17:36:01 UTC
Created attachment 37795 [details]
another document showing the same effect
Comment 4 frank 2006-07-17 09:31:48 UTC
Hi Rainer,

a NOW() function returns the current Date and time and therefore the changed
flag must be set on loading as the result of the cell changes.

Frank
Comment 5 frank 2006-07-17 10:04:39 UTC
Hi Niklas,

please have a look at this one. Maybe related to Issue 65582 ?

Frank
Comment 6 frank 2006-07-17 10:07:55 UTC
.
Comment 7 Rainer Bielefeld 2006-07-17 12:24:43 UTC
@Frank:
I knowingly checked with "now()", because it seemed to me a similar "enforced
cell calulation" as with "=ZÄHLENWENN(INDIREKT(bereichRef);F$23)"
The changed flag only will be set if the spreadsheet contains a chart (I did not
check what data must be shown in diagram to effect the reported behaviour).

The request to save will not occur if I open and close a similar spreadsheet
containing only "now()" without any chart.
Comment 8 cphilipp 2006-07-21 19:40:31 UTC
Hi,
a short remark on the "Save-Button" is not active topic from rainerbielefeld Sun
Jul 16 09:34:04 -0700 2006:

I observed the same, but when clicking to some cell, the "Save-Button" will
become active.
Comment 9 Martin Hollmichel 2007-11-09 16:52:01 UTC
change target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 10 Marcus 2017-05-20 11:11:25 UTC
Reset assigne to the default "issues@openoffice.apache.org".