Issue 67688 - Writer OLE objects in Draw do not react on snaplines in edit mode
Summary: Writer OLE objects in Draw do not react on snaplines in edit mode
Status: CONFIRMED
Alias: None
Product: Draw
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0.2
Hardware: PC All
: P4 Trivial (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-22 23:40 UTC by lineinthesand
Modified: 2017-05-20 11:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lineinthesand 2006-07-22 23:40:34 UTC
I'm trying to create a poster with different boxes containing text and images. I
want the text to float around the images. This works absolutely great in Writer.
So I took Writer, formatted the page to the width of the boxes mentioned above
and an arbitrary page height. I inserted the text and the picture and arranged
it to look nicely.

So far, so good, now here comes the problem. When I save the text document as
odt and insert it as an OLE object into Draw, what I get is kind of a copy of my
screen layout and the last view (snippet) of the Writer document before I saved
it. This means, if I scroll down, save to odt, import into Draw, the upper part
of my text doc is cut, whereas before the lower part was missing!
In addition, the frame layout of the imported object is quite odd, as it is
wider than the content but it fits the content in height, so I suppose it might
be a cutout of the viewing window I have in Writer! 

Unfortunately, I don't know if this has to be fixed in Writer or in Draw.

As for the first part of the problem (cutting the content): I can see the whole
document in the Draw-embedded object if I just zoom out in Writer so I can see
the whole page, then save it and re-insert the file.
Still, I would like the >>>bounding frame to resemble the page layout of my
writer document by default<<< rather than my screen layout! I can't imagine that
this is much work to fix, but it would be really helpful if it worked like
anyone using this kind OLE functionality probably would expect.

I used the Windows version 2.0.2 but I guess the problem will be the same in
linux. I'll try that as soon as possible.
Comment 1 wolframgarten 2006-07-24 09:41:11 UTC
Did you try to resize the window of the OLE?
If you doubleclick the OLE you get into the dit mode (black handles). If you
resize the OLE window then you can alter the size of the displayed areal.
Resizing in select mode (green handles) will resize the Window AND it contents.
If this should not fit your needs I think I did not understand completely the
problem.
Thanks in advance. 
Comment 2 lineinthesand 2006-07-24 09:57:16 UTC
I am sorry to bother you, I did not know that the bounding box could be resized
that way. I tried to use the crop tool, which, of course, was not applicable. 

Still, I think there should be some way to enter values for the size of the
bounding box and/or some means to default it to the page size in order to make
positioning easier. Unfortunately, if I resize the bounding box like you
suggested, no snap lines or snapping to objects in the drawing seem to work,
which makes exact sizing difficult.

Linux version, by the way, behaves same as Windows version, but that's obvious
anyway.
Comment 3 wolframgarten 2006-07-24 10:43:41 UTC
Since the expectations fro the size of the bounding box are very different it
would be difficult to find an acceptable solution.
The snap lines are working witht the OLE window ,too, but first you have to
activate that function: Tools/ options/ Draw/ Grid/ Snap. Or use the option bar.
A little bug in this area has been filed: i67718.
Thanks for your help.
Comment 4 wolframgarten 2006-07-24 10:44:29 UTC
Closed.
Comment 5 wolframgarten 2006-07-24 13:35:39 UTC
Reopened.
Comment 6 wolframgarten 2006-07-24 13:38:02 UTC
Ok, I had a look again and you are right, in edit mode it is not possible to use
the snap lines. As a work around you can resize the OLE in edit mode and
position it in the select mode, this works.
Comment 7 Marcus 2017-05-20 11:29:55 UTC
Reset assigne to the default "issues@openoffice.apache.org".