Issue 67701 - macros disappearing
Summary: macros disappearing
Alias: None
Product: Internationalization
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.3
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2006-07-23 17:40 UTC by qlex
Modified: 2017-05-20 11:13 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description qlex 2006-07-23 17:40:00 UTC 2.0.3 pl
i create 3 macros that change the language of the text to polish,english or
german. (format/character/language)
put those macros into the menu as items.
macros are saved in My Macros/Standard/Module1

also, there was in fresh install an unknown macro called Main1 there.

upon next start of Ooo all the macros disappeared and links in menu became obsolete.

is this a bug ?
tried to delete that Main1 macro and record my 3 macros again..didn't help

this doesn't happen with 2.0.3 en
Comment 1 mellonedain 2006-07-29 14:06:22 UTC
Reasing to Polish Project
Comment 2 philipp.lohmann 2006-07-31 09:43:20 UTC
I'm not the polish project. In fact, i am not a project at all. Furthermore this
does not seem language specific to me.

pl->ab: since this seems to be a basic problem, would this fall within your domain ?
Comment 3 ab 2006-07-31 10:23:03 UTC
ab->qlex: Sorry, but I don't really understand, what you've exactly done to get 
this problem. Could you provide an exact step-by-step description, please.
Comment 4 srhoades 2006-08-08 18:50:53 UTC
I see the same thing on a new Windows installation of 2.0.3. I don't see it on
another Windows box, where I upgraded to 2.0.3. I also don't see it on Linux,
but I can't swear it doesn't exist in Standard 2.0.3 because the new Linux
install has the Novell version. (The Windows version where I see the problem is
the standard 2.0.3 version, not the Novell version or any other customized
version.) The other difference between the two windows boxes is that the one
that works is Win2k and the one that doesn't is XP.

It looks like the macro is not saved to disk. If I restart OOo, I can still use
the macro. If I reboot the machine, it's gone.

I also noticed that on the newly installed 2.0.3, if I look at the Paths in
Options, there are only five available paths, and BASIC isn't one of them. On
the upgraded machine, there are 15 available paths, including BASIC.
Comment 5 srhoades 2006-08-09 14:57:49 UTC
I tried recording and saving a macro on another newly installed (not upgraded)
2.0.3 on another XP machine and had the same problem. 

I think the priority should be raised to P2 because an "essential feature,"
recorded macros, do not work on a newly installed instance of 2.0.3 on XP. 
Comment 6 ab 2006-08-14 11:52:30 UTC
I couldn't reproduce the problem. I assume there must be some interaction with 
earlier installations. You can test this by changing the UserInstallation path 
in program/bootstrap.ini, e.g. to Try to UserInstallation=$ORIGIN/../UserInst.
The user installation folder then will be created within the installation fol-
der. When you start the Office afterwards it will behave like if you start it 
the first time after installation. If the problem is gone then it surely was
a problem with older installations that haven't been deinstalled completely.
As long as this is no general problem that is reproducable for any installa-
tion, this is no P2 for me.
Comment 7 srhoades 2006-08-14 14:12:13 UTC
The problem occurs on two brand-new computers that did not have any version of
OpenOffice on them before 2.0.3. It does not occur on two other XP computers
that were upgraded to 2.0.3. So, I agree that there's interaction with previous
installs. If there was a previous install, there doesn't seem to be a problem.
Previous installations not being deinstalled completely seems to be a good thing
in this case.
Comment 8 srhoades 2006-08-15 22:38:52 UTC
I can reproduce at will. All I have to do is install 2.0.3 on XP. 

I've tested it on a Gateway desktop (new install), HP laptop (new install), Dell
desktop (new install), Dell desktop (upgrade from 2.0.2), and Dell laptop
(upgrade from 2.0.2).

In all cases, I see the following behaviors after creating a macro (start macro
recorder, type some characters, center them, stop recording, save the macro):

* As long as I keep OOo running, macro appears in macro organizer.

* If I shut down OOo (including quickstarter), then restart OOo, the macro
appears in macro organizer.

* If I hibernate a laptop with OOo running, then restore the session, the macro
appears in macro organizer.

* If I reboot the machine, then restart OOo, the macro no longer appears in the

Comment 9 grsingleton 2006-08-17 15:54:09 UTC
Added to cc list
Comment 10 billcase 2006-08-18 01:26:29 UTC
I wanted to create macros for an individual spreadsheet project.  I made
sure that I created a distinct library for that project and double
checked that all modules and macros were stored in that library.  I
certainly saved before exiting.  My macros disappeard on closing and reopening.

I have spent this evening creating test recorded macros.  I have the
following anomalies.  Test macros saved to My Macros -> TestLibarary
continue to appear and function after logging out and re-logging in.
However, the Test macros recorded and saved to 'myproject' continue to
disappear.  I double checked that I had, in fact, saved to 'myproject'
library.  All record of project macros, modules and libraries are gone,
nowhere on my machine, de nada, rein, nothing.

The actual library I created keeps disappearing on closing.  It was actually
called MemberLib. And, was created using the BASIC Macro Organizer under the
project file named MemberTest2.xls (i.e. Location).  Modules and Macros were
subsequently added.  Recorded macros for the MemberTest2 project were saved to
the MemberLib library.

I assigned one of the macros for example to a toolbar button.  It ran
successfully until I closed and opened my Calc file.  The button now returns the
following error dialogue "A Scripting Framework error occured while running the
Basic script
Message: BasicProviderImpl:getScript: no script!"

I am using Linux 2.6, Fedora Core 5, Gnome 2.14.3, OOo 2.0.2.
I am saving the file as an *.xls file.
Comment 11 billcase 2006-08-18 02:06:21 UTC
Just tried the same test macros in the same file converted to *.ods.  As *.ods
the macros saved appropiately and were present and usable after closing and
Comment 12 ab 2006-08-25 07:42:02 UTC
But I could not reproduce the problem so far
Comment 13 ab 2006-10-11 14:50:54 UTC
Still not reproducable -> OOo 2.x for now
Comment 14 T. J. Frazier 2007-10-27 10:49:40 UTC
Added CC.
Comment 15 ab 2008-01-25 15:22:18 UTC
-> 3.x
Comment 16 ab 2009-01-29 14:35:36 UTC
This issue refers to a very old Office version.
Can anyone still reproduce this problem?
Otherwise I will close this issue.
Comment 17 T. J. Frazier 2009-01-29 22:38:33 UTC
(WV, 3.0.0) Not seeing any whole libraries disappearing, but there is a P2,
data-loss, "changes disappearing" bug lurking out there, and I just got a solid
clue on it today. I think it involves changing context in the IDE, between
document and applications libraries. Still must run thru the permutations of
save/no-save, switch, change? save/no-save? switch back? close when?

If you want to use this issue for that, I will hurry up my efforts. Otherwise,
I'll file another issue, assuming I succeed in reproducing it reliably. /tj/
Comment 18 danigm 2009-02-17 09:58:23 UTC
In openoffice3.0.1 in ubuntu intrepid installed from deb downloaded from
webpage, I open a xls document with macros and save it as ods. All macros are
saved ok but the one that have the name with some "strange" caracter ("MóduloX")
is not copied.

If you try to rename or fill that macro in the ods, when you reopen the
document, the macro is disappeared.

If you rename the macro before save as ods it works.
Comment 19 Marcus 2017-05-20 11:13:30 UTC
Reset assigne to the default "".