Issue 67729 - keep selected (border, font-color, background-color, etc)
Summary: keep selected (border, font-color, background-color, etc)
Status: CLOSED DUPLICATE of issue 10864
Alias: None
Product: Calc
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0.3
Hardware: All All
: P4 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-24 19:00 UTC by phervas
Modified: 2010-11-10 17:14 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description phervas 2006-07-24 19:00:18 UTC
It would be great if the program would keep the selected border, font-color,
background-color, line-style and line-color when one selects one of them from
the dialog boxes, so you can click it again on some cell and apply the same
formatting. The dialog should appear when one clicks on the downward arrow next
to the color/border/etc.
Right now, if you select a background-color and apply it to a cell for example,
then click on another cell and try to apply the same color, you must search for
the color in the background-color dialog.
Comment 1 jolatt 2006-07-24 19:29:46 UTC
Create and use a template for this with the advantage, that you can change these
settings for all the cells in the whole document on which this template is applied.

Another option: Use the BRUSH-function, which was integrated to my regret. It's
another form of the so called 'hard formatting'. 

Comment 2 phervas 2006-07-26 15:29:31 UTC
Templates and the brush are cool, but the boxes for formatting should behave
logically. If I click on the selected color, it should apply it to the cell. If
I click on the downward arrow, then, it should display the dialog with the
colors, borders, etc. I dont see then why the downward arrow exists.

Writer has the correct functionality in "font-color" and "font-background"
boxes. When you click on the color, it applies it, if you click on the arrow
then it displays the colors.

Formatting might sound trivial, but it is a very important issue when you want a
Spreadsheet to look finished and professional. With the actual functionality of
the components i mentioned, it takes longer to apply formatting to cells for no
reason.
Comment 3 kpalagin 2006-08-06 20:04:28 UTC
phervas,
your RFE makes sense. I think you even should increase it's priority to P3.
For greater clarity could you please illustrate your RFE with screenshot?

jolatt,
templates and styles are great and all, but in many cases one just needs 
quick, one-off solution whiledefining template would take much more effort.
Comment 4 frank 2006-08-07 08:18:46 UTC
double to Issue 10864

*** This issue has been marked as a duplicate of 10864 ***
Comment 5 frank 2006-08-07 08:19:03 UTC
closed double
Comment 6 enapannes 2010-11-10 17:14:12 UTC
Created attachment 73420