Issue 67782 - Bullets don't pass across platforms
Summary: Bullets don't pass across platforms
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0.2
Hardware: All Windows, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-26 10:30 UTC by tuharsky
Modified: 2007-10-03 08:16 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
test case (11.50 KB, application/vnd.sun.xml.writer)
2006-08-14 07:53 UTC, tuharsky
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tuharsky 2006-07-26 10:30:56 UTC
Create bullets StarSymbol 9 in document under Linux and save as SXW.
Now open it in OpenOffice.org/Windows and You get an empty rectangle, as if the
symbol was not found.
Comment 1 michael.ruess 2006-07-26 15:25:17 UTC
I cannot reproduce the problem. Could you please attach such an .sxw to this
issue? Thanks a lot!
Comment 2 tuharsky 2006-07-26 15:36:40 UTC
I'll try, however it'll be possible only next week when I get from holidays.
Thank for Your interest.
Comment 3 michael.ruess 2006-08-08 11:48:58 UTC
Reminder ;-)
Please attach a sample document. Thanks a lot!
Comment 4 tuharsky 2006-08-14 07:53:14 UTC
Created attachment 38486 [details]
test case
Comment 5 tuharsky 2006-08-14 07:53:40 UTC
I'm sorry for the delay..
Comment 6 michael.ruess 2006-08-14 13:37:13 UTC
Ah, I see. It is because some of the default bullet symbols of StarSymbol are
not available in OpenSymbol. This is handled by issue 59997.

*** This issue has been marked as a duplicate of 59997 ***
Comment 7 michael.ruess 2006-08-14 13:38:19 UTC
Closed.
Comment 8 tuharsky 2007-02-21 14:24:08 UTC
The issue 59997 has been marked as closed. However, with OOo2.1 sk m6 Biuld-1
(considered stable) from 061202, the major bullets are still invalid in the
testcase (rectangle shape displays instead of the sharp cursor bullet). 

mru: what are Your results on this testcase? Are ALL bullets alright?
Comment 9 michael.ruess 2007-02-22 13:42:51 UTC
The fix was made in the Opensymbol font. Did you delete the old one from your
system before installing OO 2.1?
Delete it and try this from issue 59997:
http://www.openoffice.org/nonav/issues/showattachment.cgi/35683/opens___.ttf
Comment 10 tuharsky 2007-02-22 14:27:17 UTC
I didn't delete the font, nor installed the new.
However I tested on completely new installed system. WXP Pro, OOo2.1 with no
previous OOo installation. The bullets are still wrong there. I assume, that the
font comes with OOo and thus the fresh new installation should work, shouldn't?
Comment 11 michael.ruess 2007-02-22 14:40:41 UTC
Yeah, that should work of course... The corrected font is part of OO 2.1 inst_set.
I do not understand this... the document looks good on my system. I will have a
closer look at the doc now.
Comment 12 michael.ruess 2007-02-22 14:44:43 UTC
The bullets in this document are not of OpenSymbol... Wingdings is used there;
the document originates from MS Word. do you have WingDings installed on your
system?
Comment 13 tuharsky 2007-02-23 07:16:59 UTC
Aha. I don't know. How could I test that?

I have installed msttcorefonts in Debian Etch and ls in
/usr/share/fonts/truetype/msttcorefonts gives this:

Andale_Mono.ttf andalemo.ttf arialbd.ttf arialbi.ttf Arial_Black.ttf
Arial_Bold_Italic.ttf Arial_Bold.ttf Arial_Italic.ttf ariali.ttf Arial.ttf
arial.ttf ariblk.ttf comicbd.ttf Comic_Sans_MS_Bold.ttf Comic_Sans_MS.ttf
comic.ttf courbd.ttf courbi.ttf Courier_New_Bold_Italic.ttf Courier_New_Bold.ttf
Courier_New_Italic.ttf Courier_New.ttf couri.ttf cour.ttf
Georgia_Bold_Italic.ttf Georgia_Bold.ttf georgiab.ttf Georgia_Italic.ttf
georgiai.ttf Georgia.ttf georgia.ttf georgiaz.ttf Impact.ttf impact.ttf
timesbd.ttf timesbi.ttf timesi.ttf Times_New_Roman_Bold_Italic.ttf
Times_New_Roman_Bold.ttf Times_New_Roman_Italic.ttf Times_New_Roman.ttf
times.ttf trebucbd.ttf trebucbi.ttf trebucit.ttf trebuc.ttf
Trebuchet_MS_Bold_Italic.ttf Trebuchet_MS_Bold.ttf Trebuchet_MS_Italic.ttf
Trebuchet_MS.ttf Verdana_Bold_Italic.ttf Verdana_Bold.ttf verdanab.ttf
Verdana_Italic.ttf verdanai.ttf Verdana.ttf verdana.ttf verdanaz.ttf
Webdings.ttf webdings.ttf
Comment 14 michael.ruess 2007-02-23 08:52:25 UTC
When I interpreted the description a the top, you opened the docment on Windows,
an there, the symbols were wrong... so please check, if the font is installed on
the target-Windows system. Thanks!
BTW: the symbols may look ok on your Linux, because there may be a font which
replaces the non-existing "Wingdings" better than a different font on Windows.
Comment 15 tuharsky 2007-02-23 09:43:22 UTC
Okay, I'll check that.
Comment 16 michael.ruess 2007-04-04 13:04:23 UTC
The bullet symbols look exactly the same on my Windows and Linux systems. 
Font "WingDinggs" should better be installed on the Windows system.
Comment 17 michael.ruess 2007-04-04 13:09:42 UTC
Closed.
Comment 18 tuharsky 2007-10-03 08:16:43 UTC
I have tested with OOo 2.2 on Linux -created all bullets available.
Opening on fresh installation WXP+OOo2.3, no problem at all.